]> git.pld-linux.org Git - packages/ekg.git/blobdiff - ekg.spec
- kopete requires ekg WITH PTHREAD, turn on by default
[packages/ekg.git] / ekg.spec
index cc7201a776899fb024c3edcd1fed2cfcd1f228ee..6056e4de9f12e1a7512ae2a7c3d49d9f9855ca27 100644 (file)
--- a/ekg.spec
+++ b/ekg.spec
@@ -1,37 +1,61 @@
-%bcond_without voip
-%bcond_with    python
-%bcond_with    ioctl_daemon
-
+#
+# Conditional build:
+%bcond_without aspell          # without spell checking
+%bcond_without voip            # without VoIP support
+%bcond_without python          # with python support
+%bcond_without pthread         # build with Posix threads support
+%bcond_with    ioctl_daemon    # with ioctl_daemon (suid root)
+#
+%define                _pre    rc1
+#
 Summary:       A client compatible with Gadu-Gadu
 Summary(de):   Ein Cliente kompatibel mit Gadu-Gadu
 Summary(es):   Un cliente compatible con Gadu-Gadu
 Summary(it):   Un cliente compatibile con Gadu-Gadu
 Summary(pl):   Klient kompatybilny z Gadu-Gadu
 Name:          ekg
-Version:       1.4
-Release:       3
+Version:       1.6
+Release:       0.%{_pre}.1
 Epoch:         4
 License:       GPL v2
 Group:         Applications/Communications
-Source0:       http://dev.null.pl/ekg/%{name}-%{version}.tar.gz
-# Source0-md5: 8f35030c05e62c30ce9068e26bd365a2
+Source0:       http://dev.null.pl/ekg/%{name}-1.6%{_pre}.tar.gz
+# Source0-md5: bce21bd6e896b71266afc30004f27402
 Source1:       %{name}.conf
-Patch0:                %{name}-kadu-0_3_6.patch
 URL:           http://dev.null.pl/ekg/
+%{?with_aspell:BuildRequires:  aspell-devel}
 BuildRequires: autoconf
 BuildRequires: automake
 %{?with_voip:BuildRequires:    libgsm-devel}
 BuildRequires: libjpeg-devel
 BuildRequires: ncurses-devel
-BuildRequires: openssl-devel >= 0.9.7c
+BuildRequires: openssl-devel >= 0.9.7d
 BuildRequires: %{_bindir}/perl
-%{?with_python:BuildRequires:  python-devel}
+%if %{with python}
+BuildRequires: python
+BuildRequires: python-devel
+%endif
 BuildRequires: readline-devel
 BuildRequires: zlib-devel
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
-A client compatible with Gadu-Gadu.
+EKG ("Eksperymentalny Klient Gadu-Gadu") is an open source gadu-gadu
+client for UNIX systems. Gadu-Gadu is an instant messaging program,
+very popular in Poland.
+
+EKG features include:
+  - irssi-like ncurses interface
+  - sending and receiving files
+  - voice conversations
+  - launching shell commands on certain events
+  - reading input from pipe
+  - python scripting support
+  - speech synthesis (using an external program)
+  - encryption support
+
+Please note that the program is not internationalized and all messages
+are in Polish (although the commands are in English). 
 
 %description -l de
 Ein Cliente kompatibel mit Gadu-Gadu.
@@ -43,15 +67,30 @@ Un cliente compatible con Gadu-Gadu.
 Un cliente compatibile con Gadu-Gadu.
 
 %description -l pl
-Klient kompatybilny z Gadu-Gadu.
+EKG ("Eksperymentalny Klient Gadu-Gadu") jest open source'owym
+klientem gadu-gadu dla systemów uniksowych. Gadu-Gadu to popularny w
+polsce komunikator internetowy.
+
+Mo¿liwo¶ci EKG:
+  - interfejs u¿ytkownika podobny do irssi,
+  - wysy³anie i odbieranie plików,
+  - rozmowy g³osowe,
+  - uruchamianie poleceñ pow³oki w okre¶lonych sytuacjach,
+  - wczytywanie wej¶cia z potoku,
+  - wsparcie dla skryptów w jêzyku Python,
+  - synteza mowy (z u¿yciem zewnêtrznego programu),
+  - wsparcie dla szyfrowania.
+
+Program nie jest umiêdzynarodowiony i wszystkie komunikaty s± po
+polsku (jednak komendy s± w jêzyku angielskim).
 
 %package -n libgadu
 Summary:       libgadu library
 Summary(es):   Biblioteca libgadu
 Summary(pl):   Biblioteka libgadu
+License:       LGPL v2.1
 Group:         Libraries
 Obsoletes:     libgg
-License:       LGPL v2.1
 
 %description -n libgadu
 libgadu is intended to make it easy to add Gadu-Gadu communication
@@ -73,10 +112,11 @@ bazuj
 Summary:       libgadu development library
 Summary(es):   Biblioteca de desarrollo de libgadu
 Summary(pl):   Czê¶æ biblioteki libgadu dla programistów
+License:       LGPL v2.1
 Group:         Development/Libraries
-Requires:      libgadu = %{epoch}:%{version}
+Requires:      libgadu = %{epoch}:%{version}-%{release}
+Requires:      openssl-devel
 Obsoletes:     libgg-devel
-License:       LGPL
 
 %description -n libgadu-devel
 The libgadu-devel package contains the header files and some
@@ -100,10 +140,10 @@ potrzebne do kompilowania aplikacji korzystaj
 Summary:       Static libgadu library
 Summary(es):   Biblioteca libgadu estática
 Summary(pl):   Statyczna biblioteka libgadu
+License:       LGPL v2.1
 Group:         Development/Libraries
-Requires:      libgadu-devel = %{epoch}:%{version}
+Requires:      libgadu-devel = %{epoch}:%{version}-%{release}
 Obsoletes:     libgg-static
-License:       LGPL
 
 %description -n libgadu-static
 Static libgadu library.
@@ -118,28 +158,32 @@ Biblioteca libgadu est
 Statyczna biblioteka libgadu.
 
 %prep
-%setup -q
-%patch0 -p1
+%setup -q -n %{name}-%{version}%{_pre}
 
 %build
 rm -f missing
-%{__aclocal}
+%{__aclocal} -I m4
 %{__autoheader}
 %{__autoconf}
 %configure \
        --enable-shared \
        --enable-static \
+%if %{with pthread}
        --with-pthread \
+%else
+       --without-pthread \
+%endif
        --without-bind \
        %{?with_python:--with-python} \
-       %{?!with_voip:--without-libgsm} \
-       %{?!with_ioctl_daemon:--disable-ioctld}
-%{__make} CC="%{__cc} %{rpmcflags} -Wall -I/usr/include/ncurses"
+       %{!?with_voip:--without-libgsm} \
+       %{?with_aspell:--enable-aspell} \
+       %{?with_ioctl_daemon:--enable-ioctld}
+
+%{__make} \
+       CC="%{__cc} %{rpmcflags} -Wall -I%{_includedir}/ncurses"
 
 %if %{with ioctl_daemon}
-cd src
-%{__make} ioctld
-cd ..
+%{__make} -C src ioctld
 %endif
 
 %install
@@ -149,15 +193,15 @@ install -d $RPM_BUILD_ROOT%{_sysconfdir}
 %{__make} install install-ekl2 \
        DESTDIR=$RPM_BUILD_ROOT
 
-install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/
+install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}
 
 # For libgadu-devel
 
-rm examples/Makefile examples/Makefile.in examples/.cvsignore
-rm -r examples/CVS
+rm -f examples/Makefile examples/Makefile.in examples/.cvsignore
+rm -rf examples/CVS
 
 install -d $RPM_BUILD_ROOT%{_examplesdir}/libgadu-%{version}
-mv examples/* $RPM_BUILD_ROOT%{_examplesdir}/libgadu-%{version}/
+cp -af examples/* $RPM_BUILD_ROOT%{_examplesdir}/libgadu-%{version}
 
 %if %{with ioctl_daemon}
 install src/ioctld $RPM_BUILD_ROOT%{_bindir}
@@ -175,6 +219,7 @@ rm -rf $RPM_BUILD_ROOT
 %files
 %defattr(644,root,root,755)
 %doc docs/{7thguard,dcc,files,gdb,python,sim,themes,ui-ncurses,vars,voip}.txt
+%{?with_aspell:%doc docs/slownik.txt}
 %doc ChangeLog docs/{FAQ,README,TODO,ULOTKA} docs/emoticons.{ansi,sample}
 %attr(755,root,root) %{_bindir}/e*
 %{?with_ioctl_daemon:%attr(4755,root,root) %{_bindir}/ioctld}
@@ -191,13 +236,12 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %doc docs/{7thguard,ui,devel-hints,przenosny-kod}.txt docs/protocol.html
 %doc ChangeLog docs/{README,TODO}
-%{_libdir}/libgadu.so
+%attr(755,root,root) %{_libdir}/libgadu.so
 %{_includedir}/libgadu.h
 %{_includedir}/libgadu-config.h
 %{_pkgconfigdir}/*
-%dir %{_examplesdir}/libgadu-%{version}
-%{_examplesdir}/libgadu-%{version}/*
+%{_examplesdir}/libgadu-%{version}
 
 %files -n libgadu-static
 %defattr(644,root,root,755)
-%attr(644,root,root) %{_libdir}/libgadu.a
+%{_libdir}/libgadu.a
This page took 0.092405 seconds and 4 git commands to generate.