]> git.pld-linux.org Git - packages/ekg.git/blobdiff - ekg.spec
- kopete requires ekg WITH PTHREAD, turn on by default
[packages/ekg.git] / ekg.spec
index 718ce4808a4c2fda804a127efb36f386f2018a51..6056e4de9f12e1a7512ae2a7c3d49d9f9855ca27 100644 (file)
--- a/ekg.spec
+++ b/ekg.spec
@@ -2,25 +2,26 @@
 # Conditional build:
 %bcond_without aspell          # without spell checking
 %bcond_without voip            # without VoIP support
-%bcond_with    python          # with python support
+%bcond_without python          # with python support
+%bcond_without pthread         # build with Posix threads support
 %bcond_with    ioctl_daemon    # with ioctl_daemon (suid root)
 #
-
+%define                _pre    rc1
+#
 Summary:       A client compatible with Gadu-Gadu
 Summary(de):   Ein Cliente kompatibel mit Gadu-Gadu
 Summary(es):   Un cliente compatible con Gadu-Gadu
 Summary(it):   Un cliente compatibile con Gadu-Gadu
 Summary(pl):   Klient kompatybilny z Gadu-Gadu
 Name:          ekg
-Version:       1.5
-Release:       1
+Version:       1.6
+Release:       0.%{_pre}.1
 Epoch:         4
 License:       GPL v2
 Group:         Applications/Communications
-Source0:       http://dev.null.pl/ekg/%{name}-%{version}.tar.gz
-# Source0-md5: 721ebfe7b13e9531b30d558465e6695f
+Source0:       http://dev.null.pl/ekg/%{name}-1.6%{_pre}.tar.gz
+# Source0-md5: bce21bd6e896b71266afc30004f27402
 Source1:       %{name}.conf
-Patch0:                %{name}-kadu-0_3_6.patch
 URL:           http://dev.null.pl/ekg/
 %{?with_aspell:BuildRequires:  aspell-devel}
 BuildRequires: autoconf
@@ -30,13 +31,31 @@ BuildRequires:      libjpeg-devel
 BuildRequires: ncurses-devel
 BuildRequires: openssl-devel >= 0.9.7d
 BuildRequires: %{_bindir}/perl
-%{?with_python:BuildRequires:  python-devel}
+%if %{with python}
+BuildRequires: python
+BuildRequires: python-devel
+%endif
 BuildRequires: readline-devel
 BuildRequires: zlib-devel
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
-A client compatible with Gadu-Gadu.
+EKG ("Eksperymentalny Klient Gadu-Gadu") is an open source gadu-gadu
+client for UNIX systems. Gadu-Gadu is an instant messaging program,
+very popular in Poland.
+
+EKG features include:
+  - irssi-like ncurses interface
+  - sending and receiving files
+  - voice conversations
+  - launching shell commands on certain events
+  - reading input from pipe
+  - python scripting support
+  - speech synthesis (using an external program)
+  - encryption support
+
+Please note that the program is not internationalized and all messages
+are in Polish (although the commands are in English). 
 
 %description -l de
 Ein Cliente kompatibel mit Gadu-Gadu.
@@ -48,7 +67,22 @@ Un cliente compatible con Gadu-Gadu.
 Un cliente compatibile con Gadu-Gadu.
 
 %description -l pl
-Klient kompatybilny z Gadu-Gadu.
+EKG ("Eksperymentalny Klient Gadu-Gadu") jest open source'owym
+klientem gadu-gadu dla systemów uniksowych. Gadu-Gadu to popularny w
+polsce komunikator internetowy.
+
+Mo¿liwo¶ci EKG:
+  - interfejs u¿ytkownika podobny do irssi,
+  - wysy³anie i odbieranie plików,
+  - rozmowy g³osowe,
+  - uruchamianie poleceñ pow³oki w okre¶lonych sytuacjach,
+  - wczytywanie wej¶cia z potoku,
+  - wsparcie dla skryptów w jêzyku Python,
+  - synteza mowy (z u¿yciem zewnêtrznego programu),
+  - wsparcie dla szyfrowania.
+
+Program nie jest umiêdzynarodowiony i wszystkie komunikaty s± po
+polsku (jednak komendy s± w jêzyku angielskim).
 
 %package -n libgadu
 Summary:       libgadu library
@@ -80,7 +114,7 @@ Summary(es): Biblioteca de desarrollo de libgadu
 Summary(pl):   Czê¶æ biblioteki libgadu dla programistów
 License:       LGPL v2.1
 Group:         Development/Libraries
-Requires:      libgadu = %{epoch}:%{version}
+Requires:      libgadu = %{epoch}:%{version}-%{release}
 Requires:      openssl-devel
 Obsoletes:     libgg-devel
 
@@ -108,7 +142,7 @@ Summary(es):        Biblioteca libgadu est
 Summary(pl):   Statyczna biblioteka libgadu
 License:       LGPL v2.1
 Group:         Development/Libraries
-Requires:      libgadu-devel = %{epoch}:%{version}
+Requires:      libgadu-devel = %{epoch}:%{version}-%{release}
 Obsoletes:     libgg-static
 
 %description -n libgadu-static
@@ -124,12 +158,9 @@ Biblioteca libgadu est
 Statyczna biblioteka libgadu.
 
 %prep
-%setup -q -n %{name}-%{version}
-#%patch0 -p1
+%setup -q -n %{name}-%{version}%{_pre}
 
 %build
-sed -i -e 's/#define.*GG_LIBGADU_VERSION.*/#define GG_LIBGADU_VERSION "%{version}.%{snap}"/g' lib/libgadu.h
-
 rm -f missing
 %{__aclocal} -I m4
 %{__autoheader}
@@ -137,12 +168,16 @@ rm -f missing
 %configure \
        --enable-shared \
        --enable-static \
+%if %{with pthread}
        --with-pthread \
+%else
+       --without-pthread \
+%endif
        --without-bind \
        %{?with_python:--with-python} \
        %{!?with_voip:--without-libgsm} \
        %{?with_aspell:--enable-aspell} \
-       %{!?with_ioctl_daemon:--disable-ioctld}
+       %{?with_ioctl_daemon:--enable-ioctld}
 
 %{__make} \
        CC="%{__cc} %{rpmcflags} -Wall -I%{_includedir}/ncurses"
@@ -162,11 +197,11 @@ install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}
 
 # For libgadu-devel
 
-rm examples/Makefile examples/Makefile.in examples/.cvsignore
-rm -r examples/CVS
+rm -f examples/Makefile examples/Makefile.in examples/.cvsignore
+rm -rf examples/CVS
 
 install -d $RPM_BUILD_ROOT%{_examplesdir}/libgadu-%{version}
-mv examples/* $RPM_BUILD_ROOT%{_examplesdir}/libgadu-%{version}
+cp -af examples/* $RPM_BUILD_ROOT%{_examplesdir}/libgadu-%{version}
 
 %if %{with ioctl_daemon}
 install src/ioctld $RPM_BUILD_ROOT%{_bindir}
@@ -201,13 +236,12 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %doc docs/{7thguard,ui,devel-hints,przenosny-kod}.txt docs/protocol.html
 %doc ChangeLog docs/{README,TODO}
-%{_libdir}/libgadu.so
+%attr(755,root,root) %{_libdir}/libgadu.so
 %{_includedir}/libgadu.h
 %{_includedir}/libgadu-config.h
 %{_pkgconfigdir}/*
-%dir %{_examplesdir}/libgadu-%{version}
-%{_examplesdir}/libgadu-%{version}/*
+%{_examplesdir}/libgadu-%{version}
 
 %files -n libgadu-static
 %defattr(644,root,root,755)
-%attr(644,root,root) %{_libdir}/libgadu.a
+%{_libdir}/libgadu.a
This page took 0.041475 seconds and 4 git commands to generate.