]> git.pld-linux.org Git - packages/ejabberd.git/commitdiff
- rel 2; fix mod_ping to not kill clients that do not support ping feature auto/th/ejabberd-19.08-2
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Wed, 4 Sep 2019 08:28:54 +0000 (10:28 +0200)
committerArkadiusz Miśkiewicz <arekm@maven.pl>
Wed, 4 Sep 2019 08:28:54 +0000 (10:28 +0200)
ejabberd.spec
ping-bug-3010.patch [new file with mode: 0644]

index 4caddb7a10abab6a09818839fb85fe542f90ea90..4faeabe2e3dae29da469041c5a659fb29093338d 100644 (file)
@@ -10,7 +10,7 @@ Summary:      Fault-tolerant distributed Jabber/XMPP server
 Summary(pl.UTF-8):     Odporny na awarie rozproszony serwer Jabbera/XMPP
 Name:          ejabberd
 Version:       19.08
-Release:       1
+Release:       2
 License:       GPL
 Group:         Applications/Communications
 Source0:       http://www.process-one.net/downloads/ejabberd/%{version}/%{name}-%{version}.tgz
@@ -73,6 +73,7 @@ Patch1:               %{name}-config.patch
 # https://paleg.github.io/mod_logdb/
 # https://github.com/paleg/ejabberd/compare/paleg:19.08...paleg:19.08-mod_logdb.patch
 Patch3:                %{name}-mod_logdb.patch
+Patch4:                ping-bug-3010.patch
 URL:           http://www.ejabberd.im/
 BuildRequires: autoconf
 BuildRequires: automake
@@ -126,6 +127,7 @@ Server-side logging module.
 %if %{with logdb}
 %patch3 -p1
 %endif
+%patch4 -p1
 
 # Various parts of the build system use 'git describe'
 # which returns nonsense on manual builds using the builder script
diff --git a/ping-bug-3010.patch b/ping-bug-3010.patch
new file mode 100644 (file)
index 0000000..9b5fa2d
--- /dev/null
@@ -0,0 +1,23 @@
+From 9a8245b8e6a17b306d07cd96f2483044dd4981d2 Mon Sep 17 00:00:00 2001
+From: Evgeny Khramtsov <ekhramtsov@process-one.net>
+Date: Wed, 4 Sep 2019 10:31:09 +0300
+Subject: [PATCH] Fix the regression introduced in dd57950
+
+Fixes #3010
+---
+ src/mod_ping.erl | 2 --
+ 1 file changed, 2 deletions(-)
+
+diff --git a/src/mod_ping.erl b/src/mod_ping.erl
+index d4c226e56a..8e6827247f 100644
+--- a/src/mod_ping.erl
++++ b/src/mod_ping.erl
+@@ -132,8 +132,6 @@ handle_cast(Msg, State) ->
+     ?WARNING_MSG("Unexpected cast: ~p", [Msg]),
+     {noreply, State}.
+-handle_info({iq_reply, #iq{type = error}, JID}, State) ->
+-    handle_info({iq_reply, timeout, JID}, State);
+ handle_info({iq_reply, #iq{}, _JID}, State) ->
+     {noreply, State};
+ handle_info({iq_reply, timeout, JID}, State) ->
This page took 0.050301 seconds and 4 git commands to generate.