]> git.pld-linux.org Git - packages/eigen.git/blobdiff - eigen.spec
- updated to 2.0.17
[packages/eigen.git] / eigen.spec
index 825b65c1cb43b14fb3abfa68bb1f5436685e30f5..d515a53d8ce6ae483ea3749fdc522660afbcde5d 100644 (file)
@@ -1,27 +1,61 @@
-Summary:       template library for linear algebra
+Summary:       Template library for linear algebra
+Summary(pl.UTF-8):     Biblioteka szablonów do algebry liniowej
 Name:          eigen
-Version:       1.0.5
-Release:       0.1
-License:       GPL v2
-Group:         Libraries
-Source0:       http://download.tuxfamily.org/eigen/%{name}-%{version}.tar.gz
-# Source0-md5: 960d7e5fb6542270eae4d53ca99b607c
-URL:           http://eigen.tuxfamily.org/index.php?title=Main_Page
+Version:       2.0.17
+Release:       1
+Epoch:         1
+License:       LGPL v3+ or GPL v2+
+Group:         Development/Libraries
+Source0:       http://bitbucket.org/eigen/eigen/get/%{version}.tar.bz2
+# Source0-md5: 2dfd1e2765d82c306adbfcd6a0eb324b
+URL:           http://eigen.tuxfamily.org/
+BuildRequires: cmake >= 2.6.2
+BuildRequires: rpmbuild(macros) >= 1.577
+Obsoletes:     eigen-devel
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
-Eigen is a lightweight C++ template library for vector and matrix
-math, a.k.a. linear algebra.
+Eigen is a C++ template library for linear algebra: vectors, matrices,
+and related algorithms. It is versatile, fast, elegant and
+compiler-friendly.
+
+Eigen handles, without code duplication and in a completely integrated
+way:
+ - both fixed-size and dynamic-size matrices and vectors
+ - both dense and sparse (the latter is still experimental) matrices
+   and vectors
+ - both plain matrices/vectors and abstract expressions
+ - both column-major (the default) and row-major matrix storage
+ - both basic matrix/vector manipulation and many more advanced,
+   specialized modules providing algorithms for linear algebra,
+   geometry, quaternions, or advanced array manipulation.
+
+%description -l pl.UTF-8
+Eigen to biblioteka szablonów C++ do algebry liniowej: wektorów,
+macierzy i związanych z nimi algorytmów. Jest elastyczna, szybka,
+elegancka i przyjazna dla kompilatorów.
+
+Obsługuje bez powielania kodu i w całkowicie zintegrowany sposób:
+ - macierze i wektory o stałym i dynamicznym rozmiarze
+ - macierze i wektory gęste i rzadkie (te drugie jeszcze
+   eksperymentalnie)
+ - zwykłe macierze/wektory jak i abstrakcyjne wyrażenia
+ - przechowywanie danych kolumnowe (domyślne) oraz wierszowe
+ - podstawowe operacje na macierzach/wektorach, jak i wiele
+   bardziej zaawansowanych, specjalizowanych modułów z algorytmami
+   algebry liniowej, geometrii, kwaternionów i zaawansowanych operacji
+   na tablicach.
 
 %prep
-%setup -q -n %{name}
+%setup -q -n eigen-eigen-b23437e61a07
 
 %build
-mkdir build
+install -d build
 cd build
-%cmake \
-       -DCMAKE_INSTALL_PREFIX=%{_prefix} \
-       ../
+%cmake .. \
+       -DCMAKE_CXX_COMPILER_WORKS=1 \
+       -DCMAKE_CXX_COMPILER="%{__cc}"
+
 %{__make}
 
 %install
@@ -35,6 +69,5 @@ rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%doc LICENSE TODO README
-%dir %{_includedir}/eigen
-%{_includedir}/eigen/*.h
+%{_includedir}/eigen2
+%{_npkgconfigdir}/eigen2.pc
This page took 0.085682 seconds and 4 git commands to generate.