]> git.pld-linux.org Git - packages/eigen.git/blame_incremental - eigen.spec
- updated to 2.0.17
[packages/eigen.git] / eigen.spec
... / ...
CommitLineData
1Summary: Template library for linear algebra
2Summary(pl.UTF-8): Biblioteka szablonów do algebry liniowej
3Name: eigen
4Version: 2.0.17
5Release: 1
6Epoch: 1
7License: LGPL v3+ or GPL v2+
8Group: Development/Libraries
9Source0: http://bitbucket.org/eigen/eigen/get/%{version}.tar.bz2
10# Source0-md5: 2dfd1e2765d82c306adbfcd6a0eb324b
11URL: http://eigen.tuxfamily.org/
12BuildRequires: cmake >= 2.6.2
13BuildRequires: rpmbuild(macros) >= 1.577
14Obsoletes: eigen-devel
15BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
16
17%description
18Eigen is a C++ template library for linear algebra: vectors, matrices,
19and related algorithms. It is versatile, fast, elegant and
20compiler-friendly.
21
22Eigen handles, without code duplication and in a completely integrated
23way:
24 - both fixed-size and dynamic-size matrices and vectors
25 - both dense and sparse (the latter is still experimental) matrices
26 and vectors
27 - both plain matrices/vectors and abstract expressions
28 - both column-major (the default) and row-major matrix storage
29 - both basic matrix/vector manipulation and many more advanced,
30 specialized modules providing algorithms for linear algebra,
31 geometry, quaternions, or advanced array manipulation.
32
33%description -l pl.UTF-8
34Eigen to biblioteka szablonów C++ do algebry liniowej: wektorów,
35macierzy i związanych z nimi algorytmów. Jest elastyczna, szybka,
36elegancka i przyjazna dla kompilatorów.
37
38Obsługuje bez powielania kodu i w całkowicie zintegrowany sposób:
39 - macierze i wektory o stałym i dynamicznym rozmiarze
40 - macierze i wektory gęste i rzadkie (te drugie jeszcze
41 eksperymentalnie)
42 - zwykłe macierze/wektory jak i abstrakcyjne wyrażenia
43 - przechowywanie danych kolumnowe (domyślne) oraz wierszowe
44 - podstawowe operacje na macierzach/wektorach, jak i wiele
45 bardziej zaawansowanych, specjalizowanych modułów z algorytmami
46 algebry liniowej, geometrii, kwaternionów i zaawansowanych operacji
47 na tablicach.
48
49%prep
50%setup -q -n eigen-eigen-b23437e61a07
51
52%build
53install -d build
54cd build
55%cmake .. \
56 -DCMAKE_CXX_COMPILER_WORKS=1 \
57 -DCMAKE_CXX_COMPILER="%{__cc}"
58
59%{__make}
60
61%install
62rm -rf $RPM_BUILD_ROOT
63
64%{__make} -C build install \
65 DESTDIR=$RPM_BUILD_ROOT
66
67%clean
68rm -rf $RPM_BUILD_ROOT
69
70%files
71%defattr(644,root,root,755)
72%{_includedir}/eigen2
73%{_npkgconfigdir}/eigen2.pc
This page took 0.050618 seconds and 4 git commands to generate.