]> git.pld-linux.org Git - packages/egroupware.git/blobdiff - egroupware.spec
- apply changes inspired from spec for suse
[packages/egroupware.git] / egroupware.spec
index f6d75ff6660490b13b1dc3f7ba440c5e20e757a2..20974ccc7b6762589b287fb9bf75d27882543996 100644 (file)
@@ -1,34 +1,44 @@
 # TODO
 # - subpackages for applications
 # - separate htdocs and includedirs
+# - list of bundled software (to use pld packages instead):
 # - everything
+
+%define        _rel 0.3
 Summary:       eGroupWare - a web-based groupware suite written in PHP
 Summary(pl):   eGroupWAre - oparte na WWW oprogramowanie do pracy grupowej napisane w PHP
 Name:          egroupware
-Version:       1.0.0.009
-Release:       0.17
-Epoch:         0
+Version:       1.2
+Release:       2.%{_rel}
 License:       GPL
 Group:         Applications/WWW
-Source0:       http://dl.sourceforge.net/egroupware/eGroupWare-%{version}.tar.bz2
-# Source0-md5: 2ed2f3041ab4ff235f56ed23dfa7274b
+Source0:       http://dl.sourceforge.net/egroupware/eGroupWare-%{version}-2.tar.bz2
+# Source0-md5: 2758792188125086f815e0e412a30904
 Source1:       %{name}.conf
+Source2:       %{name}.cron
 Patch0:                %{name}-setup.patch
 Patch1:                %{name}-ttfdir.patch
 URL:           http://www.egroupware.org/
+BuildRequires: rpmbuild(macros) >= 1.268
 BuildRequires: sed >= 4.0
-Requires:      %{name}(DB_Driver)
-Requires:      php >= 3:4.1.2
+Requires:      %{name}(DB_Driver) = %{version}-%{release}
+Requires:      /usr/bin/php
+Requires:      crondaemon
+Requires:      fonts-TTF-bitstream-vera
+Requires:      php >= 3:4.3
+Requires:      php-cli
 Requires:      php-gd
+Requires:      php-imap
 Requires:      php-mbstring
 Requires:      php-pcre
-Requires:      php-cli
-Requires:      fonts-TTF-bitstream-vera
+Requires:      webapps
 BuildArch:     noarch
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
-%define                _appdir %{_datadir}/%{name}
-%define                _sysconfdir /etc/%{name}
+%define                _webapps        /etc/webapps
+%define                _webapp         %{name}
+%define                _sysconfdir     %{_webapps}/%{_webapp}
+%define                _appdir         %{_datadir}/%{_webapp}
 
 %description
 eGroupWare is a multi-user, web-based groupware suite developed on a
@@ -47,7 +57,7 @@ telefoniczne), zarz
 Summary:       eGroupware setup package
 Summary(pl):   Pakiet do wstêpnej konfiguracji eGroupware
 Group:         Applications/WWW
-PreReq:                %{name} = %{epoch}:%{version}-%{release}
+Requires:      %{name} = %{version}-%{release}
 
 %description setup
 Install this package to configure initial eGroupware installation. You
@@ -55,8 +65,8 @@ should uninstall this package when you're done, as it considered
 insecure to keep the setup files in place.
 
 %description setup -l pl
-Ten pakiet nale¿y zainstalowaæ w celu wstêpnej konfiguracji eGroupware po
-pierwszej instalacji. Potem nale¿y go odinstalowaæ, jako ¿e
+Ten pakiet nale¿y zainstalowaæ w celu wstêpnej konfiguracji eGroupware
+po pierwszej instalacji. Potem nale¿y go odinstalowaæ, jako ¿e
 pozostawienie plików instalacyjnych mog³oby byæ niebezpieczne.
 
 %package db-mysql
@@ -106,96 +116,93 @@ eGroupware.
 %setup -q -n %{name}
 
 # remove CVS control files
-find -name CVS -print0 | xargs -0 rm -rf
+find -name .svn -print0 | xargs -0 rm -rf
 # undos the sources
-find -regex '.*\.\(php\|inc\|html\|txt\|js\)$' -print0 | xargs -0 sed -i -e 's,
-$,,'
+find -regex '.*\.\(php\|inc\|html\|txt\|js\)$' -print0 | xargs -0 sed -i -e 's,\r$,,'
 
 %patch0 -p1
 %patch1 -p1
 
 # GPL
-rm -f doc/LICENSE
+rm doc/LICENSE
 
 # no need.
-rm -rf doc/rpm-build
+rm -r doc/rpm-build
 
 # using PLD package
-rm -rf projects/ttf-bitstream-vera-1.10
+rm -r projectmanager/inc/ttf-bitstream-vera-1.10
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT{%{_appdir},%{_sysconfdir}}
+install -d $RPM_BUILD_ROOT{%{_appdir},%{_sysconfdir},/var/lib/%{name}/{default/{files,backup},sessions}}
 
 cp -a *.php $RPM_BUILD_ROOT%{_appdir}
-cp -a addressbook admin backup bookmarks calendar comic developer_tools \
-email emailadmin etemplate felamimail filemanager forum ftp fudforum headlines \
-infolog jinn manual messenger news_admin phpbrain phpgwapi phpldapadmin \
-phpsysinfo polls preferences projects registration setup sitemgr stocks tts \
-wiki $RPM_BUILD_ROOT%{_appdir}
+cp -a */ $RPM_BUILD_ROOT%{_appdir}
 
 > $RPM_BUILD_ROOT%{_sysconfdir}/header.php
 ln -s %{_sysconfdir}/header.php $RPM_BUILD_ROOT%{_appdir}/header.inc.php
 
 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/apache.conf
+install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/httpd.conf
+install -D %{SOURCE2} $RPM_BUILD_ROOT/etc/cron.d/%{name}
 
 # needed by setup script
 install header.inc.php.template $RPM_BUILD_ROOT%{_appdir}
 
+rm -rf $RPM_BUILD_ROOT%{_appdir}/doc
+
 %clean
 rm -rf $RPM_BUILD_ROOT
 
-%triggerin -- apache1 >= 1.3.33-2
-%apache_config_install -v 1 -c %{_sysconfdir}/apache.conf
+%triggerin -- apache1
+%webapp_register apache %{_webapp}
 
-%triggerun -- apache1 >= 1.3.33-2
-%apache_config_uninstall -v 1
+%triggerun -- apache1
+%webapp_unregister apache %{_webapp}
 
-%triggerin -- apache >= 2.0.0
-%apache_config_install -v 2 -c %{_sysconfdir}/apache.conf
+%triggerin -- apache < 2.2.0, apache-base
+%webapp_register httpd %{_webapp}
 
-%triggerun -- apache >= 2.0.0
-%apache_config_uninstall -v 2
+%triggerun -- apache < 2.2.0, apache-base
+%webapp_unregister httpd %{_webapp}
 
 %files
 %defattr(644,root,root,755)
-%attr(710,root,http) %dir %{_sysconfdir}
+%doc doc/*
+%dir %attr(750,root,http) %{_sysconfdir}
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/apache.conf
+%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/httpd.conf
 %attr(660,root,http) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/header.php
-%doc doc/*
+%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}
 %dir %{_appdir}
 %{_appdir}/*.php
 %{_appdir}/addressbook
 %{_appdir}/admin
-%{_appdir}/backup
 %{_appdir}/bookmarks
 %{_appdir}/calendar
-%{_appdir}/comic
 %{_appdir}/developer_tools
-%{_appdir}/email
 %{_appdir}/emailadmin
 %{_appdir}/etemplate
 %{_appdir}/felamimail
 %{_appdir}/filemanager
-%{_appdir}/forum
-%{_appdir}/ftp
-%{_appdir}/headlines
 %{_appdir}/infolog
-%{_appdir}/jinn
 %{_appdir}/manual
-%{_appdir}/messenger
 %{_appdir}/news_admin
 %{_appdir}/phpbrain
-%{_appdir}/phpldapadmin
-%{_appdir}/phpsysinfo
 %{_appdir}/polls
+%{_appdir}/phpsysinfo
 %{_appdir}/preferences
-%{_appdir}/projects
 %{_appdir}/registration
 %{_appdir}/sitemgr
-%{_appdir}/stocks
-%{_appdir}/tts
 %{_appdir}/wiki
+%{_appdir}/home
+%{_appdir}/mydms
+%{_appdir}/projectmanager
+%{_appdir}/resources
+%{_appdir}/sambaadmin
+%{_appdir}/syncml
+%{_appdir}/timesheet
+%{_appdir}/workflow
 
 %dir %{_appdir}/phpgwapi
 %{_appdir}/phpgwapi/*.php
@@ -206,14 +213,14 @@ rm -rf $RPM_BUILD_ROOT
 %{_appdir}/phpgwapi/setup
 %{_appdir}/phpgwapi/templates
 %{_appdir}/phpgwapi/themes
+%{_appdir}/phpgwapi/tests
 %dir %attr(775,root,http) %{_appdir}/phpgwapi/images
 %{_appdir}/phpgwapi/images/*
 
-%dir %attr(775,root,http) %{_appdir}/fudforum
-%{_appdir}/fudforum/*.php
-%{_appdir}/fudforum/inc
-%{_appdir}/fudforum/setup
-%{_appdir}/fudforum/templates
+%dir /var/lib/%{name}/default
+%dir %attr(775,root,http) /var/lib/%{name}/default/backup
+%dir %attr(775,root,http) /var/lib/%{name}/default/files
+%dir %attr(775,root,http) /var/lib/%{name}/sessions
 
 %files setup
 %defattr(644,root,root,755)
This page took 0.278287 seconds and 4 git commands to generate.