]> git.pld-linux.org Git - packages/efreet.git/blame - efreet.spec
- x32 rebuild
[packages/efreet.git] / efreet.spec
CommitLineData
6565bede 1# NOTE: for versions >= 1.8 see efl.spec
d470277b
JB
2#
3# Conditional build:
4%bcond_without static_libs # don't build static library
5#
cd863ba4
JB
6%define ecore_ver 1.7.10
7%define eet_ver 1.7.10
8%define eina_ver 1.7.10
07e33737 9
d470277b
JB
10Summary: freedesktop.org standards implementation for the EFL
11Summary(pl.UTF-8): Implementacja standardów freedesktop.org dla EFL
12Name: efreet
cd863ba4 13Version: 1.7.10
d70bc883 14Release: 2
04827781 15License: BSD
d470277b 16Group: X11/Libraries
863f344e 17Source0: http://download.enlightenment.org/releases/%{name}-%{version}.tar.bz2
cd863ba4 18# Source0-md5: 4aa5d4a677abd2d5a013ccfe61be8824
9bd7b500 19URL: http://trac.enlightenment.org/e/wiki/Efreet
93cc5570
JB
20BuildRequires: autoconf >= 2.52
21BuildRequires: automake >= 1.6
07e33737 22BuildRequires: ecore-devel >= %{ecore_ver}
04827781
JB
23BuildRequires: ecore-file-devel >= %{ecore_ver}
24BuildRequires: eet-devel >= %{eet_ver}
173d24b3 25BuildRequires: eina-devel >= %{eina_ver}
af74faaa 26BuildRequires: gettext-tools >= 0.17
d470277b 27BuildRequires: libtool
04827781 28BuildRequires: pkgconfig >= 1:0.22
04827781 29Requires: ecore >= %{ecore_ver}
07e33737 30Requires: ecore-file >= %{ecore_ver}
173d24b3 31Requires: eet >= %{eet_ver}
8e8b1b65 32Requires: eina >= %{eina_ver}
d470277b
JB
33BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35%description
36Efreet is an implementation of the following specifications from
37freedesktop.org:
38 - Base Directory - Locations for system and user specific desktop
39 configuration files,
40 - Desktop Entries - The metadata associated with the applications
41 installed on a system,
42 - Application Menus - The arrangement of available applications into
43 a hierarchical menu,
44 - Icon Themes - A means of associating icons with various objects on
45 the desktop in a themable fashion.
46
47By following these specifications, Enlightenment 0.17 uses the same
48format for describing application launchers, menus and icon themes as
49the GNOME, KDE and XFCE Desktop Environments. A system must only
50provide a single set of this data for use with any of these desktops.
51
52%description -l pl.UTF-8
53Efreet to implementacja następujących specyfikacji z freedesktop.org:
54 - Base Directory - położenie plików konfiguracyjnych środowiska dla
55 systemu i użytkownika,
56 - Desktop Entries - metadane związane z aplikacjami zainstalowanymi w
57 systemie,
58 - Application Menus - uporządkowanie dostępnych aplikacji w menu
59 hierarchiczne,
60 - Icon Themes - sposób wiązania ikon z różnymi obiektami w środowisku
61 w sposób pozwalający na ustawianie motywów.
62
63%package devel
64Summary: Efreet header files
65Summary(pl.UTF-8): Pliki nagłówkowe Efreet
66Group: Development/Libraries
67Requires: %{name} = %{version}-%{release}
04827781
JB
68Requires: ecore-devel >= %{ecore_ver}
69Requires: ecore-file-devel >= %{ecore_ver}
70Requires: eet-devel >= %{eet_ver}
173d24b3 71Requires: eina-devel >= %{eina_ver}
d470277b
JB
72
73%description devel
74Header files for Efreet.
75
76%description devel -l pl.UTF-8
77Pliki nagłówkowe Efreet.
78
79%package static
80Summary: Static Efreet library
81Summary(pl.UTF-8): Statyczna biblioteka Efreet
82Group: Development/Libraries
83Requires: %{name}-devel = %{version}-%{release}
84
85%description static
86Static Efreet library.
87
88%description static -l pl.UTF-8
89Statyczna biblioteka Efreet.
90
91%prep
863f344e 92%setup -q
d470277b 93
d470277b 94%build
ee7b66d9 95%{__gettextize}
d470277b
JB
96%{__libtoolize}
97%{__aclocal} -I m4
98%{__autoconf}
99%{__autoheader}
100%{__automake}
101%configure \
04827781 102 --disable-silent-rules \
d470277b 103 %{!?with_static_libs:--disable-static}
04827781 104%{__make}
d470277b
JB
105
106%install
107rm -rf $RPM_BUILD_ROOT
108
109%{__make} install \
110 DESTDIR=$RPM_BUILD_ROOT
111
112# just tests
04827781
JB
113%{__rm} $RPM_BUILD_ROOT%{_bindir}/efreet_{alloc,menu_alloc,test,spec_test,cache_test}
114%{__rm} -r $RPM_BUILD_ROOT%{_datadir}/%{name}/test
d470277b 115
ee7b66d9
JB
116%find_lang %{name}
117
d470277b
JB
118%clean
119rm -rf $RPM_BUILD_ROOT
120
121%post -p /sbin/ldconfig
122%postun -p /sbin/ldconfig
123
ee7b66d9 124%files -f %{name}.lang
d470277b 125%defattr(644,root,root,755)
173d24b3
JB
126%doc AUTHORS COPYING ChangeLog NEWS README TODO
127%attr(755,root,root) %{_bindir}/efreet_icon_cache_dump
04827781
JB
128%attr(755,root,root) %{_libdir}/libefreet.so.*.*.*
129%attr(755,root,root) %ghost %{_libdir}/libefreet.so.1
130%attr(755,root,root) %{_libdir}/libefreet_mime.so.*.*.*
131%attr(755,root,root) %ghost %{_libdir}/libefreet_mime.so.1
132%attr(755,root,root) %{_libdir}/libefreet_trash.so.*.*.*
133%attr(755,root,root) %ghost %{_libdir}/libefreet_trash.so.1
134%dir %{_libdir}/efreet
135%attr(755,root,root) %{_libdir}/efreet/efreet_desktop_cache_create
173d24b3 136%attr(755,root,root) %{_libdir}/efreet/efreet_icon_cache_create
d470277b
JB
137
138%files devel
139%defattr(644,root,root,755)
93cc5570
JB
140%attr(755,root,root) %{_libdir}/libefreet.so
141%attr(755,root,root) %{_libdir}/libefreet_mime.so
adf62b9b 142%attr(755,root,root) %{_libdir}/libefreet_trash.so
93cc5570
JB
143%{_libdir}/libefreet.la
144%{_libdir}/libefreet_mime.la
adf62b9b 145%{_libdir}/libefreet_trash.la
04827781 146%{_includedir}/efreet-1
93cc5570
JB
147%{_pkgconfigdir}/efreet.pc
148%{_pkgconfigdir}/efreet-mime.pc
adf62b9b 149%{_pkgconfigdir}/efreet-trash.pc
d470277b
JB
150
151%if %{with static_libs}
152%files static
153%defattr(644,root,root,755)
93cc5570
JB
154%{_libdir}/libefreet.a
155%{_libdir}/libefreet_mime.a
adf62b9b 156%{_libdir}/libefreet_trash.a
d470277b 157%endif
This page took 0.150791 seconds and 4 git commands to generate.