]> git.pld-linux.org Git - packages/efl.git/commitdiff
- updated to 1.10.1
authorJakub Bogusz <qboosh@pld-linux.org>
Sat, 14 Jun 2014 15:33:38 +0000 (17:33 +0200)
committerJakub Bogusz <qboosh@pld-linux.org>
Sat, 14 Jun 2014 15:33:38 +0000 (17:33 +0200)
- added gif patch (fixes build with giflib >= 5.1)

efl-gif.patch [new file with mode: 0644]
efl.spec

diff --git a/efl-gif.patch b/efl-gif.patch
new file mode 100644 (file)
index 0000000..4310f3b
--- /dev/null
@@ -0,0 +1,50 @@
+--- efl-1.10.1/src/modules/evas/loaders/gif/evas_image_load_gif.c.orig 2014-06-03 12:38:57.000000000 +0200
++++ efl-1.10.1/src/modules/evas/loaders/gif/evas_image_load_gif.c      2014-06-14 16:57:31.264950243 +0200
+@@ -528,7 +528,11 @@
+    ret = EINA_TRUE;
+ on_error: // jump here on any errors to clean up
++#if (GIFLIB_MAJOR > 5) || ((GIFLIB_MAJOR == 5) && (GIFLIB_MINOR >= 1))
++   if (gif) DGifCloseFile(gif, NULL);
++#else
+    if (gif) DGifCloseFile(gif);
++#endif
+    if (fi.map) eina_file_map_free(f, fi.map);
+    return ret;
+ }
+@@ -606,7 +610,11 @@
+    // start as we have nothnig to build on
+    if ((index > 0) && (index < loader->imgnum) && (animated->animated))
+      {
++#if (GIFLIB_MAJOR > 5) || ((GIFLIB_MAJOR == 5) && (GIFLIB_MINOR >= 1))
++        if (loader->gif) DGifCloseFile(loader->gif, NULL);
++#else
+         if (loader->gif) DGifCloseFile(loader->gif);
++#endif
+         if ((loader->fi.map) && (loader->f))
+           eina_file_map_free(loader->f, loader->fi.map);
+         loader->gif = NULL;
+@@ -764,7 +772,11 @@
+    loader->imgnum = imgnum;
+    if ((animated->frame_count <= 1) || (rec == TERMINATE_RECORD_TYPE))
+      {
++#if (GIFLIB_MAJOR > 5) || ((GIFLIB_MAJOR == 5) && (GIFLIB_MINOR >= 1))
++        if (loader->gif) DGifCloseFile(loader->gif, NULL);
++#else
+         if (loader->gif) DGifCloseFile(loader->gif);
++#endif
+         if ((loader->fi.map) && (loader->f))
+           eina_file_map_free(loader->f, loader->fi.map);
+         loader->gif = NULL;
+@@ -848,7 +860,11 @@
+ evas_image_load_file_close_gif2(void *loader_data)
+ {
+    Loader_Info *loader = loader_data;
++#if (GIFLIB_MAJOR > 5) || ((GIFLIB_MAJOR == 5) && (GIFLIB_MINOR >= 1))
++   if (loader->gif) DGifCloseFile(loader->gif, NULL);
++#else
+    if (loader->gif) DGifCloseFile(loader->gif);
++#endif
+    if ((loader->fi.map) && (loader->f))
+      eina_file_map_free(loader->f, loader->fi.map);
+    free(loader);
index 98232f4db86b13741fb69c9dbbd89ae3fa6af00b..fb8c4fe0586929f9fe18d538e655da673b44b5ee 100644 (file)
--- a/efl.spec
+++ b/efl.spec
 Summary:       EFL - The Enlightenment Foundation Libraries
 Summary(pl.UTF-8):     EFL (Enlightenment Foundation Libraries) - biblioteki tworzące Enlightment
 Name:          efl
-Version:       1.10.0
+Version:       1.10.1
 Release:       1
 License:       LGPL v2.1+, BSD (depends on component)
 Group:         Libraries
 Source0:       http://download.enlightenment.org/rel/libs/efl/%{name}-%{version}.tar.bz2
-# Source0-md5: 588dfe1957530c801c5599dfc19a9840
+# Source0-md5: eadc55e41602b3b34d6b9b0e0b12826a
 Patch0:                %{name}-pc.patch
 Patch1:                %{name}-wayland.patch
 Patch2:                %{name}-am.patch
+Patch3:                %{name}-gif.patch
 URL:           https://trac.enlightenment.org/e/wiki/EFL
 %{?with_egl:BuildRequires:     EGL-devel}
 BuildRequires: OpenGL-GLX-devel
@@ -2417,6 +2418,7 @@ Obsługa składni EDC dla Vima.
 %patch0 -p1
 %patch1 -p1
 %patch2 -p1
+%patch3 -p1
 
 %build
 %{__libtoolize}
This page took 0.102833 seconds and 4 git commands to generate.