]> git.pld-linux.org Git - packages/efi-boot-update.git/blob - efi-boot-update.spec
cba2ebfc4fbdbb2c8f8b2e5edecee579864c388d
[packages/efi-boot-update.git] / efi-boot-update.spec
1 # $Revision: 1.81 $, $Date: 2012/04/20 10:52:52 $
2 #
3 Summary:        EFI bootloader updater
4 Name:           efi-boot-update
5 Version:        0.1
6 Release:        0.1
7 License:        GPL v2
8 Group:          Applications
9 Source0:        %{name}
10 Source1:        update.conf
11 Source2:        shellx64.conf
12 Source3:        shellx32.conf
13 Source4:        grub.conf
14 Source10:       README
15 Source11:       TODO
16 URL:            http://www.pld-linux.org/
17 BuildRequires:  help2man
18 Suggests:       efibootmgr
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %define         _sbindir /sbin
22
23 %description
24 Script to update EFI bootloaders.
25
26 %prep
27 %setup -qcT
28 cp %{SOURCE0} .
29 cp %{SOURCE10} %{SOURCE11} .
30
31 %build
32 chmod a+x %{name}
33 help2man --no-info ./%{name} > %{name}.8
34
35 %install
36 rm -rf $RPM_BUILD_ROOT
37 install -d $RPM_BUILD_ROOT/etc/efi-boot/update.d
38 install -d $RPM_BUILD_ROOT{/lib/efi/{x32,x64},%{_sbindir},%{_mandir}/man8}
39
40 install %{name} $RPM_BUILD_ROOT%{_sbindir}/%{name}
41 install %{name}.8 $RPM_BUILD_ROOT%{_mandir}/man8/%{name}.8
42 install %{SOURCE1} $RPM_BUILD_ROOT/etc/efi-boot
43 install %{SOURCE2} %{SOURCE3} %{SOURCE4} $RPM_BUILD_ROOT/etc/efi-boot/update.d
44
45 %clean
46 rm -rf $RPM_BUILD_ROOT
47
48 # Most efi-boot-update-managed loaders will use kernel files
49 # even if the kernel itself is not build as EFI
50 %triggerin -- kernel
51 /sbin/efi-boot-update || :
52 %triggerin -- kernel-longterm
53 /sbin/efi-boot-update || :
54
55 %files
56 %defattr(644,root,root,755)
57 %doc README TODO
58 %attr(755,root,root) %{_sbindir}/%{name}
59 %dir /etc/efi-boot
60 %config(noreplace) %verify(not md5 mtime size) /etc/efi-boot/update.conf
61 %config(noreplace) %verify(not md5 mtime size) /etc/efi-boot/update.d/*.conf
62 %dir /etc/efi-boot/update.d
63 %dir /lib/efi
64 %dir /lib/efi/x32
65 %dir /lib/efi/x64
66 %{_mandir}/man8/%{name}.8*
This page took 0.061602 seconds and 2 git commands to generate.