]> git.pld-linux.org Git - packages/efi-boot-update.git/blob - efi-boot-update.spec
'grub-installed' module added
[packages/efi-boot-update.git] / efi-boot-update.spec
1 # $Revision: 1.81 $, $Date: 2012/04/20 10:52:52 $
2 #
3 Summary:        EFI bootloader updater
4 Name:           efi-boot-update
5 Version:        0.1
6 Release:        0.1
7 License:        GPL v2
8 Group:          Applications
9 Source0:        %{name}
10 Source1:        update.conf
11 Source2:        shellx64.conf
12 Source3:        shellia32.conf
13 Source4:        grub.conf
14 Source5:        grub-installed.conf
15 Source10:       README
16 Source11:       TODO
17 URL:            http://www.pld-linux.org/
18 BuildRequires:  help2man
19 Suggests:       efibootmgr
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %define         _sbindir /sbin
23
24 %description
25 Script to update EFI bootloaders.
26
27 %prep
28 %setup -qcT
29 cp %{SOURCE0} .
30 cp %{SOURCE10} %{SOURCE11} .
31
32 %build
33 chmod a+x %{name}
34 help2man --no-info ./%{name} > %{name}.8
35
36 %install
37 rm -rf $RPM_BUILD_ROOT
38 install -d $RPM_BUILD_ROOT/etc/efi-boot/update.d
39 install -d $RPM_BUILD_ROOT{/lib/efi/{ia32,x64},%{_sbindir},%{_mandir}/man8}
40
41 install %{name} $RPM_BUILD_ROOT%{_sbindir}/%{name}
42 install %{name}.8 $RPM_BUILD_ROOT%{_mandir}/man8/%{name}.8
43 install %{SOURCE1} $RPM_BUILD_ROOT/etc/efi-boot
44 install %{SOURCE2} %{SOURCE3} %{SOURCE4} %{SOURCE5} \
45                                 $RPM_BUILD_ROOT/etc/efi-boot/update.d
46
47 %clean
48 rm -rf $RPM_BUILD_ROOT
49
50 # Most efi-boot-update-managed loaders will use kernel files
51 # even if the kernel itself is not build as EFI
52 %triggerin -- kernel
53 /sbin/efi-boot-update || :
54 %triggerin -- kernel-longterm
55 /sbin/efi-boot-update || :
56
57 %files
58 %defattr(644,root,root,755)
59 %doc README TODO
60 %attr(755,root,root) %{_sbindir}/%{name}
61 %dir /etc/efi-boot
62 %config(noreplace) %verify(not md5 mtime size) /etc/efi-boot/update.conf
63 %config(noreplace) %verify(not md5 mtime size) /etc/efi-boot/update.d/*.conf
64 %dir /etc/efi-boot/update.d
65 %dir /lib/efi
66 %dir /lib/efi/ia32
67 %dir /lib/efi/x64
68 %{_mandir}/man8/%{name}.8*
This page took 0.058404 seconds and 3 git commands to generate.