]> git.pld-linux.org Git - packages/efi-boot-update.git/blob - efi-boot-update.spec
- x32 rebuild
[packages/efi-boot-update.git] / efi-boot-update.spec
1 # $Revision: 1.81 $, $Date: 2012/04/20 10:52:52 $
2 Summary:        EFI bootloader updater
3 Summary(pl.UTF-8):      Skrypt do uaktualniania bootloaderów EFI
4 Name:           efi-boot-update
5 Version:        0.2
6 Release:        2
7 License:        GPL v2
8 Group:          Applications/System
9 Source0:        %{name}
10 Source1:        update.conf
11 Source2:        grub.conf
12 Source3:        grub-installed.conf
13 Source4:        kernel.conf
14 Source5:        kernel-old.conf
15 Source10:       README
16 Source11:       TODO
17 URL:            http://www.pld-linux.org/
18 BuildRequires:  help2man
19 Suggests:       efibootmgr
20 Suggests:       efi-shell-x64
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %define         _sbindir /sbin
24
25 %description
26 Script to update EFI bootloaders.
27
28 %description -l pl.UTF-8
29 Skrypt do uaktualniania bootloaderów EFI.
30
31 %prep
32 %setup -qcT
33 cp %{SOURCE0} .
34 cp %{SOURCE10} %{SOURCE11} .
35
36 %build
37 chmod a+x %{name}
38 help2man --no-info ./%{name} > %{name}.8
39
40 %install
41 rm -rf $RPM_BUILD_ROOT
42 install -d $RPM_BUILD_ROOT/etc/efi-boot/update.d
43 install -d $RPM_BUILD_ROOT{/lib/efi/{ia32,x64},%{_sbindir},%{_mandir}/man8}
44
45 install %{name} $RPM_BUILD_ROOT%{_sbindir}/%{name}
46 install %{name}.8 $RPM_BUILD_ROOT%{_mandir}/man8/%{name}.8
47 install %{SOURCE1} $RPM_BUILD_ROOT/etc/efi-boot
48 install %{SOURCE2} %{SOURCE3} $RPM_BUILD_ROOT/etc/efi-boot/update.d
49 install %{SOURCE4} %{SOURCE5} $RPM_BUILD_ROOT/etc/efi-boot/update.d
50
51 %clean
52 rm -rf $RPM_BUILD_ROOT
53
54 # Most efi-boot-update-managed loaders will use kernel files
55 # even if the kernel itself is not built as EFI
56 %triggerin -- kernel
57 /sbin/efi-boot-update --auto || :
58 %triggerin -- kernel-longterm
59 /sbin/efi-boot-update --auto || :
60
61 %files
62 %defattr(644,root,root,755)
63 %doc README TODO
64 %attr(755,root,root) %{_sbindir}/%{name}
65 %dir /etc/efi-boot
66 %config(noreplace) %verify(not md5 mtime size) /etc/efi-boot/update.conf
67 %dir /etc/efi-boot/update.d
68 %config(noreplace) %verify(not md5 mtime size) /etc/efi-boot/update.d/grub.conf
69 %config(noreplace) %verify(not md5 mtime size) /etc/efi-boot/update.d/grub-installed.conf
70 %config(noreplace) %verify(not md5 mtime size) /etc/efi-boot/update.d/kernel.conf
71 %config(noreplace) %verify(not md5 mtime size) /etc/efi-boot/update.d/kernel-old.conf
72 %dir /lib/efi
73 %dir /lib/efi/ia32
74 %dir /lib/efi/x64
75 %{_mandir}/man8/%{name}.8*
This page took 0.027307 seconds and 3 git commands to generate.