]> git.pld-linux.org Git - packages/efax.git/commitdiff
- add efax package
authorsmyda <smyda@ite.pl>
Wed, 7 Apr 1999 09:37:11 +0000 (09:37 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    efax.patch -> 1.1
    efax.spec -> 1.1

efax.patch [new file with mode: 0644]
efax.spec [new file with mode: 0644]

diff --git a/efax.patch b/efax.patch
new file mode 100644 (file)
index 0000000..af71a2f
--- /dev/null
@@ -0,0 +1,77 @@
+diff -Nur efax-0.9.orig/Makefile efax-0.9/Makefile
+--- efax-0.9.orig/Makefile     Fri Mar 12 02:00:34 1999
++++ efax-0.9/Makefile  Wed Apr  7 11:05:40 1999
+@@ -9,7 +9,7 @@
+ # is undefined
+ CFLAGS=
+-LDFLAGS=
++LDFLAGS=-s
+ # Change the following to the destination directories for
+ # binaries and man pages. Probably /usr/bin and /usr/man on
+diff -Nur efax-0.9.orig/efaxio.c efax-0.9/efaxio.c
+--- efax-0.9.orig/efaxio.c     Tue Mar  2 07:15:44 1999
++++ efax-0.9/efaxio.c  Wed Apr  7 11:10:52 1999
+@@ -2,6 +2,7 @@
+ #include <signal.h>    
+ #include <stdio.h>
+ #include <string.h>
++#include <time.h>
+ #include "efaxio.h"           /* EFAX */
+ #include "efaxmsg.h"
+diff -Nur efax-0.9.orig/fax efax-0.9/fax
+--- efax-0.9.orig/fax  Wed Mar 24 09:07:28 1999
++++ efax-0.9/fax       Wed Apr  7 11:07:28 1999
+@@ -17,9 +17,9 @@
+ # The names of the fax script, efax and efix, including full path
+ # if necessary.
+-FAX=fax
+-EFAX=efax
+-EFIX=efix
++FAX=/usr/bin/fax
++EFAX=/usr/bin/efax
++EFIX=/usr/bin/efix
+ # The device to which the fax modem is connected (e.g. ttya for
+ # /dev/ttya).  Use a dial-out (cua) device if available.  If
+@@ -28,23 +28,23 @@
+ # /dev/modem is a link to /dev/cua1, then getty, uucp, kermit,
+ # pppd, dip, etc. must *all* use either /dev/modem or /dev/cua1.
+-DEV=cua1
++DEV=modem
+ # Your fax number in international format, 20 characters maximum.
+ # Use only digits, spaces, and the "+" character.
+-FROM="+1 800 555 5555"
++FROM="+0 000 000 0000"
+ # Your name as it should appear on the page header.
+-NAME="Put Your Name Here"
++NAME="from PLD system"
+ # The preferred page size for creating and printing faxes.
+ # Allowed values are "letter", "legal", and "a4".
+-PAGE=letter
++# PAGE=letter
+ # PAGE=legal
+-# PAGE=a4
++PAGE=a4
+ # The type of printer. Use 'pcl' for HP-PCL or 'ps' for
+ # Postscript.  See definition of PRINT (below) for more options.
+@@ -67,7 +67,7 @@
+ # The name of the Ghostscript executable including full path if
+ # necessary.  Only required if faxing Postscript files.
+-GS=gs
++GS=/usr/bin/gs
+ # Dial string prefix and suffix such as T for tone dialing, P for
+ # pulse dialing, 9 to get an external line, commas for delays or
diff --git a/efax.spec b/efax.spec
new file mode 100644 (file)
index 0000000..cf75837
--- /dev/null
+++ b/efax.spec
@@ -0,0 +1,83 @@
+Summary:       sends and receives faxes over class 1 or class 2 modems
+Summary(de):   sendet und empfängt Faxe über Modems der Klassen 1 und 2
+Summary(fr):   envoie et reçoit des faxs sur des modems classe 1 ou 2
+Summary(pl):   wysy³anie i odbieranie faxów modemami klasy 1 oraz 2
+Summary(tr):   1 veya 2 sýnýfý modemler üzerinden fax gönderir
+Name:          efax
+Version:       0.9
+Release:       1
+Copyright:     GPL
+Group:         Applications/Communications
+Group(pl):     Aplikacje/Komunikacja
+Source:                ftp://sunsite.unc.edu/pub/Linux/apps/comm/fax/efax-0.9.tar.gz
+Patch:         efax-0.9.patch
+Patch3:                efax-08a-64bit.patch
+Buildroot:     /tmp/%{name}-%{version}-root
+
+%description
+This is a program to send and receive faxes over class 1 or
+class 2 fax modems.  It has a nice interface to help 
+facilitate faxing.
+
+%description -l de
+Dies ist ein Programm zum Versenden und Empfangen von 
+Faxnachrichten über Faxmodems der Klasse 2. Dank
+seiner attraktiven Bedieneroberfläche wird das Faxen zum
+Kinderspiel
+
+%description -l fr
+C'est un programme pour envoyer et recevoir des messages sur des modems de
+classe 1 ou 2. Il posséde une interface agréable pour faciliter l'envoi
+des fax.
+
+%description -l pl
+Program umo¿liwiaj±cy wysy³anie i odbieranie faxów faxmodemami klasy 1 
+oraz 2. Program ten posiada ³atwy interface u³atwiaj±cy faxowanie.
+
+%description -l tr
+Bu program ile 1 veya 2 sýnýfý modemlerle fax gönderilebilir. Fax
+iletiþimini kolaylaþtýrmak için programýn güzel bir kullanýcý arayüzü
+bulunmaktadýr.
+
+%prep
+%setup
+%patch -p1
+
+#%ifarch alpha
+#%patch3 -p1
+#%endif
+
+%build
+make CFLAGS="$RPM_OPT_FLAGS"
+
+%install
+install -d $RPM_BUILD_ROOT/usr/{bin,man/man1}
+make install BINDIR=$RPM_BUILD_ROOT/usr/bin MANDIR=$RPM_BUILD_ROOT/usr/man
+gzip -9nf $RPM_BUILD_ROOT/usr/man/man*/*
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%files
+%defattr(644, root, root, 755)
+%doc README COPYING
+%config %attr(755,root,root) /usr/bin/fax
+%attr(755,root,root) /usr/bin/efax
+%attr(755,root,root) /usr/bin/efix
+/usr/man/man1/*.gz
+
+%changelog
+* Wed Apr  7 1999 Jacek Smyda <smyda@posexperts.com.pl>
+  [0.9-1]
+- finally 0.9
+- translations for pl
+- gzip man pages
+
+* Mon Apr 27 1998 Prospector System <bugs@redhat.com>
+- translations modified for de, fr, tr
+
+* Wed Oct 22 1997 Michael Fulbright <msf@redhat.com>
+- cleaned spec file to new standard, confirmed package is up to date
+
+* Tue Mar 25 1997 Erik Troan <ewt@redhat.com>
+- Added efax-08a-64bit.patch from David Mosberger
This page took 0.070141 seconds and 4 git commands to generate.