]> git.pld-linux.org Git - packages/eeze.git/blobdiff - eeze.spec
- x32 rebuild
[packages/eeze.git] / eeze.spec
index 7fdf5f277a424f65eb80a0a62f29ebf288286f39..b96d23631425907c73b428060d1e89374a58336c 100644 (file)
--- a/eeze.spec
+++ b/eeze.spec
+# NOTE: for versions >= 1.8 see efl.spec
 #
 # Conditional build:
 %bcond_without static_libs     # don't build static library
 #
-%define                ecore_ver       1.0.0
-%define                svn             %{nil}
+%define                ecore_ver       1.7.10
+%define                eet_ver         1.7.10
+%define                eina_ver        1.7.10
 
 Summary:       Library for manipulating devices through udev
 Summary(pl.UTF-8):     Biblioteka do operowania urządzeniami korzystająca z udev
 Name:          eeze
-%define        subver  beta2
-Version:       1.0.0
-Release:       0.%{subver}.1
-License:       LGPL v2.1
-Group:         X11/Libraries
-Source0:       http://download.enlightenment.org/releases/%{name}-%{version}.%{subver}.tar.bz2
-# Source0-md5: dc7b009216d351ed282664f8ee47631d
-URL:           http://enlightenment.org/p.php?p=about/libs/efreet
+Version:       1.7.10
+Release:       4
+License:       BSD
+Group:         Libraries
+Source0:       http://download.enlightenment.org/releases/%{name}-%{version}.tar.bz2
+# Source0-md5: dfe17a0870e1430f7459d45e514fbbdd
+URL:           http://trac.enlightenment.org/e/wiki/Eeze
 BuildRequires: autoconf >= 2.52
 BuildRequires: automake >= 1.6
-# ecore-file; ecore-desktop for tests
+BuildRequires: ecore-con-devel >= %{ecore_ver}
 BuildRequires: ecore-devel >= %{ecore_ver}
+BuildRequires: ecore-file-devel >= %{ecore_ver}
+BuildRequires: eet-devel >= %{eet_ver}
+BuildRequires: eina-devel >= %{eina_ver}
+BuildRequires: libmount-devel >= 2.18.0
 BuildRequires: libtool
-BuildRequires: udev-devel
-BuildRequires: pkgconfig
-BuildRequires: sed >= 4.0
-Requires:      ecore-file >= %{ecore_ver}
+BuildRequires: udev-devel >= 1:148
+BuildRequires: pkgconfig >= 1:0.22
+Requires:      ecore >= %{ecore_ver}
+Requires:      eet >= %{eet_ver}
+Requires:      eina >= %{eina_ver}
+Requires:      libmount >= 2.18.0
+Requires:      udev-libs >= 1:148
+Obsoletes:     enlightenment-utils-eeze
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
-Eeze is a library for manipulating devices through udev with a simple and fast
-api. It interfaces directly with libudev, avoiding such middleman daemons as
-udisks/upower or hal, to immediately gather device information the instant it
-becomes known to the system.  This can be used to determine such things as:
-  * If a cdrom has a disk inserted
-  * The temperature of a cpu core
-  * The remaining power left in a battery
-  * The current power consumption of various parts
-  * Monitor in realtime the status of peripheral devices
+Eeze is a library for manipulating devices through udev with a simple
+and fast API. It interfaces directly with libudev, avoiding such
+middleman daemons as udisks/upower or hal, to immediately gather
+device information the instant it becomes known to the system. This
+can be used to determine such things as:
+ - If a CD-ROM has a disk inserted
+ - The temperature of a cpu core
+ - The remaining power left in a battery
+ - The current power consumption of various parts
+ - Monitor in realtime the status of peripheral devices.
   
-Each of the above examples can be performed by using only a single eeze
-function, as one of the primary focuses of the library is to reduce the
-complexity of managing devices.
+Each of the above examples can be performed by using only a single
+eeze function, as one of the primary focuses of the library is to
+reduce the complexity of managing devices.
+
+%description -l pl.UTF-8
+Eeze to bibliotek do operowania urządzeniami poprzez udev z prostym i
+szybkim API. Działa bezpośrednio z libudev, bez pośrednich demonów,
+takich jak udisks, upower czy hal, aby zebrać informacje z urządzeń
+natychmiast, kiedy staną się znane w systemie. Może to służyć do
+określania rzeczy takich jak:
+ - włożenie płyty CD
+ - termperatura rdzenia procesora
+ - pozostała pojemność baterii
+ - aktualne zużycie energii przez różne elementy
+ - monitorowanie stanu urządzeń peryferyjnych w czasie rzeczywistym.
+
+Każde z tych zapytań może być wykonane przy użyciu jedynie pojedynczej
+funkcji eeze, jako że jedną z głównych idei biblioteki jest
+ograniczenie skomplikowania zarządzania urządzeniami.
 
 %package devel
 Summary:       Eeze header files
 Summary(pl.UTF-8):     Pliki nagłówkowe Eeze
 Group:         Development/Libraries
 Requires:      %{name} = %{version}-%{release}
-# ecore-file
-BuildRequires: ecore-devel >= %{ecore_ver}
+Requires:      ecore-devel >= %{ecore_ver}
+Requires:      eina-devel >= %{eina_ver}
+Requires:      udev-devel >= 1:148
 
 %description devel
-Header files for Efreet.
+Header files for Eeze.
 
 %description devel -l pl.UTF-8
-Pliki nagłówkowe Efreet.
+Pliki nagłówkowe Eeze.
 
 %package static
-Summary:       Static Efreet library
-Summary(pl.UTF-8):     Statyczna biblioteka Efreet
+Summary:       Static Eeze library
+Summary(pl.UTF-8):     Statyczna biblioteka Eeze
 Group:         Development/Libraries
 Requires:      %{name}-devel = %{version}-%{release}
 
 %description static
-Static Efreet library.
+Static Eeze library.
 
 %description static -l pl.UTF-8
-Statyczna biblioteka Efreet.
+Statyczna biblioteka Eeze.
 
 %prep
-%setup -q -n %{name}-%{version}.%{subver}
-
-sed -i -e 's/-g -O0//' src/lib/Makefile.am
+%setup -q
 
 %build
 %{__libtoolize}
@@ -80,8 +105,12 @@ sed -i -e 's/-g -O0//' src/lib/Makefile.am
 %{__autoheader}
 %{__automake}
 %configure \
-       %{!?with_static_libs:--disable-static}
-%{__make} V=1
+       --disable-silent-rules \
+       %{!?with_static_libs:--disable-static} \
+       --with-eject=/usr/bin/eject \
+       --with-mount=/bin/mount \
+       --with-umount=/bin/umount
+%{__make}
 
 %install
 rm -rf $RPM_BUILD_ROOT
@@ -89,10 +118,6 @@ rm -rf $RPM_BUILD_ROOT
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
 
-# just tests
-rm -f $RPM_BUILD_ROOT%{_bindir}/efreet_{alloc,menu_alloc,test,spec_test,cache_test}
-rm -rf $RPM_BUILD_ROOT%{_datadir}/%{name}/test
-
 %clean
 rm -rf $RPM_BUILD_ROOT
 
@@ -101,16 +126,19 @@ rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%doc AUTHORS COPYING README
-%attr(755,root,root) %{_libdir}/libeeze%{svn}.so.*.*.*
-%attr(755,root,root) %ghost %{_libdir}/libeeze%{svn}.so.1
+%doc AUTHORS COPYING ChangeLog NEWS README TODO
+%attr(755,root,root) %{_bindir}/eeze_disk_ls
+%attr(755,root,root) %{_bindir}/eeze_mount
+%attr(755,root,root) %{_bindir}/eeze_scanner
+%attr(755,root,root) %{_bindir}/eeze_umount
+%attr(755,root,root) %{_libdir}/libeeze.so.*.*.*
+%attr(755,root,root) %ghost %{_libdir}/libeeze.so.1
 
 %files devel
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/libeeze.so
 %{_libdir}/libeeze.la
-%dir %{_includedir}/eeze-1
-%{_includedir}/eeze-1/*.h
+%{_includedir}/eeze-1
 %{_pkgconfigdir}/eeze.pc
 
 %if %{with static_libs}
This page took 0.03181 seconds and 4 git commands to generate.