]> git.pld-linux.org Git - packages/eeze.git/blobdiff - eeze.spec
- x32 rebuild
[packages/eeze.git] / eeze.spec
index 6c494646a5c505a588a4ec225a54cd9b96e419b8..b96d23631425907c73b428060d1e89374a58336c 100644 (file)
--- a/eeze.spec
+++ b/eeze.spec
@@ -1,45 +1,56 @@
+# NOTE: for versions >= 1.8 see efl.spec
 #
 # Conditional build:
 %bcond_without static_libs     # don't build static library
 #
-%define                ecore_ver       1.0.0
+%define                ecore_ver       1.7.10
+%define                eet_ver         1.7.10
+%define                eina_ver        1.7.10
 
 Summary:       Library for manipulating devices through udev
 Summary(pl.UTF-8):     Biblioteka do operowania urządzeniami korzystająca z udev
 Name:          eeze
-%define        subver  beta3
-Version:       1.0.0
-Release:       0.%{subver}.1
+Version:       1.7.10
+Release:       4
 License:       BSD
-Group:         X11/Libraries
-Source0:       http://download.enlightenment.org/releases/%{name}-%{version}.%{subver}.tar.bz2
-# Source0-md5: e24260aed69402c966e84d231935b261
+Group:         Libraries
+Source0:       http://download.enlightenment.org/releases/%{name}-%{version}.tar.bz2
+# Source0-md5: dfe17a0870e1430f7459d45e514fbbdd
 URL:           http://trac.enlightenment.org/e/wiki/Eeze
 BuildRequires: autoconf >= 2.52
 BuildRequires: automake >= 1.6
+BuildRequires: ecore-con-devel >= %{ecore_ver}
 BuildRequires: ecore-devel >= %{ecore_ver}
+BuildRequires: ecore-file-devel >= %{ecore_ver}
+BuildRequires: eet-devel >= %{eet_ver}
+BuildRequires: eina-devel >= %{eina_ver}
+BuildRequires: libmount-devel >= 2.18.0
 BuildRequires: libtool
-BuildRequires: udev-devel >= 148
+BuildRequires: udev-devel >= 1:148
 BuildRequires: pkgconfig >= 1:0.22
 Requires:      ecore >= %{ecore_ver}
-Requires:      udev-libs >= 148
+Requires:      eet >= %{eet_ver}
+Requires:      eina >= %{eina_ver}
+Requires:      libmount >= 2.18.0
+Requires:      udev-libs >= 1:148
+Obsoletes:     enlightenment-utils-eeze
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
 Eeze is a library for manipulating devices through udev with a simple
 and fast API. It interfaces directly with libudev, avoiding such
-middleman daemons as udisks/upower or hal, to immediately gather device
-information the instant it becomes known to the system. This can be
-used to determine such things as:
+middleman daemons as udisks/upower or hal, to immediately gather
+device information the instant it becomes known to the system. This
+can be used to determine such things as:
  - If a CD-ROM has a disk inserted
  - The temperature of a cpu core
  - The remaining power left in a battery
  - The current power consumption of various parts
  - Monitor in realtime the status of peripheral devices.
   
-Each of the above examples can be performed by using only a single eeze
-function, as one of the primary focuses of the library is to reduce the
-complexity of managing devices.
+Each of the above examples can be performed by using only a single
+eeze function, as one of the primary focuses of the library is to
+reduce the complexity of managing devices.
 
 %description -l pl.UTF-8
 Eeze to bibliotek do operowania urządzeniami poprzez udev z prostym i
@@ -63,7 +74,8 @@ Summary(pl.UTF-8):    Pliki nagłówkowe Eeze
 Group:         Development/Libraries
 Requires:      %{name} = %{version}-%{release}
 Requires:      ecore-devel >= %{ecore_ver}
-Requires:      udev-devel >= 148
+Requires:      eina-devel >= %{eina_ver}
+Requires:      udev-devel >= 1:148
 
 %description devel
 Header files for Eeze.
@@ -84,7 +96,7 @@ Static Eeze library.
 Statyczna biblioteka Eeze.
 
 %prep
-%setup -q -n %{name}-%{version}.%{subver}
+%setup -q
 
 %build
 %{__libtoolize}
@@ -94,7 +106,10 @@ Statyczna biblioteka Eeze.
 %{__automake}
 %configure \
        --disable-silent-rules \
-       %{!?with_static_libs:--disable-static}
+       %{!?with_static_libs:--disable-static} \
+       --with-eject=/usr/bin/eject \
+       --with-mount=/bin/mount \
+       --with-umount=/bin/umount
 %{__make}
 
 %install
@@ -103,8 +118,6 @@ rm -rf $RPM_BUILD_ROOT
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
 
-%{__rm} $RPM_BUILD_ROOT%{_bindir}/eeze_udev_test
-
 %clean
 rm -rf $RPM_BUILD_ROOT
 
@@ -113,7 +126,11 @@ rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%doc AUTHORS COPYING README TODO
+%doc AUTHORS COPYING ChangeLog NEWS README TODO
+%attr(755,root,root) %{_bindir}/eeze_disk_ls
+%attr(755,root,root) %{_bindir}/eeze_mount
+%attr(755,root,root) %{_bindir}/eeze_scanner
+%attr(755,root,root) %{_bindir}/eeze_umount
 %attr(755,root,root) %{_libdir}/libeeze.so.*.*.*
 %attr(755,root,root) %ghost %{_libdir}/libeeze.so.1
 
This page took 0.082777 seconds and 4 git commands to generate.