]> git.pld-linux.org Git - packages/eeze.git/blob - eeze.spec
- note efl.spec for later versions
[packages/eeze.git] / eeze.spec
1 # NOTE: for versions >= 1.8 see efl.spec
2 #
3 # Conditional build:
4 %bcond_without  static_libs     # don't build static library
5 #
6 %define         ecore_ver       1.7.9
7 %define         eet_ver         1.7.9
8 %define         eina_ver        1.7.9
9
10 Summary:        Library for manipulating devices through udev
11 Summary(pl.UTF-8):      Biblioteka do operowania urządzeniami korzystająca z udev
12 Name:           eeze
13 Version:        1.7.9
14 Release:        1
15 License:        BSD
16 Group:          Libraries
17 Source0:        http://download.enlightenment.org/releases/%{name}-%{version}.tar.bz2
18 # Source0-md5:  94743f4f50682b58e2761bfb5978a48a
19 URL:            http://trac.enlightenment.org/e/wiki/Eeze
20 BuildRequires:  autoconf >= 2.52
21 BuildRequires:  automake >= 1.6
22 BuildRequires:  ecore-con-devel >= %{ecore_ver}
23 BuildRequires:  ecore-devel >= %{ecore_ver}
24 BuildRequires:  ecore-file-devel >= %{ecore_ver}
25 BuildRequires:  eet-devel >= %{eet_ver}
26 BuildRequires:  eina-devel >= %{eina_ver}
27 BuildRequires:  libmount-devel >= 2.18.0
28 BuildRequires:  libtool
29 BuildRequires:  udev-devel >= 1:148
30 BuildRequires:  pkgconfig >= 1:0.22
31 Requires:       ecore >= %{ecore_ver}
32 Requires:       eet >= %{eet_ver}
33 Requires:       eina >= %{eina_ver}
34 Requires:       libmount >= 2.18.0
35 Requires:       udev-libs >= 1:148
36 Obsoletes:      enlightenment-utils-eeze
37 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
38
39 %description
40 Eeze is a library for manipulating devices through udev with a simple
41 and fast API. It interfaces directly with libudev, avoiding such
42 middleman daemons as udisks/upower or hal, to immediately gather
43 device information the instant it becomes known to the system. This
44 can be used to determine such things as:
45  - If a CD-ROM has a disk inserted
46  - The temperature of a cpu core
47  - The remaining power left in a battery
48  - The current power consumption of various parts
49  - Monitor in realtime the status of peripheral devices.
50   
51 Each of the above examples can be performed by using only a single
52 eeze function, as one of the primary focuses of the library is to
53 reduce the complexity of managing devices.
54
55 %description -l pl.UTF-8
56 Eeze to bibliotek do operowania urządzeniami poprzez udev z prostym i
57 szybkim API. Działa bezpośrednio z libudev, bez pośrednich demonów,
58 takich jak udisks, upower czy hal, aby zebrać informacje z urządzeń
59 natychmiast, kiedy staną się znane w systemie. Może to służyć do
60 określania rzeczy takich jak:
61  - włożenie płyty CD
62  - termperatura rdzenia procesora
63  - pozostała pojemność baterii
64  - aktualne zużycie energii przez różne elementy
65  - monitorowanie stanu urządzeń peryferyjnych w czasie rzeczywistym.
66
67 Każde z tych zapytań może być wykonane przy użyciu jedynie pojedynczej
68 funkcji eeze, jako że jedną z głównych idei biblioteki jest
69 ograniczenie skomplikowania zarządzania urządzeniami.
70
71 %package devel
72 Summary:        Eeze header files
73 Summary(pl.UTF-8):      Pliki nagłówkowe Eeze
74 Group:          Development/Libraries
75 Requires:       %{name} = %{version}-%{release}
76 Requires:       ecore-devel >= %{ecore_ver}
77 Requires:       eina-devel >= %{eina_ver}
78 Requires:       udev-devel >= 1:148
79
80 %description devel
81 Header files for Eeze.
82
83 %description devel -l pl.UTF-8
84 Pliki nagłówkowe Eeze.
85
86 %package static
87 Summary:        Static Eeze library
88 Summary(pl.UTF-8):      Statyczna biblioteka Eeze
89 Group:          Development/Libraries
90 Requires:       %{name}-devel = %{version}-%{release}
91
92 %description static
93 Static Eeze library.
94
95 %description static -l pl.UTF-8
96 Statyczna biblioteka Eeze.
97
98 %prep
99 %setup -q
100
101 %build
102 %{__libtoolize}
103 %{__aclocal} -I m4
104 %{__autoconf}
105 %{__autoheader}
106 %{__automake}
107 %configure \
108         --disable-silent-rules \
109         %{!?with_static_libs:--disable-static} \
110         --with-eject=/usr/bin/eject \
111         --with-mount=/bin/mount \
112         --with-umount=/bin/umount
113 %{__make}
114
115 %install
116 rm -rf $RPM_BUILD_ROOT
117
118 %{__make} install \
119         DESTDIR=$RPM_BUILD_ROOT
120
121 %clean
122 rm -rf $RPM_BUILD_ROOT
123
124 %post   -p /sbin/ldconfig
125 %postun -p /sbin/ldconfig
126
127 %files
128 %defattr(644,root,root,755)
129 %doc AUTHORS COPYING ChangeLog NEWS README TODO
130 %attr(755,root,root) %{_bindir}/eeze_disk_ls
131 %attr(755,root,root) %{_bindir}/eeze_mount
132 %attr(755,root,root) %{_bindir}/eeze_scanner
133 %attr(755,root,root) %{_bindir}/eeze_umount
134 %attr(755,root,root) %{_libdir}/libeeze.so.*.*.*
135 %attr(755,root,root) %ghost %{_libdir}/libeeze.so.1
136
137 %files devel
138 %defattr(644,root,root,755)
139 %attr(755,root,root) %{_libdir}/libeeze.so
140 %{_libdir}/libeeze.la
141 %{_includedir}/eeze-1
142 %{_pkgconfigdir}/eeze.pc
143
144 %if %{with static_libs}
145 %files static
146 %defattr(644,root,root,755)
147 %{_libdir}/libeeze.a
148 %endif
This page took 0.065914 seconds and 4 git commands to generate.