]> git.pld-linux.org Git - packages/eeze.git/blob - eeze.spec
- rel 1
[packages/eeze.git] / eeze.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static library
4 #
5 %define         ecore_ver       1.0.0
6
7 Summary:        Library for manipulating devices through udev
8 Summary(pl.UTF-8):      Biblioteka do operowania urządzeniami korzystająca z udev
9 Name:           eeze
10 Version:        1.0.0
11 Release:        1
12 License:        BSD
13 Group:          X11/Libraries
14 Source0:        http://download.enlightenment.org/releases/%{name}-%{version}.tar.bz2
15 # Source0-md5:  49123331a173f687e67a3a9c6a2115f2
16 URL:            http://trac.enlightenment.org/e/wiki/Eeze
17 BuildRequires:  autoconf >= 2.52
18 BuildRequires:  automake >= 1.6
19 BuildRequires:  ecore-devel >= %{ecore_ver}
20 BuildRequires:  libtool
21 BuildRequires:  udev-devel >= 148
22 BuildRequires:  pkgconfig >= 1:0.22
23 Requires:       ecore >= %{ecore_ver}
24 Requires:       udev-libs >= 148
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 Eeze is a library for manipulating devices through udev with a simple
29 and fast API. It interfaces directly with libudev, avoiding such
30 middleman daemons as udisks/upower or hal, to immediately gather device
31 information the instant it becomes known to the system. This can be
32 used to determine such things as:
33  - If a CD-ROM has a disk inserted
34  - The temperature of a cpu core
35  - The remaining power left in a battery
36  - The current power consumption of various parts
37  - Monitor in realtime the status of peripheral devices.
38   
39 Each of the above examples can be performed by using only a single eeze
40 function, as one of the primary focuses of the library is to reduce the
41 complexity of managing devices.
42
43 %description -l pl.UTF-8
44 Eeze to bibliotek do operowania urządzeniami poprzez udev z prostym i
45 szybkim API. Działa bezpośrednio z libudev, bez pośrednich demonów,
46 takich jak udisks, upower czy hal, aby zebrać informacje z urządzeń
47 natychmiast, kiedy staną się znane w systemie. Może to służyć do
48 określania rzeczy takich jak:
49  - włożenie płyty CD
50  - termperatura rdzenia procesora
51  - pozostała pojemność baterii
52  - aktualne zużycie energii przez różne elementy
53  - monitorowanie stanu urządzeń peryferyjnych w czasie rzeczywistym.
54
55 Każde z tych zapytań może być wykonane przy użyciu jedynie pojedynczej
56 funkcji eeze, jako że jedną z głównych idei biblioteki jest
57 ograniczenie skomplikowania zarządzania urządzeniami.
58
59 %package devel
60 Summary:        Eeze header files
61 Summary(pl.UTF-8):      Pliki nagłówkowe Eeze
62 Group:          Development/Libraries
63 Requires:       %{name} = %{version}-%{release}
64 Requires:       ecore-devel >= %{ecore_ver}
65 Requires:       udev-devel >= 148
66
67 %description devel
68 Header files for Eeze.
69
70 %description devel -l pl.UTF-8
71 Pliki nagłówkowe Eeze.
72
73 %package static
74 Summary:        Static Eeze library
75 Summary(pl.UTF-8):      Statyczna biblioteka Eeze
76 Group:          Development/Libraries
77 Requires:       %{name}-devel = %{version}-%{release}
78
79 %description static
80 Static Eeze library.
81
82 %description static -l pl.UTF-8
83 Statyczna biblioteka Eeze.
84
85 %prep
86 %setup -q
87
88 %build
89 %{__libtoolize}
90 %{__aclocal} -I m4
91 %{__autoconf}
92 %{__autoheader}
93 %{__automake}
94 %configure \
95         --disable-silent-rules \
96         %{!?with_static_libs:--disable-static}
97 %{__make}
98
99 %install
100 rm -rf $RPM_BUILD_ROOT
101
102 %{__make} install \
103         DESTDIR=$RPM_BUILD_ROOT
104
105 %{__rm} $RPM_BUILD_ROOT%{_bindir}/eeze_udev_test
106
107 %clean
108 rm -rf $RPM_BUILD_ROOT
109
110 %post   -p /sbin/ldconfig
111 %postun -p /sbin/ldconfig
112
113 %files
114 %defattr(644,root,root,755)
115 %doc AUTHORS COPYING README TODO
116 %attr(755,root,root) %{_libdir}/libeeze.so.*.*.*
117 %attr(755,root,root) %ghost %{_libdir}/libeeze.so.1
118
119 %files devel
120 %defattr(644,root,root,755)
121 %attr(755,root,root) %{_libdir}/libeeze.so
122 %{_libdir}/libeeze.la
123 %{_includedir}/eeze-1
124 %{_pkgconfigdir}/eeze.pc
125
126 %if %{with static_libs}
127 %files static
128 %defattr(644,root,root,755)
129 %{_libdir}/libeeze.a
130 %endif
This page took 0.058048 seconds and 4 git commands to generate.