]> git.pld-linux.org Git - packages/eeze.git/blob - eeze.spec
- new
[packages/eeze.git] / eeze.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static library
4 #
5 %define         ecore_ver       1.0.0
6 %define         svn             %{nil}
7
8 Summary:        Library for manipulating devices through udev
9 Summary(pl.UTF-8):      Biblioteka do operowania urządzeniami korzystająca z udev
10 Name:           eeze
11 %define subver  beta2
12 Version:        1.0.0
13 Release:        0.%{subver}.1
14 License:        LGPL v2.1
15 Group:          X11/Libraries
16 Source0:        http://download.enlightenment.org/releases/%{name}-%{version}.%{subver}.tar.bz2
17 # Source0-md5:  dc7b009216d351ed282664f8ee47631d
18 URL:            http://enlightenment.org/p.php?p=about/libs/efreet
19 BuildRequires:  autoconf >= 2.52
20 BuildRequires:  automake >= 1.6
21 # ecore-file; ecore-desktop for tests
22 BuildRequires:  ecore-devel >= %{ecore_ver}
23 BuildRequires:  libtool
24 BuildRequires:  udev-devel
25 BuildRequires:  pkgconfig
26 BuildRequires:  sed >= 4.0
27 Requires:       ecore-file >= %{ecore_ver}
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 Eeze is a library for manipulating devices through udev with a simple and fast
32 api. It interfaces directly with libudev, avoiding such middleman daemons as
33 udisks/upower or hal, to immediately gather device information the instant it
34 becomes known to the system.  This can be used to determine such things as:
35   * If a cdrom has a disk inserted
36   * The temperature of a cpu core
37   * The remaining power left in a battery
38   * The current power consumption of various parts
39   * Monitor in realtime the status of peripheral devices
40   
41 Each of the above examples can be performed by using only a single eeze
42 function, as one of the primary focuses of the library is to reduce the
43 complexity of managing devices.
44
45 %package devel
46 Summary:        Eeze header files
47 Summary(pl.UTF-8):      Pliki nagłówkowe Eeze
48 Group:          Development/Libraries
49 Requires:       %{name} = %{version}-%{release}
50 # ecore-file
51 BuildRequires:  ecore-devel >= %{ecore_ver}
52
53 %description devel
54 Header files for Efreet.
55
56 %description devel -l pl.UTF-8
57 Pliki nagłówkowe Efreet.
58
59 %package static
60 Summary:        Static Efreet library
61 Summary(pl.UTF-8):      Statyczna biblioteka Efreet
62 Group:          Development/Libraries
63 Requires:       %{name}-devel = %{version}-%{release}
64
65 %description static
66 Static Efreet library.
67
68 %description static -l pl.UTF-8
69 Statyczna biblioteka Efreet.
70
71 %prep
72 %setup -q -n %{name}-%{version}.%{subver}
73
74 sed -i -e 's/-g -O0//' src/lib/Makefile.am
75
76 %build
77 %{__libtoolize}
78 %{__aclocal} -I m4
79 %{__autoconf}
80 %{__autoheader}
81 %{__automake}
82 %configure \
83         %{!?with_static_libs:--disable-static}
84 %{__make} V=1
85
86 %install
87 rm -rf $RPM_BUILD_ROOT
88
89 %{__make} install \
90         DESTDIR=$RPM_BUILD_ROOT
91
92 # just tests
93 rm -f $RPM_BUILD_ROOT%{_bindir}/efreet_{alloc,menu_alloc,test,spec_test,cache_test}
94 rm -rf $RPM_BUILD_ROOT%{_datadir}/%{name}/test
95
96 %clean
97 rm -rf $RPM_BUILD_ROOT
98
99 %post   -p /sbin/ldconfig
100 %postun -p /sbin/ldconfig
101
102 %files
103 %defattr(644,root,root,755)
104 %doc AUTHORS COPYING README
105 %attr(755,root,root) %{_libdir}/libeeze%{svn}.so.*.*.*
106 %attr(755,root,root) %ghost %{_libdir}/libeeze%{svn}.so.1
107
108 %files devel
109 %defattr(644,root,root,755)
110 %attr(755,root,root) %{_libdir}/libeeze.so
111 %{_libdir}/libeeze.la
112 %dir %{_includedir}/eeze-1
113 %{_includedir}/eeze-1/*.h
114 %{_pkgconfigdir}/eeze.pc
115
116 %if %{with static_libs}
117 %files static
118 %defattr(644,root,root,755)
119 %{_libdir}/libeeze.a
120 %endif
This page took 0.07639 seconds and 4 git commands to generate.