]> git.pld-linux.org Git - packages/eeze.git/blob - eeze.spec
- updated to 1.1.0
[packages/eeze.git] / eeze.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static library
4 #
5 %define         ecore_ver       1.1.0
6 %define         eet_ver         1.5.0
7 %define         eina_ver        1.1.0
8
9 Summary:        Library for manipulating devices through udev
10 Summary(pl.UTF-8):      Biblioteka do operowania urządzeniami korzystająca z udev
11 Name:           eeze
12 Version:        1.1.0
13 Release:        1
14 License:        BSD
15 Group:          X11/Libraries
16 Source0:        http://download.enlightenment.org/releases/%{name}-%{version}.tar.bz2
17 # Source0-md5:  04bd5202e12b57e0dddbcca2acc52df9
18 URL:            http://trac.enlightenment.org/e/wiki/Eeze
19 BuildRequires:  autoconf >= 2.52
20 BuildRequires:  automake >= 1.6
21 BuildRequires:  ecore-con-devel >= %{ecore_ver}
22 BuildRequires:  ecore-devel >= %{ecore_ver}
23 BuildRequires:  ecore-file-devel >= %{ecore_ver}
24 BuildRequires:  eet-devel >= %{eet_ver}
25 BuildRequires:  eina-devel >= %{eina_ver}
26 BuildRequires:  libmount-devel >= 2.18.0
27 BuildRequires:  libtool
28 BuildRequires:  udev-devel >= 148
29 BuildRequires:  pkgconfig >= 1:0.22
30 Requires:       ecore >= %{ecore_ver}
31 Requires:       eet >= %{eet_ver}
32 Requires:       eina >= %{eina_ver}
33 Requires:       udev-libs >= 148
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 %description
37 Eeze is a library for manipulating devices through udev with a simple
38 and fast API. It interfaces directly with libudev, avoiding such
39 middleman daemons as udisks/upower or hal, to immediately gather
40 device information the instant it becomes known to the system. This
41 can be used to determine such things as:
42  - If a CD-ROM has a disk inserted
43  - The temperature of a cpu core
44  - The remaining power left in a battery
45  - The current power consumption of various parts
46  - Monitor in realtime the status of peripheral devices.
47   
48 Each of the above examples can be performed by using only a single
49 eeze function, as one of the primary focuses of the library is to
50 reduce the complexity of managing devices.
51
52 %description -l pl.UTF-8
53 Eeze to bibliotek do operowania urządzeniami poprzez udev z prostym i
54 szybkim API. Działa bezpośrednio z libudev, bez pośrednich demonów,
55 takich jak udisks, upower czy hal, aby zebrać informacje z urządzeń
56 natychmiast, kiedy staną się znane w systemie. Może to służyć do
57 określania rzeczy takich jak:
58  - włożenie płyty CD
59  - termperatura rdzenia procesora
60  - pozostała pojemność baterii
61  - aktualne zużycie energii przez różne elementy
62  - monitorowanie stanu urządzeń peryferyjnych w czasie rzeczywistym.
63
64 Każde z tych zapytań może być wykonane przy użyciu jedynie pojedynczej
65 funkcji eeze, jako że jedną z głównych idei biblioteki jest
66 ograniczenie skomplikowania zarządzania urządzeniami.
67
68 %package devel
69 Summary:        Eeze header files
70 Summary(pl.UTF-8):      Pliki nagłówkowe Eeze
71 Group:          Development/Libraries
72 Requires:       %{name} = %{version}-%{release}
73 Requires:       ecore-devel >= %{ecore_ver}
74 Requires:       eina-devel >= %{eina_ver}
75 Requires:       udev-devel >= 148
76
77 %description devel
78 Header files for Eeze.
79
80 %description devel -l pl.UTF-8
81 Pliki nagłówkowe Eeze.
82
83 %package static
84 Summary:        Static Eeze library
85 Summary(pl.UTF-8):      Statyczna biblioteka Eeze
86 Group:          Development/Libraries
87 Requires:       %{name}-devel = %{version}-%{release}
88
89 %description static
90 Static Eeze library.
91
92 %description static -l pl.UTF-8
93 Statyczna biblioteka Eeze.
94
95 %prep
96 %setup -q
97
98 %build
99 %{__libtoolize}
100 %{__aclocal} -I m4
101 %{__autoconf}
102 %{__autoheader}
103 %{__automake}
104 %configure \
105         --disable-silent-rules \
106         %{!?with_static_libs:--disable-static}
107 %{__make}
108
109 %install
110 rm -rf $RPM_BUILD_ROOT
111
112 %{__make} install \
113         DESTDIR=$RPM_BUILD_ROOT
114
115 %clean
116 rm -rf $RPM_BUILD_ROOT
117
118 %post   -p /sbin/ldconfig
119 %postun -p /sbin/ldconfig
120
121 %files
122 %defattr(644,root,root,755)
123 %doc AUTHORS COPYING ChangeLog NEWS README TODO
124 %attr(755,root,root) %{_bindir}/eeze_disk_ls
125 %attr(755,root,root) %{_bindir}/eeze_mount
126 %attr(755,root,root) %{_bindir}/eeze_umount
127 %attr(755,root,root) %{_libdir}/libeeze.so.*.*.*
128 %attr(755,root,root) %ghost %{_libdir}/libeeze.so.1
129 # some enlightenment package?
130 #%attr(755,root,root) %{_libdir}/enlightenment/utils/eeze_scanner
131
132 %files devel
133 %defattr(644,root,root,755)
134 %attr(755,root,root) %{_libdir}/libeeze.so
135 %{_libdir}/libeeze.la
136 %{_includedir}/eeze-1
137 %{_pkgconfigdir}/eeze.pc
138
139 %if %{with static_libs}
140 %files static
141 %defattr(644,root,root,755)
142 %{_libdir}/libeeze.a
143 %endif
This page took 0.069738 seconds and 4 git commands to generate.