]> git.pld-linux.org Git - packages/eeze.git/blob - eeze.spec
- updated to 1.0.0.beta3
[packages/eeze.git] / eeze.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static library
4 #
5 %define         ecore_ver       1.0.0
6
7 Summary:        Library for manipulating devices through udev
8 Summary(pl.UTF-8):      Biblioteka do operowania urządzeniami korzystająca z udev
9 Name:           eeze
10 %define subver  beta3
11 Version:        1.0.0
12 Release:        0.%{subver}.1
13 License:        BSD
14 Group:          X11/Libraries
15 Source0:        http://download.enlightenment.org/releases/%{name}-%{version}.%{subver}.tar.bz2
16 # Source0-md5:  e24260aed69402c966e84d231935b261
17 URL:            http://trac.enlightenment.org/e/wiki/Eeze
18 BuildRequires:  autoconf >= 2.52
19 BuildRequires:  automake >= 1.6
20 BuildRequires:  ecore-devel >= %{ecore_ver}
21 BuildRequires:  libtool
22 BuildRequires:  udev-devel >= 148
23 BuildRequires:  pkgconfig >= 1:0.22
24 Requires:       ecore >= %{ecore_ver}
25 Requires:       udev-libs >= 148
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 Eeze is a library for manipulating devices through udev with a simple
30 and fast API. It interfaces directly with libudev, avoiding such
31 middleman daemons as udisks/upower or hal, to immediately gather device
32 information the instant it becomes known to the system. This can be
33 used to determine such things as:
34  - If a CD-ROM has a disk inserted
35  - The temperature of a cpu core
36  - The remaining power left in a battery
37  - The current power consumption of various parts
38  - Monitor in realtime the status of peripheral devices.
39   
40 Each of the above examples can be performed by using only a single eeze
41 function, as one of the primary focuses of the library is to reduce the
42 complexity of managing devices.
43
44 %description -l pl.UTF-8
45 Eeze to bibliotek do operowania urządzeniami poprzez udev z prostym i
46 szybkim API. Działa bezpośrednio z libudev, bez pośrednich demonów,
47 takich jak udisks, upower czy hal, aby zebrać informacje z urządzeń
48 natychmiast, kiedy staną się znane w systemie. Może to służyć do
49 określania rzeczy takich jak:
50  - włożenie płyty CD
51  - termperatura rdzenia procesora
52  - pozostała pojemność baterii
53  - aktualne zużycie energii przez różne elementy
54  - monitorowanie stanu urządzeń peryferyjnych w czasie rzeczywistym.
55
56 Każde z tych zapytań może być wykonane przy użyciu jedynie pojedynczej
57 funkcji eeze, jako że jedną z głównych idei biblioteki jest
58 ograniczenie skomplikowania zarządzania urządzeniami.
59
60 %package devel
61 Summary:        Eeze header files
62 Summary(pl.UTF-8):      Pliki nagłówkowe Eeze
63 Group:          Development/Libraries
64 Requires:       %{name} = %{version}-%{release}
65 Requires:       ecore-devel >= %{ecore_ver}
66 Requires:       udev-devel >= 148
67
68 %description devel
69 Header files for Eeze.
70
71 %description devel -l pl.UTF-8
72 Pliki nagłówkowe Eeze.
73
74 %package static
75 Summary:        Static Eeze library
76 Summary(pl.UTF-8):      Statyczna biblioteka Eeze
77 Group:          Development/Libraries
78 Requires:       %{name}-devel = %{version}-%{release}
79
80 %description static
81 Static Eeze library.
82
83 %description static -l pl.UTF-8
84 Statyczna biblioteka Eeze.
85
86 %prep
87 %setup -q -n %{name}-%{version}.%{subver}
88
89 %build
90 %{__libtoolize}
91 %{__aclocal} -I m4
92 %{__autoconf}
93 %{__autoheader}
94 %{__automake}
95 %configure \
96         --disable-silent-rules \
97         %{!?with_static_libs:--disable-static}
98 %{__make}
99
100 %install
101 rm -rf $RPM_BUILD_ROOT
102
103 %{__make} install \
104         DESTDIR=$RPM_BUILD_ROOT
105
106 %{__rm} $RPM_BUILD_ROOT%{_bindir}/eeze_udev_test
107
108 %clean
109 rm -rf $RPM_BUILD_ROOT
110
111 %post   -p /sbin/ldconfig
112 %postun -p /sbin/ldconfig
113
114 %files
115 %defattr(644,root,root,755)
116 %doc AUTHORS COPYING README TODO
117 %attr(755,root,root) %{_libdir}/libeeze.so.*.*.*
118 %attr(755,root,root) %ghost %{_libdir}/libeeze.so.1
119
120 %files devel
121 %defattr(644,root,root,755)
122 %attr(755,root,root) %{_libdir}/libeeze.so
123 %{_libdir}/libeeze.la
124 %{_includedir}/eeze-1
125 %{_pkgconfigdir}/eeze.pc
126
127 %if %{with static_libs}
128 %files static
129 %defattr(644,root,root,755)
130 %{_libdir}/libeeze.a
131 %endif
This page took 0.139726 seconds and 3 git commands to generate.