]> git.pld-linux.org Git - packages/eeze.git/blob - eeze.spec
- updated to 1.7.7
[packages/eeze.git] / eeze.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static library
4 #
5 %define         ecore_ver       1.7.7
6 %define         eet_ver         1.7.7
7 %define         eina_ver        1.7.7
8
9 Summary:        Library for manipulating devices through udev
10 Summary(pl.UTF-8):      Biblioteka do operowania urządzeniami korzystająca z udev
11 Name:           eeze
12 Version:        1.7.7
13 Release:        1
14 License:        BSD
15 Group:          Libraries
16 Source0:        http://download.enlightenment.org/releases/%{name}-%{version}.tar.bz2
17 # Source0-md5:  eff2a8f2577e93fc65a33b80792722ea
18 URL:            http://trac.enlightenment.org/e/wiki/Eeze
19 BuildRequires:  autoconf >= 2.52
20 BuildRequires:  automake >= 1.6
21 BuildRequires:  ecore-con-devel >= %{ecore_ver}
22 BuildRequires:  ecore-devel >= %{ecore_ver}
23 BuildRequires:  ecore-file-devel >= %{ecore_ver}
24 BuildRequires:  eet-devel >= %{eet_ver}
25 BuildRequires:  eina-devel >= %{eina_ver}
26 BuildRequires:  libmount-devel >= 2.18.0
27 BuildRequires:  libtool
28 BuildRequires:  udev-devel >= 1:148
29 BuildRequires:  pkgconfig >= 1:0.22
30 Requires:       ecore >= %{ecore_ver}
31 Requires:       eet >= %{eet_ver}
32 Requires:       eina >= %{eina_ver}
33 Requires:       libmount >= 2.18.0
34 Requires:       udev-libs >= 1:148
35 Obsoletes:      enlightenment-utils-eeze
36 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38 %description
39 Eeze is a library for manipulating devices through udev with a simple
40 and fast API. It interfaces directly with libudev, avoiding such
41 middleman daemons as udisks/upower or hal, to immediately gather
42 device information the instant it becomes known to the system. This
43 can be used to determine such things as:
44  - If a CD-ROM has a disk inserted
45  - The temperature of a cpu core
46  - The remaining power left in a battery
47  - The current power consumption of various parts
48  - Monitor in realtime the status of peripheral devices.
49   
50 Each of the above examples can be performed by using only a single
51 eeze function, as one of the primary focuses of the library is to
52 reduce the complexity of managing devices.
53
54 %description -l pl.UTF-8
55 Eeze to bibliotek do operowania urządzeniami poprzez udev z prostym i
56 szybkim API. Działa bezpośrednio z libudev, bez pośrednich demonów,
57 takich jak udisks, upower czy hal, aby zebrać informacje z urządzeń
58 natychmiast, kiedy staną się znane w systemie. Może to służyć do
59 określania rzeczy takich jak:
60  - włożenie płyty CD
61  - termperatura rdzenia procesora
62  - pozostała pojemność baterii
63  - aktualne zużycie energii przez różne elementy
64  - monitorowanie stanu urządzeń peryferyjnych w czasie rzeczywistym.
65
66 Każde z tych zapytań może być wykonane przy użyciu jedynie pojedynczej
67 funkcji eeze, jako że jedną z głównych idei biblioteki jest
68 ograniczenie skomplikowania zarządzania urządzeniami.
69
70 %package devel
71 Summary:        Eeze header files
72 Summary(pl.UTF-8):      Pliki nagłówkowe Eeze
73 Group:          Development/Libraries
74 Requires:       %{name} = %{version}-%{release}
75 Requires:       ecore-devel >= %{ecore_ver}
76 Requires:       eina-devel >= %{eina_ver}
77 Requires:       udev-devel >= 1:148
78
79 %description devel
80 Header files for Eeze.
81
82 %description devel -l pl.UTF-8
83 Pliki nagłówkowe Eeze.
84
85 %package static
86 Summary:        Static Eeze library
87 Summary(pl.UTF-8):      Statyczna biblioteka Eeze
88 Group:          Development/Libraries
89 Requires:       %{name}-devel = %{version}-%{release}
90
91 %description static
92 Static Eeze library.
93
94 %description static -l pl.UTF-8
95 Statyczna biblioteka Eeze.
96
97 %prep
98 %setup -q
99
100 %build
101 %{__libtoolize}
102 %{__aclocal} -I m4
103 %{__autoconf}
104 %{__autoheader}
105 %{__automake}
106 %configure \
107         --disable-silent-rules \
108         %{!?with_static_libs:--disable-static} \
109         --with-eject=/usr/bin/eject \
110         --with-mount=/bin/mount \
111         --with-umount=/bin/umount
112 %{__make}
113
114 %install
115 rm -rf $RPM_BUILD_ROOT
116
117 %{__make} install \
118         DESTDIR=$RPM_BUILD_ROOT
119
120 %clean
121 rm -rf $RPM_BUILD_ROOT
122
123 %post   -p /sbin/ldconfig
124 %postun -p /sbin/ldconfig
125
126 %files
127 %defattr(644,root,root,755)
128 %doc AUTHORS COPYING ChangeLog NEWS README TODO
129 %attr(755,root,root) %{_bindir}/eeze_disk_ls
130 %attr(755,root,root) %{_bindir}/eeze_mount
131 %attr(755,root,root) %{_bindir}/eeze_scanner
132 %attr(755,root,root) %{_bindir}/eeze_umount
133 %attr(755,root,root) %{_libdir}/libeeze.so.*.*.*
134 %attr(755,root,root) %ghost %{_libdir}/libeeze.so.1
135
136 %files devel
137 %defattr(644,root,root,755)
138 %attr(755,root,root) %{_libdir}/libeeze.so
139 %{_libdir}/libeeze.la
140 %{_includedir}/eeze-1
141 %{_pkgconfigdir}/eeze.pc
142
143 %if %{with static_libs}
144 %files static
145 %defattr(644,root,root,755)
146 %{_libdir}/libeeze.a
147 %endif
This page took 0.035175 seconds and 3 git commands to generate.