]> git.pld-linux.org Git - packages/eeze.git/blob - eeze.spec
372c7e8dcaaae03a73a0d468ce82d7cb63b9f2f5
[packages/eeze.git] / eeze.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static library
4 #
5 %define         ecore_ver       1.7.5
6 %define         eet_ver         1.7.5
7 %define         eina_ver        1.7.5
8
9 Summary:        Library for manipulating devices through udev
10 Summary(pl.UTF-8):      Biblioteka do operowania urządzeniami korzystająca z udev
11 Name:           eeze
12 Version:        1.7.5
13 Release:        1
14 License:        BSD
15 Group:          Libraries
16 Source0:        http://download.enlightenment.org/releases/%{name}-%{version}.tar.bz2
17 # Source0-md5:  0891f831e2d25bd48a5c26e8793b1714
18 URL:            http://trac.enlightenment.org/e/wiki/Eeze
19 BuildRequires:  autoconf >= 2.52
20 BuildRequires:  automake >= 1.6
21 BuildRequires:  ecore-con-devel >= %{ecore_ver}
22 BuildRequires:  ecore-devel >= %{ecore_ver}
23 BuildRequires:  ecore-file-devel >= %{ecore_ver}
24 BuildRequires:  eet-devel >= %{eet_ver}
25 BuildRequires:  eina-devel >= %{eina_ver}
26 BuildRequires:  libmount-devel >= 2.18.0
27 BuildRequires:  libtool
28 BuildRequires:  udev-devel >= 1:148
29 BuildRequires:  pkgconfig >= 1:0.22
30 Requires:       ecore >= %{ecore_ver}
31 Requires:       eet >= %{eet_ver}
32 Requires:       eina >= %{eina_ver}
33 Requires:       udev-libs >= 1:148
34 Obsoletes:      enlightenment-utils-eeze
35 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37 %description
38 Eeze is a library for manipulating devices through udev with a simple
39 and fast API. It interfaces directly with libudev, avoiding such
40 middleman daemons as udisks/upower or hal, to immediately gather
41 device information the instant it becomes known to the system. This
42 can be used to determine such things as:
43  - If a CD-ROM has a disk inserted
44  - The temperature of a cpu core
45  - The remaining power left in a battery
46  - The current power consumption of various parts
47  - Monitor in realtime the status of peripheral devices.
48   
49 Each of the above examples can be performed by using only a single
50 eeze function, as one of the primary focuses of the library is to
51 reduce the complexity of managing devices.
52
53 %description -l pl.UTF-8
54 Eeze to bibliotek do operowania urządzeniami poprzez udev z prostym i
55 szybkim API. Działa bezpośrednio z libudev, bez pośrednich demonów,
56 takich jak udisks, upower czy hal, aby zebrać informacje z urządzeń
57 natychmiast, kiedy staną się znane w systemie. Może to służyć do
58 określania rzeczy takich jak:
59  - włożenie płyty CD
60  - termperatura rdzenia procesora
61  - pozostała pojemność baterii
62  - aktualne zużycie energii przez różne elementy
63  - monitorowanie stanu urządzeń peryferyjnych w czasie rzeczywistym.
64
65 Każde z tych zapytań może być wykonane przy użyciu jedynie pojedynczej
66 funkcji eeze, jako że jedną z głównych idei biblioteki jest
67 ograniczenie skomplikowania zarządzania urządzeniami.
68
69 %package devel
70 Summary:        Eeze header files
71 Summary(pl.UTF-8):      Pliki nagłówkowe Eeze
72 Group:          Development/Libraries
73 Requires:       %{name} = %{version}-%{release}
74 Requires:       ecore-devel >= %{ecore_ver}
75 Requires:       eina-devel >= %{eina_ver}
76 Requires:       udev-devel >= 1:148
77
78 %description devel
79 Header files for Eeze.
80
81 %description devel -l pl.UTF-8
82 Pliki nagłówkowe Eeze.
83
84 %package static
85 Summary:        Static Eeze library
86 Summary(pl.UTF-8):      Statyczna biblioteka Eeze
87 Group:          Development/Libraries
88 Requires:       %{name}-devel = %{version}-%{release}
89
90 %description static
91 Static Eeze library.
92
93 %description static -l pl.UTF-8
94 Statyczna biblioteka Eeze.
95
96 %prep
97 %setup -q
98
99 %build
100 %{__libtoolize}
101 %{__aclocal} -I m4
102 %{__autoconf}
103 %{__autoheader}
104 %{__automake}
105 %configure \
106         --disable-silent-rules \
107         %{!?with_static_libs:--disable-static} \
108         --with-eject=/usr/bin/eject \
109         --with-mount=/bin/mount \
110         --with-umount=/bin/umount
111 %{__make}
112
113 %install
114 rm -rf $RPM_BUILD_ROOT
115
116 %{__make} install \
117         DESTDIR=$RPM_BUILD_ROOT
118
119 %clean
120 rm -rf $RPM_BUILD_ROOT
121
122 %post   -p /sbin/ldconfig
123 %postun -p /sbin/ldconfig
124
125 %files
126 %defattr(644,root,root,755)
127 %doc AUTHORS COPYING ChangeLog NEWS README TODO
128 %attr(755,root,root) %{_bindir}/eeze_disk_ls
129 %attr(755,root,root) %{_bindir}/eeze_mount
130 %attr(755,root,root) %{_bindir}/eeze_scanner
131 %attr(755,root,root) %{_bindir}/eeze_umount
132 %attr(755,root,root) %{_libdir}/libeeze.so.*.*.*
133 %attr(755,root,root) %ghost %{_libdir}/libeeze.so.1
134
135 %files devel
136 %defattr(644,root,root,755)
137 %attr(755,root,root) %{_libdir}/libeeze.so
138 %{_libdir}/libeeze.la
139 %{_includedir}/eeze-1
140 %{_pkgconfigdir}/eeze.pc
141
142 %if %{with static_libs}
143 %files static
144 %defattr(644,root,root,755)
145 %{_libdir}/libeeze.a
146 %endif
This page took 0.078533 seconds and 2 git commands to generate.