]> git.pld-linux.org Git - packages/eeze.git/blob - eeze.spec
- updated to 1.2.0
[packages/eeze.git] / eeze.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static library
4 #
5 %define         ecore_ver       1.2.0
6 %define         eet_ver         1.6.0
7 %define         eina_ver        1.2.0
8
9 Summary:        Library for manipulating devices through udev
10 Summary(pl.UTF-8):      Biblioteka do operowania urządzeniami korzystająca z udev
11 Name:           eeze
12 Version:        1.2.0
13 Release:        1
14 License:        BSD
15 Group:          X11/Libraries
16 Source0:        http://download.enlightenment.org/releases/%{name}-%{version}.tar.bz2
17 # Source0-md5:  1483b8a0868a1537eb75a3f24875bbad
18 URL:            http://trac.enlightenment.org/e/wiki/Eeze
19 BuildRequires:  autoconf >= 2.52
20 BuildRequires:  automake >= 1.6
21 BuildRequires:  ecore-con-devel >= %{ecore_ver}
22 BuildRequires:  ecore-devel >= %{ecore_ver}
23 BuildRequires:  ecore-file-devel >= %{ecore_ver}
24 BuildRequires:  eet-devel >= %{eet_ver}
25 BuildRequires:  eina-devel >= %{eina_ver}
26 BuildRequires:  libmount-devel >= 2.18.0
27 BuildRequires:  libtool
28 BuildRequires:  udev-devel >= 1:148
29 BuildRequires:  pkgconfig >= 1:0.22
30 Requires:       ecore >= %{ecore_ver}
31 Requires:       eet >= %{eet_ver}
32 Requires:       eina >= %{eina_ver}
33 Requires:       udev-libs >= 1:148
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 %description
37 Eeze is a library for manipulating devices through udev with a simple
38 and fast API. It interfaces directly with libudev, avoiding such
39 middleman daemons as udisks/upower or hal, to immediately gather
40 device information the instant it becomes known to the system. This
41 can be used to determine such things as:
42  - If a CD-ROM has a disk inserted
43  - The temperature of a cpu core
44  - The remaining power left in a battery
45  - The current power consumption of various parts
46  - Monitor in realtime the status of peripheral devices.
47   
48 Each of the above examples can be performed by using only a single
49 eeze function, as one of the primary focuses of the library is to
50 reduce the complexity of managing devices.
51
52 %description -l pl.UTF-8
53 Eeze to bibliotek do operowania urządzeniami poprzez udev z prostym i
54 szybkim API. Działa bezpośrednio z libudev, bez pośrednich demonów,
55 takich jak udisks, upower czy hal, aby zebrać informacje z urządzeń
56 natychmiast, kiedy staną się znane w systemie. Może to służyć do
57 określania rzeczy takich jak:
58  - włożenie płyty CD
59  - termperatura rdzenia procesora
60  - pozostała pojemność baterii
61  - aktualne zużycie energii przez różne elementy
62  - monitorowanie stanu urządzeń peryferyjnych w czasie rzeczywistym.
63
64 Każde z tych zapytań może być wykonane przy użyciu jedynie pojedynczej
65 funkcji eeze, jako że jedną z głównych idei biblioteki jest
66 ograniczenie skomplikowania zarządzania urządzeniami.
67
68 %package devel
69 Summary:        Eeze header files
70 Summary(pl.UTF-8):      Pliki nagłówkowe Eeze
71 Group:          Development/Libraries
72 Requires:       %{name} = %{version}-%{release}
73 Requires:       ecore-devel >= %{ecore_ver}
74 Requires:       eina-devel >= %{eina_ver}
75 Requires:       udev-devel >= 1:148
76
77 %description devel
78 Header files for Eeze.
79
80 %description devel -l pl.UTF-8
81 Pliki nagłówkowe Eeze.
82
83 %package static
84 Summary:        Static Eeze library
85 Summary(pl.UTF-8):      Statyczna biblioteka Eeze
86 Group:          Development/Libraries
87 Requires:       %{name}-devel = %{version}-%{release}
88
89 %description static
90 Static Eeze library.
91
92 %description static -l pl.UTF-8
93 Statyczna biblioteka Eeze.
94
95 %package -n enlightenment-utils-eeze
96 Summary:        Eeze library utils for enlightenment
97 #Summary(pl.UTF-8):     
98 Group:          Development/Libraries
99 Requires:       %{name} = %{version}-%{release}
100
101 %description -n enlightenment-utils-eeze
102 Eeze library utils for enlightenment.
103
104 %prep
105 %setup -q
106
107 %build
108 %{__libtoolize}
109 %{__aclocal} -I m4
110 %{__autoconf}
111 %{__autoheader}
112 %{__automake}
113 %configure \
114         --disable-silent-rules \
115         %{!?with_static_libs:--disable-static} \
116         --with-eject=/usr/bin/eject \
117         --with-mount=/bin/mount \
118         --with-umount=/bin/umount
119 %{__make}
120
121 %install
122 rm -rf $RPM_BUILD_ROOT
123
124 %{__make} install \
125         DESTDIR=$RPM_BUILD_ROOT
126
127 %clean
128 rm -rf $RPM_BUILD_ROOT
129
130 %post   -p /sbin/ldconfig
131 %postun -p /sbin/ldconfig
132
133 %files
134 %defattr(644,root,root,755)
135 %doc AUTHORS COPYING ChangeLog NEWS README TODO
136 %attr(755,root,root) %{_bindir}/eeze_disk_ls
137 %attr(755,root,root) %{_bindir}/eeze_mount
138 %attr(755,root,root) %{_bindir}/eeze_umount
139 %attr(755,root,root) %{_libdir}/libeeze.so.*.*.*
140 %attr(755,root,root) %ghost %{_libdir}/libeeze.so.1
141
142 %files devel
143 %defattr(644,root,root,755)
144 %attr(755,root,root) %{_libdir}/libeeze.so
145 %{_libdir}/libeeze.la
146 %{_includedir}/eeze-1
147 %{_pkgconfigdir}/eeze.pc
148
149 %if %{with static_libs}
150 %files static
151 %defattr(644,root,root,755)
152 %{_libdir}/libeeze.a
153 %endif
154
155 %files -n enlightenment-utils-eeze
156 %defattr(644,root,root,755)
157 %attr(755,root,root) %{_libdir}/enlightenment/utils/eeze_scanner
This page took 0.053818 seconds and 3 git commands to generate.