]> git.pld-linux.org Git - packages/eeze.git/blame - eeze.spec
- updated to 1.7.9
[packages/eeze.git] / eeze.spec
CommitLineData
1f22bc91 1#
2# Conditional build:
3%bcond_without static_libs # don't build static library
4#
ffee8fd1
JB
5%define ecore_ver 1.7.9
6%define eet_ver 1.7.9
7%define eina_ver 1.7.9
1f22bc91 8
9Summary: Library for manipulating devices through udev
10Summary(pl.UTF-8): Biblioteka do operowania urządzeniami korzystająca z udev
11Name: eeze
ffee8fd1 12Version: 1.7.9
ccd39455 13Release: 1
a786efc1 14License: BSD
ccd39455 15Group: Libraries
76ec9f2e 16Source0: http://download.enlightenment.org/releases/%{name}-%{version}.tar.bz2
ffee8fd1 17# Source0-md5: 94743f4f50682b58e2761bfb5978a48a
a786efc1 18URL: http://trac.enlightenment.org/e/wiki/Eeze
1f22bc91 19BuildRequires: autoconf >= 2.52
20BuildRequires: automake >= 1.6
1a99e44e 21BuildRequires: ecore-con-devel >= %{ecore_ver}
1f22bc91 22BuildRequires: ecore-devel >= %{ecore_ver}
1a99e44e
JB
23BuildRequires: ecore-file-devel >= %{ecore_ver}
24BuildRequires: eet-devel >= %{eet_ver}
25BuildRequires: eina-devel >= %{eina_ver}
26BuildRequires: libmount-devel >= 2.18.0
1f22bc91 27BuildRequires: libtool
0b03b2ac 28BuildRequires: udev-devel >= 1:148
a786efc1
JB
29BuildRequires: pkgconfig >= 1:0.22
30Requires: ecore >= %{ecore_ver}
1a99e44e
JB
31Requires: eet >= %{eet_ver}
32Requires: eina >= %{eina_ver}
33fe17aa 33Requires: libmount >= 2.18.0
0b03b2ac 34Requires: udev-libs >= 1:148
ccd39455 35Obsoletes: enlightenment-utils-eeze
1f22bc91 36BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38%description
a786efc1
JB
39Eeze is a library for manipulating devices through udev with a simple
40and fast API. It interfaces directly with libudev, avoiding such
107dec0f
JB
41middleman daemons as udisks/upower or hal, to immediately gather
42device information the instant it becomes known to the system. This
43can be used to determine such things as:
a786efc1
JB
44 - If a CD-ROM has a disk inserted
45 - The temperature of a cpu core
46 - The remaining power left in a battery
47 - The current power consumption of various parts
48 - Monitor in realtime the status of peripheral devices.
1f22bc91 49
107dec0f
JB
50Each of the above examples can be performed by using only a single
51eeze function, as one of the primary focuses of the library is to
52reduce the complexity of managing devices.
1f22bc91 53
a786efc1
JB
54%description -l pl.UTF-8
55Eeze to bibliotek do operowania urządzeniami poprzez udev z prostym i
56szybkim API. Działa bezpośrednio z libudev, bez pośrednich demonów,
57takich jak udisks, upower czy hal, aby zebrać informacje z urządzeń
58natychmiast, kiedy staną się znane w systemie. Może to służyć do
59określania rzeczy takich jak:
60 - włożenie płyty CD
61 - termperatura rdzenia procesora
62 - pozostała pojemność baterii
63 - aktualne zużycie energii przez różne elementy
64 - monitorowanie stanu urządzeń peryferyjnych w czasie rzeczywistym.
65
66Każde z tych zapytań może być wykonane przy użyciu jedynie pojedynczej
67funkcji eeze, jako że jedną z głównych idei biblioteki jest
68ograniczenie skomplikowania zarządzania urządzeniami.
69
1f22bc91 70%package devel
71Summary: Eeze header files
72Summary(pl.UTF-8): Pliki nagłówkowe Eeze
73Group: Development/Libraries
74Requires: %{name} = %{version}-%{release}
a786efc1 75Requires: ecore-devel >= %{ecore_ver}
1a99e44e 76Requires: eina-devel >= %{eina_ver}
0b03b2ac 77Requires: udev-devel >= 1:148
1f22bc91 78
79%description devel
a786efc1 80Header files for Eeze.
1f22bc91 81
82%description devel -l pl.UTF-8
a786efc1 83Pliki nagłówkowe Eeze.
1f22bc91 84
85%package static
a786efc1
JB
86Summary: Static Eeze library
87Summary(pl.UTF-8): Statyczna biblioteka Eeze
1f22bc91 88Group: Development/Libraries
89Requires: %{name}-devel = %{version}-%{release}
90
91%description static
a786efc1 92Static Eeze library.
1f22bc91 93
94%description static -l pl.UTF-8
a786efc1 95Statyczna biblioteka Eeze.
1f22bc91 96
97%prep
76ec9f2e 98%setup -q
1f22bc91 99
1f22bc91 100%build
101%{__libtoolize}
102%{__aclocal} -I m4
103%{__autoconf}
104%{__autoheader}
105%{__automake}
106%configure \
a786efc1 107 --disable-silent-rules \
d868083e 108 %{!?with_static_libs:--disable-static} \
109 --with-eject=/usr/bin/eject \
110 --with-mount=/bin/mount \
111 --with-umount=/bin/umount
a786efc1 112%{__make}
1f22bc91 113
114%install
115rm -rf $RPM_BUILD_ROOT
116
117%{__make} install \
118 DESTDIR=$RPM_BUILD_ROOT
119
1f22bc91 120%clean
121rm -rf $RPM_BUILD_ROOT
122
123%post -p /sbin/ldconfig
124%postun -p /sbin/ldconfig
125
126%files
127%defattr(644,root,root,755)
1a99e44e
JB
128%doc AUTHORS COPYING ChangeLog NEWS README TODO
129%attr(755,root,root) %{_bindir}/eeze_disk_ls
130%attr(755,root,root) %{_bindir}/eeze_mount
ccd39455 131%attr(755,root,root) %{_bindir}/eeze_scanner
1a99e44e 132%attr(755,root,root) %{_bindir}/eeze_umount
a786efc1
JB
133%attr(755,root,root) %{_libdir}/libeeze.so.*.*.*
134%attr(755,root,root) %ghost %{_libdir}/libeeze.so.1
1f22bc91 135
136%files devel
137%defattr(644,root,root,755)
138%attr(755,root,root) %{_libdir}/libeeze.so
139%{_libdir}/libeeze.la
a786efc1 140%{_includedir}/eeze-1
1f22bc91 141%{_pkgconfigdir}/eeze.pc
142
143%if %{with static_libs}
144%files static
145%defattr(644,root,root,755)
146%{_libdir}/libeeze.a
147%endif
This page took 0.080718 seconds and 4 git commands to generate.