]> git.pld-linux.org Git - packages/eeze.git/blame - eeze.spec
- x32 rebuild
[packages/eeze.git] / eeze.spec
CommitLineData
75df9446 1# NOTE: for versions >= 1.8 see efl.spec
1f22bc91 2#
3# Conditional build:
4%bcond_without static_libs # don't build static library
5#
1845978b
JB
6%define ecore_ver 1.7.10
7%define eet_ver 1.7.10
8%define eina_ver 1.7.10
1f22bc91 9
10Summary: Library for manipulating devices through udev
11Summary(pl.UTF-8): Biblioteka do operowania urządzeniami korzystająca z udev
12Name: eeze
1845978b 13Version: 1.7.10
f70ce826 14Release: 4
a786efc1 15License: BSD
ccd39455 16Group: Libraries
76ec9f2e 17Source0: http://download.enlightenment.org/releases/%{name}-%{version}.tar.bz2
1845978b 18# Source0-md5: dfe17a0870e1430f7459d45e514fbbdd
a786efc1 19URL: http://trac.enlightenment.org/e/wiki/Eeze
1f22bc91 20BuildRequires: autoconf >= 2.52
21BuildRequires: automake >= 1.6
1a99e44e 22BuildRequires: ecore-con-devel >= %{ecore_ver}
1f22bc91 23BuildRequires: ecore-devel >= %{ecore_ver}
1a99e44e
JB
24BuildRequires: ecore-file-devel >= %{ecore_ver}
25BuildRequires: eet-devel >= %{eet_ver}
26BuildRequires: eina-devel >= %{eina_ver}
27BuildRequires: libmount-devel >= 2.18.0
1f22bc91 28BuildRequires: libtool
0b03b2ac 29BuildRequires: udev-devel >= 1:148
a786efc1
JB
30BuildRequires: pkgconfig >= 1:0.22
31Requires: ecore >= %{ecore_ver}
1a99e44e
JB
32Requires: eet >= %{eet_ver}
33Requires: eina >= %{eina_ver}
33fe17aa 34Requires: libmount >= 2.18.0
0b03b2ac 35Requires: udev-libs >= 1:148
ccd39455 36Obsoletes: enlightenment-utils-eeze
1f22bc91 37BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
38
39%description
a786efc1
JB
40Eeze is a library for manipulating devices through udev with a simple
41and fast API. It interfaces directly with libudev, avoiding such
107dec0f
JB
42middleman daemons as udisks/upower or hal, to immediately gather
43device information the instant it becomes known to the system. This
44can be used to determine such things as:
a786efc1
JB
45 - If a CD-ROM has a disk inserted
46 - The temperature of a cpu core
47 - The remaining power left in a battery
48 - The current power consumption of various parts
49 - Monitor in realtime the status of peripheral devices.
1f22bc91 50
107dec0f
JB
51Each of the above examples can be performed by using only a single
52eeze function, as one of the primary focuses of the library is to
53reduce the complexity of managing devices.
1f22bc91 54
a786efc1
JB
55%description -l pl.UTF-8
56Eeze to bibliotek do operowania urządzeniami poprzez udev z prostym i
57szybkim API. Działa bezpośrednio z libudev, bez pośrednich demonów,
58takich jak udisks, upower czy hal, aby zebrać informacje z urządzeń
59natychmiast, kiedy staną się znane w systemie. Może to służyć do
60określania rzeczy takich jak:
61 - włożenie płyty CD
62 - termperatura rdzenia procesora
63 - pozostała pojemność baterii
64 - aktualne zużycie energii przez różne elementy
65 - monitorowanie stanu urządzeń peryferyjnych w czasie rzeczywistym.
66
67Każde z tych zapytań może być wykonane przy użyciu jedynie pojedynczej
68funkcji eeze, jako że jedną z głównych idei biblioteki jest
69ograniczenie skomplikowania zarządzania urządzeniami.
70
1f22bc91 71%package devel
72Summary: Eeze header files
73Summary(pl.UTF-8): Pliki nagłówkowe Eeze
74Group: Development/Libraries
75Requires: %{name} = %{version}-%{release}
a786efc1 76Requires: ecore-devel >= %{ecore_ver}
1a99e44e 77Requires: eina-devel >= %{eina_ver}
0b03b2ac 78Requires: udev-devel >= 1:148
1f22bc91 79
80%description devel
a786efc1 81Header files for Eeze.
1f22bc91 82
83%description devel -l pl.UTF-8
a786efc1 84Pliki nagłówkowe Eeze.
1f22bc91 85
86%package static
a786efc1
JB
87Summary: Static Eeze library
88Summary(pl.UTF-8): Statyczna biblioteka Eeze
1f22bc91 89Group: Development/Libraries
90Requires: %{name}-devel = %{version}-%{release}
91
92%description static
a786efc1 93Static Eeze library.
1f22bc91 94
95%description static -l pl.UTF-8
a786efc1 96Statyczna biblioteka Eeze.
1f22bc91 97
98%prep
76ec9f2e 99%setup -q
1f22bc91 100
1f22bc91 101%build
102%{__libtoolize}
103%{__aclocal} -I m4
104%{__autoconf}
105%{__autoheader}
106%{__automake}
107%configure \
a786efc1 108 --disable-silent-rules \
d868083e 109 %{!?with_static_libs:--disable-static} \
110 --with-eject=/usr/bin/eject \
111 --with-mount=/bin/mount \
112 --with-umount=/bin/umount
a786efc1 113%{__make}
1f22bc91 114
115%install
116rm -rf $RPM_BUILD_ROOT
117
118%{__make} install \
119 DESTDIR=$RPM_BUILD_ROOT
120
1f22bc91 121%clean
122rm -rf $RPM_BUILD_ROOT
123
124%post -p /sbin/ldconfig
125%postun -p /sbin/ldconfig
126
127%files
128%defattr(644,root,root,755)
1a99e44e
JB
129%doc AUTHORS COPYING ChangeLog NEWS README TODO
130%attr(755,root,root) %{_bindir}/eeze_disk_ls
131%attr(755,root,root) %{_bindir}/eeze_mount
ccd39455 132%attr(755,root,root) %{_bindir}/eeze_scanner
1a99e44e 133%attr(755,root,root) %{_bindir}/eeze_umount
a786efc1
JB
134%attr(755,root,root) %{_libdir}/libeeze.so.*.*.*
135%attr(755,root,root) %ghost %{_libdir}/libeeze.so.1
1f22bc91 136
137%files devel
138%defattr(644,root,root,755)
139%attr(755,root,root) %{_libdir}/libeeze.so
140%{_libdir}/libeeze.la
a786efc1 141%{_includedir}/eeze-1
1f22bc91 142%{_pkgconfigdir}/eeze.pc
143
144%if %{with static_libs}
145%files static
146%defattr(644,root,root,755)
147%{_libdir}/libeeze.a
148%endif
This page took 0.06341 seconds and 4 git commands to generate.