]> git.pld-linux.org Git - packages/eeze.git/blame - eeze.spec
- force mount, umount, eject paths
[packages/eeze.git] / eeze.spec
CommitLineData
1f22bc91 1#
2# Conditional build:
3%bcond_without static_libs # don't build static library
4#
1a99e44e
JB
5%define ecore_ver 1.1.0
6%define eet_ver 1.5.0
7%define eina_ver 1.1.0
1f22bc91 8
9Summary: Library for manipulating devices through udev
10Summary(pl.UTF-8): Biblioteka do operowania urządzeniami korzystająca z udev
11Name: eeze
1a99e44e 12Version: 1.1.0
d868083e 13Release: 2
a786efc1 14License: BSD
1f22bc91 15Group: X11/Libraries
76ec9f2e 16Source0: http://download.enlightenment.org/releases/%{name}-%{version}.tar.bz2
1a99e44e 17# Source0-md5: 04bd5202e12b57e0dddbcca2acc52df9
a786efc1 18URL: http://trac.enlightenment.org/e/wiki/Eeze
1f22bc91 19BuildRequires: autoconf >= 2.52
20BuildRequires: automake >= 1.6
1a99e44e 21BuildRequires: ecore-con-devel >= %{ecore_ver}
1f22bc91 22BuildRequires: ecore-devel >= %{ecore_ver}
1a99e44e
JB
23BuildRequires: ecore-file-devel >= %{ecore_ver}
24BuildRequires: eet-devel >= %{eet_ver}
25BuildRequires: eina-devel >= %{eina_ver}
26BuildRequires: libmount-devel >= 2.18.0
1f22bc91 27BuildRequires: libtool
a786efc1
JB
28BuildRequires: udev-devel >= 148
29BuildRequires: pkgconfig >= 1:0.22
30Requires: ecore >= %{ecore_ver}
1a99e44e
JB
31Requires: eet >= %{eet_ver}
32Requires: eina >= %{eina_ver}
a786efc1 33Requires: udev-libs >= 148
1f22bc91 34BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36%description
a786efc1
JB
37Eeze is a library for manipulating devices through udev with a simple
38and fast API. It interfaces directly with libudev, avoiding such
107dec0f
JB
39middleman daemons as udisks/upower or hal, to immediately gather
40device information the instant it becomes known to the system. This
41can be used to determine such things as:
a786efc1
JB
42 - If a CD-ROM has a disk inserted
43 - The temperature of a cpu core
44 - The remaining power left in a battery
45 - The current power consumption of various parts
46 - Monitor in realtime the status of peripheral devices.
1f22bc91 47
107dec0f
JB
48Each of the above examples can be performed by using only a single
49eeze function, as one of the primary focuses of the library is to
50reduce the complexity of managing devices.
1f22bc91 51
a786efc1
JB
52%description -l pl.UTF-8
53Eeze to bibliotek do operowania urządzeniami poprzez udev z prostym i
54szybkim API. Działa bezpośrednio z libudev, bez pośrednich demonów,
55takich jak udisks, upower czy hal, aby zebrać informacje z urządzeń
56natychmiast, kiedy staną się znane w systemie. Może to służyć do
57określania rzeczy takich jak:
58 - włożenie płyty CD
59 - termperatura rdzenia procesora
60 - pozostała pojemność baterii
61 - aktualne zużycie energii przez różne elementy
62 - monitorowanie stanu urządzeń peryferyjnych w czasie rzeczywistym.
63
64Każde z tych zapytań może być wykonane przy użyciu jedynie pojedynczej
65funkcji eeze, jako że jedną z głównych idei biblioteki jest
66ograniczenie skomplikowania zarządzania urządzeniami.
67
1f22bc91 68%package devel
69Summary: Eeze header files
70Summary(pl.UTF-8): Pliki nagłówkowe Eeze
71Group: Development/Libraries
72Requires: %{name} = %{version}-%{release}
a786efc1 73Requires: ecore-devel >= %{ecore_ver}
1a99e44e 74Requires: eina-devel >= %{eina_ver}
a786efc1 75Requires: udev-devel >= 148
1f22bc91 76
77%description devel
a786efc1 78Header files for Eeze.
1f22bc91 79
80%description devel -l pl.UTF-8
a786efc1 81Pliki nagłówkowe Eeze.
1f22bc91 82
83%package static
a786efc1
JB
84Summary: Static Eeze library
85Summary(pl.UTF-8): Statyczna biblioteka Eeze
1f22bc91 86Group: Development/Libraries
87Requires: %{name}-devel = %{version}-%{release}
88
89%description static
a786efc1 90Static Eeze library.
1f22bc91 91
92%description static -l pl.UTF-8
a786efc1 93Statyczna biblioteka Eeze.
1f22bc91 94
95%prep
76ec9f2e 96%setup -q
1f22bc91 97
1f22bc91 98%build
99%{__libtoolize}
100%{__aclocal} -I m4
101%{__autoconf}
102%{__autoheader}
103%{__automake}
104%configure \
a786efc1 105 --disable-silent-rules \
d868083e 106 %{!?with_static_libs:--disable-static} \
107 --with-eject=/usr/bin/eject \
108 --with-mount=/bin/mount \
109 --with-umount=/bin/umount
a786efc1 110%{__make}
1f22bc91 111
112%install
113rm -rf $RPM_BUILD_ROOT
114
115%{__make} install \
116 DESTDIR=$RPM_BUILD_ROOT
117
1f22bc91 118%clean
119rm -rf $RPM_BUILD_ROOT
120
121%post -p /sbin/ldconfig
122%postun -p /sbin/ldconfig
123
124%files
125%defattr(644,root,root,755)
1a99e44e
JB
126%doc AUTHORS COPYING ChangeLog NEWS README TODO
127%attr(755,root,root) %{_bindir}/eeze_disk_ls
128%attr(755,root,root) %{_bindir}/eeze_mount
129%attr(755,root,root) %{_bindir}/eeze_umount
a786efc1
JB
130%attr(755,root,root) %{_libdir}/libeeze.so.*.*.*
131%attr(755,root,root) %ghost %{_libdir}/libeeze.so.1
d868083e 132%attr(755,root,root) %{_libdir}/enlightenment/utils/eeze_scanner
1f22bc91 133
134%files devel
135%defattr(644,root,root,755)
136%attr(755,root,root) %{_libdir}/libeeze.so
137%{_libdir}/libeeze.la
a786efc1 138%{_includedir}/eeze-1
1f22bc91 139%{_pkgconfigdir}/eeze.pc
140
141%if %{with static_libs}
142%files static
143%defattr(644,root,root,755)
144%{_libdir}/libeeze.a
145%endif
This page took 0.068345 seconds and 4 git commands to generate.