]> git.pld-linux.org Git - packages/edb.git/commitdiff
- updated for 1.0.5
authorJakub Bogusz <qboosh@pld-linux.org>
Wed, 27 Oct 2004 22:15:52 +0000 (22:15 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    edb-ac_fix.patch -> 1.3

edb-ac_fix.patch

index ebdb6e653c4ded188e56af7abae01f975e465b96..a1187fc1fa05b6f6777f009ad2857e68b164ae91 100644 (file)
@@ -1,22 +1,9 @@
---- edb-1.0.3/configure.in.orig        Fri Sep 21 19:36:06 2001
-+++ edb-1.0.3/configure.in     Fri Aug  9 20:21:54 2002
-@@ -1,5 +1,5 @@
--AC_INIT(src/Edb.h)
--AM_CONFIG_HEADER(config.h)
-+AC_INIT([src/Edb.h])
-+AM_CONFIG_HEADER([config.h])
- AM_INIT_AUTOMAKE(edb, 1.0.3)
- AC_PROG_CC
- AM_PROG_CC_STDC
-@@ -17,66 +17,11 @@
+--- edb-1.0.5/configure.in.orig        2004-07-13 06:02:42.000000000 +0200
++++ edb-1.0.5/configure.in     2004-10-27 23:52:20.952292416 +0200
+@@ -24,55 +24,6 @@
+ dnl AC_PROG_INSTALL()
+ dnl AC_ARG_PROGRAM()
  
- ##################### DB stuff
--AC_PROG_INSTALL()
-+AC_PROG_INSTALL
- AC_CANONICAL_HOST
--AC_ARG_PROGRAM()
--
 -dnl This is where we handle stuff that autoconf can't handle: compiler,
 -dnl preprocessor and load flags, libraries that the standard tests don't
 -dnl look for.  The default optimization is -O.
@@ -25,8 +12,8 @@
 -dnl Don't override anything if it's already set from the environment.
 -AC_SUBST(CFLAGS)
 -AC_SUBST(CPPFLAGS)
--AC_SUBST(CXX)
--AC_SUBST(CXXFLAGS)
+-dnl AC_SUBST(CXX)
+-dnl AC_SUBST(CXXFLAGS)
 -AC_SUBST(LDFLAGS)
 -case "$host_os" in
 -aix4.1*)   CFLAGS=${CFLAGS-"-O3"};;
 -esac
 -CXXFLAGS=${CXXFLAGS-"$CFLAGS"}
 -
--dnl The default compiler is cc (NOT gcc), the default CFLAGS is as specified
--dnl above, NOT what is set by AC_PROG_CC, as it won't set optimization flags.
--dnl We still call AC_PROG_CC so that we get the other side-effects.
--AC_CHECK_PROG(CC, cc, cc)
--AC_CHECK_PROG(CC, gcc, gcc)
-+AC_ARG_PROGRAM
- AC_PROG_CC
 -dnl Optional C++ API..
 -dnl
 -dnl XXX
 -dnl Versions of GCC up to 2.8.0 required -fhandle-exceptions, but it is
 -dnl the default in versions 2.8.0 and after.
--AC_MSG_CHECKING(if --enable-cxx option specified)
--AC_ARG_ENABLE(cxx,
--      [  --enable-cxx            Provide C++ interfaces.],
--      [db_cv_cxx="$enable_cxx"], [db_cv_cxx="no"])
--AC_MSG_RESULT($db_cv_cxx)
--if test "$db_cv_cxx" = "yes"; then
--      AC_PROG_CXX
+-dnl AC_MSG_CHECKING(if --enable-cxx option specified)
+-dnl AC_ARG_ENABLE(cxx,
+-dnl   [  --enable-cxx            Provide C++ interfaces.],
+-dnl   [db_cv_cxx="$enable_cxx"], [db_cv_cxx="no"])
+-dnl AC_MSG_RESULT($db_cv_cxx)
+-dnl if test "$db_cv_cxx" = "yes"; then
+-dnl   AC_PROG_CXX
 -
--      if test "$GXX" = "yes"; then
--              CXXFLAGS="-fhandle-exceptions $CXXFLAGS"
--      fi
+-dnl   if test "$GXX" = "yes"; then
+-dnl           CXXFLAGS="-fhandle-exceptions $CXXFLAGS"
+-dnl   fi
 -
--      LIBOBJS="$LIBOBJS \$(COBJS)"
--fi
+-dnl   AC_LIBOBJ="$AC_LIBOBJ \$(COBJS)"
+-dnl fi
 -
  dnl There are additional libraries we need for some compiler/architecture
  dnl combinations.
  AC_SUBST(LIBS)
-@@ -88,7 +33,7 @@
-       [db_cv_compat185="$enable_compat185"], [db_cv_compat185="no"])
- AC_MSG_RESULT($db_cv_compat185)
- if test "$db_cv_compat185" = "yes"; then
--      LIBOBJS="db185.o $LIBOBJS"
-+      AC_LIBOBJ([db185])
- fi
- dnl Optional utilities.
-@@ -137,7 +82,15 @@
- AC_CHECK_TYPE(ssize_t, int)
- AC_C_BIGENDIAN
- AC_C_CONST
--AC_STRUCT_ST_BLKSIZE
-+AC_DIAGNOSE([obsolete],[AC_STRUCT_ST_BLKSIZE:
-+        your code should no longer depend upon `HAVE_ST_BLKSIZE', but
-+        `HAVE_STRUCT_STAT_ST_BLKSIZE'.  Remove this warning and
-+        the `AC_DEFINE' when you adjust the code.])
-+AC_CHECK_MEMBERS([struct stat.st_blksize],[AC_DEFINE(HAVE_ST_BLKSIZE, 1,
-+                            [Define to 1 if your `struct stat' has
-+                             `st_blksize'.  Deprecated, use
-+                             `HAVE_STRUCT_STAT_ST_BLKSIZE' instead.])])
-+
- AC_HEADER_STAT
- AC_TYPE_MODE_T
- AC_TYPE_OFF_T
-@@ -163,7 +116,9 @@
- dnl A/UX has a broken getopt(3).
- case "$host_os" in
--aux*) LIBOBJS="getopt.o $LIBOBJS";;
-+aux*) 
-+AC_LIBOBJ([getopt])
-+;;
- esac
- dnl Checks for system functions for which we don't have replacements.
-@@ -453,7 +408,8 @@
-       AC_DEFINE(HAVE_ASSEM_UTS4_CC)
-       mutex_align="sizeof(int)"
-       spin_line1="typedef int tsl_t;"
--      LIBOBJS="$LIBOBJS uts4.cc.o";;
-+      AC_LIBOBJ([uts4.cc])
-+      ;;
- x86/gcc)
-       AC_DEFINE(HAVE_ASSEM_X86_GCC)
-       mutex_align="1"
-@@ -647,15 +603,15 @@
- fi
- AC_MSG_RESULT($gtk_ok)
--AC_CHECK_LIB(ncurses, putwin,
--  AC_CHECK_HEADER(ncurses.h, ncurses_ok=yes, ncurses_ok=no),
-+AC_CHECK_LIB(ncurses, putwin,[
-+  AC_CHECK_HEADER(ncurses.h, ncurses_ok=yes, ncurses_ok=no)],
-   ncurses_ok=no,
-   -lncurses)
-   
- AM_CONDITIONAL(EDB_VT_ED, test "$ncurses_ok" = yes)
- AM_CONDITIONAL(EDB_GTK_ED, test "$gtk_ok" = yes)
--AC_OUTPUT([
-+AC_OUTPUT([
- Makefile
- src/Makefile
- tools/Makefile
-@@ -665,7 +621,6 @@
+@@ -450,7 +401,6 @@
  src/edb_int.h
  src/edb_185.h
  debian/Makefile
 +edb-config])
 +AC_CONFIG_COMMANDS([default],
 +      [chmod +x edb-config])
+--- edb-1.0.5/src/os_stat.c.orig       2001-04-05 18:31:35.000000000 +0200
++++ edb-1.0.5/src/os_stat.c    2004-10-27 23:52:51.401663408 +0200
+@@ -88,7 +88,7 @@
+        * Check for a 0 size -- the HP MPE/iX architecture has st_blksize,
+        * but it's always 0.
+        */
+-#ifdef HAVE_ST_BLKSIZE
++#ifdef HAVE_STRUCT_STAT_ST_BLKSIZE
+       if (iosizep != NULL && (*iosizep = sb.st_blksize) == 0)
+               *iosizep = DB_DEF_IOSIZE;
+ #else
This page took 0.130422 seconds and 4 git commands to generate.