]> git.pld-linux.org Git - packages/ed.git/commitdiff
- updated for 0.6
authorJakub Bogusz <qboosh@pld-linux.org>
Wed, 11 Jul 2007 18:33:41 +0000 (18:33 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    ed-autoconf.patch -> 1.4
    ed-debian.patch -> 1.2
    ed-info.patch -> 1.3
    ed-multilib.patch -> 1.2

ed-autoconf.patch
ed-debian.patch
ed-info.patch
ed-multilib.patch

index 675ab78bf7c90a9ab38170730090ca9d88486418..7707e21e7b97e3efce766fed738711c2ba4c8bc4 100644 (file)
@@ -1,44 +1,11 @@
-diff -Nru ed-0.2/Makefile.in ed-0.2.new/Makefile.in
---- ed-0.2/Makefile.in Sat Nov 19 13:45:32 1994
-+++ ed-0.2.new/Makefile.in     Thu Jun 17 23:30:43 1999
-@@ -99,20 +99,17 @@
-       $(TEXI2DVI) $(srcdir)/ed.texinfo
- install: ed ed.info installdirs
--      $(INSTALL_PROGRAM) ed $(bindir)/$(binprefix)ed
--      rm -f $(bindir)/$(binprefix)red
--      cd $(bindir); \
--        $(LN_S) $(binprefix)ed $(binprefix)red
--      $(INSTALL_DATA) $(srcdir)/ed.info $(infodir)/$(binprefix)ed.info
--      $(INSTALL_DATA) $(srcdir)/ed.1 $(mandir)/$(binprefix)ed$(manext)
--      rm -f $(mandir)/$(binprefix)red$(manext)
-+      $(INSTALL_PROGRAM) ed $(DESTDIR)$(bindir)/$(binprefix)ed
-+      $(LN_S) ed $(DESTDIR)$(bindir)/red
-+      $(INSTALL_DATA) $(srcdir)/ed.info $(DESTDIR)$(infodir)/$(binprefix)ed.info
-+      $(INSTALL_DATA) $(srcdir)/ed.1 $(DESTDIR)$(mandir)/$(binprefix)ed$(manext)
-       cd $(mandir); \
--        $(LN_S) $(binprefix)ed$(manext) $(binprefix)red$(manext)
-+      echo ".so ed$(manext)" > $(DESTDIR)$(mandir)/red$(manext)
- # Make sure all installation directories, e.g. $(bindir) actually exist by
- # making them if necessary.
- installdirs:
--      $(srcdir)/mkinstalldirs $(bindir) $(infodir) $(mandir)
-+      $(srcdir)/mkinstalldirs $(DESTDIR)$(bindir) $(DESTDIR)$(infodir) $(DESTDIR)$(mandir)
- uninstall: all
-       rm -f $(bindir)/$(binprefix)ed $(bindir)/$(binprefix)red
-diff -Nru ed-0.2/Makefile.in ed-0.2.new/Makefile.in
---- ed-0.2/Makefile.in Fri Jun 18 00:44:39 1999
-+++ ed-0.2.new/Makefile.in     Fri Jun 18 00:06:21 1999
-@@ -41,8 +41,8 @@
- prefix = @prefix@
- exec_prefix = @exec_prefix@
- bindir = $(exec_prefix)/bin
--infodir = $(prefix)/info
--mandir = $(prefix)/man/man1
-+infodir = @infodir@
-+mandir = @mandir@/man1
- manext = .1
- CPPFLAGS = -I. -I$(srcdir) $(DEFS) @CPPFLAGS@
+--- ed-0.6/Makefile.in.orig    2007-07-11 07:30:30.566630525 +0200
++++ ed-0.6/Makefile.in 2007-07-11 07:34:51.909523607 +0200
+@@ -59,7 +59,7 @@
+       if test ! -d $(DESTDIR)$(mandir)/man1 ; then $(INSTALL) -d $(DESTDIR)$(mandir)/man1 ; fi
+       $(INSTALL_DATA) $(VPATH)/doc/$(progname).1 $(DESTDIR)$(mandir)/man1/$(progname).1
+       -rm -f $(DESTDIR)$(mandir)/man1/r$(progname).1
+-      cd $(DESTDIR)$(mandir)/man1 ; ln $(progname).1 r$(progname).1
++      cd $(DESTDIR)$(mandir)/man1 ; echo ".so $(progname).1" > r$(progname).1
+ install-strip : all
+       $(MAKE) INSTALL_PROGRAM='$(INSTALL_PROGRAM) -s' install
index 29f52daa75526a59c3759954d7ea97e976f27462..4debcf96a9d6d90b30df53bee2664f0acf7a38a4 100644 (file)
@@ -1,135 +1,6 @@
---- ed-0.2.orig/glbl.c
-+++ ed-0.2/glbl.c
-@@ -128,8 +128,8 @@
-       for (; *ibufp;)
-       if ((status = extract_addr_range ()) < 0 ||
-           (status = exec_command ()) < 0 ||
--          status > 0 && (status = display_lines (
--                                 current_addr, current_addr, status)) < 0)
-+          (status > 0 && (status = display_lines (
-+                                 current_addr, current_addr, status)) < 0))
-         return status;
-     }
-   return 0;
---- ed-0.2.orig/io.c
-+++ ed-0.2/io.c
-@@ -100,7 +100,7 @@
-     return ERR;
-   if (o_n && appended && size && o_isbinary && o_newline_added)
-     fputs ("Newline inserted\n", stderr);
--  else if (newline_added && (!appended || !isbinary && !o_isbinary))
-+  else if (newline_added && (!appended || (!isbinary && !o_isbinary)))
-     fputs ("Newline appended\n", stderr);
-   if (isbinary && newline_added && !appended)
-     size += 1;
-@@ -120,8 +120,8 @@
-   register int c;
-   register int i = 0;
--  while (((c = getc (fp)) != EOF || !feof (fp) &&
--        !ferror (fp)) && c != '\n')
-+  while (((c = getc (fp)) != EOF || (!feof (fp) &&
-+        !ferror (fp))) && c != '\n')
-     {
-       REALLOC (sbuf, sbufsz, i + 1, ERR);
-       if (!(sbuf[i++] = c))
---- ed-0.2.orig/main.c
-+++ ed-0.2/main.c
-@@ -165,6 +165,11 @@
-   int c, n;
-   long status = 0;
-+#ifdef __GNUC__
-+      (void)&argc;
-+      (void)&argv;
-+#endif
-+
-   program_name = argv[0];
-   red = (n = strlen (argv[0])) > 2 && argv[0][n - 3] == 'r';
- top:
-@@ -220,7 +225,7 @@
-   reliable_signal (SIGQUIT, SIG_IGN);
-   reliable_signal (SIGINT, signal_int);
- #ifdef HAVE_SIGSETJMP
--  if (status = sigsetjmp (env, 1))
-+  if ((status = sigsetjmp (env, 1)))
- #else
-   if (status = setjmp (env))
- #endif
-@@ -659,7 +664,7 @@
-       return ERR;
-       else if (build_active_list (c == 'g' || c == 'G') < 0)
-       return ERR;
--      else if (n = (c == 'G' || c == 'V'))
-+      else if ((n = (c == 'G' || c == 'V')))
-       GET_COMMAND_SUFFIX ();
-       isglobal++;
-       if (exec_global (n, gflag) < 0)
-@@ -1069,7 +1074,7 @@
-     return ERR;
-   do
-     {
--      if (n = dir ? INC_MOD (n, addr_last) : DEC_MOD (n, addr_last))
-+      if ((n = dir ? INC_MOD (n, addr_last) : DEC_MOD (n, addr_last)))
-       {
-         lp = get_addressed_line_node (n);
-         if ((s = get_sbuf_line (lp)) == NULL)
-@@ -1648,7 +1653,7 @@
-   REALLOC (file, filesz, PATH_MAX + 1, NULL);
-   /* assert: no trailing escape */
--  while (file[i++] = (*s == '\\') ? *++s : *s)
-+  while ((file[i++] = (*s == '\\') ? *++s : *s))
-     s++;
-   return file;
- }
---- ed-0.2.orig/re.c
-+++ ed-0.2/re.c
-@@ -62,7 +62,7 @@
-       return NULL;
-     }
-   patlock = 0;
--  if (n = regcomp (exp, exps, 0))
-+  if ((n = regcomp (exp, exps, 0)))
-     {
-       regerror (n, exp, errmsg, ERRSZ);
-       free (exp);
---- ed-0.2.orig/sub.c
-+++ ed-0.2/sub.c
-@@ -101,7 +101,7 @@
-       else if (!isglobal)
-       {
-         while ((n = get_tty_line ()) == 0 ||
--               n > 0 && ibuf[n - 1] != '\n')
-+               (n > 0 && ibuf[n - 1] != '\n'))
-           clearerr (stdin);
-         if (n < 0)
-           return NULL;
-@@ -229,7 +229,7 @@
-           }
-         txt += rm[0].rm_eo;
-       }
--      while (*txt && (!changed || (gflag & GSG) && rm[0].rm_eo) &&
-+      while (*txt && (!changed || ((gflag & GSG) && rm[0].rm_eo)) &&
-            !regexec (pat, txt, SE_MAX, rm, REG_NOTBOL));
-       i = eot - txt;
-       REALLOC (rbuf, rbufsz, off + i + 2, ERR);
---- ed-0.2.orig/Makefile.in
-+++ ed-0.2/Makefile.in
-@@ -65,8 +65,8 @@
- all: ed
--ed: $(OBJECTS) libed.a
--      $(CC) $(LDFLAGS) -o ed $(OBJECTS) libed.a $(LIBS)
-+ed: $(OBJECTS)
-+      $(CC) $(LDFLAGS) -o ed $(OBJECTS) $(LIBS)
- buf.o: ed.h config.h regex.h
- ed.o: ed.h config.h regex.h
---- ed-0.2.orig/ed.1
-+++ ed-0.2/ed.1
-@@ -196,14 +196,14 @@
+--- ed-0.6/doc/ed.1.orig       2006-10-05 21:35:42.000000000 +0200
++++ ed-0.6/doc/ed.1    2007-07-11 18:36:57.789372484 +0200
+@@ -195,14 +195,14 @@
  The last line in the buffer.
  
  .TP 8
 -.I [0,$].
 +.IR [0,$] .
  
- .HP
+ .TP 8
  -
-@@ -215,9 +215,9 @@
+@@ -212,7 +212,7 @@
  and may be repeated with cumulative effect.
  
- .HP
+ .TP 8
 --\fIn\fR
 +.RI - n
- .TP 8
--^\fIn\fR
-+.RI ^ n
  The
  .IR n th
  previous line, where
-@@ -235,7 +235,7 @@
+@@ -228,9 +228,9 @@
+ and may be repeated with cumulative effect.
  .HP
- +\fIn\fR
- .TP 8
 -whitespace \fIn\fR
 +.I whitespace n
+ .TP 8
+-+\fIn\fR
++.RI + n
  The
  .IR n th
  next line, where
-@@ -253,16 +253,16 @@
- %
+@@ -246,16 +246,16 @@
+ ,
  The first through last lines in the buffer.  This is equivalent to
  the address range
 -.I 1,$.
  The
  next line containing the regular expression
  .IR re .
-@@ -271,7 +271,7 @@
+@@ -264,7 +264,7 @@
  // repeats the last search.
  
  .TP 8
  The
  previous line containing the regular expression
  .IR re .
-@@ -280,7 +280,7 @@
+@@ -273,7 +273,7 @@
  ?? repeats the last search.
  
  .TP 8
  The
  line previously marked by a
  .I `k'
-@@ -331,7 +331,7 @@
+@@ -324,7 +324,7 @@
  matches itself.
  
  .TP 8
  Matches any single character.
  
  .TP 8
-@@ -482,7 +482,7 @@
+@@ -475,7 +475,7 @@
  \fR\e+\fR
  Matches the single character regular expression or subexpression
  immediately preceding it one or more times.  So the regular expression
  regular expression or subexpression, then it matches a literal `+'.
  
  
-@@ -564,7 +564,7 @@
+@@ -557,7 +557,7 @@
  The current address is set to the last line read.
  
  .TP 8
  Edits the standard output of
  .IR `!command' ,
  (see
-@@ -746,7 +746,7 @@
+@@ -739,7 +739,7 @@
  The current address is set to the last line read.
  
  .TP 8
  Reads
  to after the addressed line
  the standard output of
-@@ -843,7 +843,7 @@
+@@ -836,7 +836,7 @@
  suffix toggles the global suffix of the last substitution.
  The
  .I `p'
  The current address is set to the last line affected.
  
  .TP 8
-@@ -909,7 +909,7 @@
+@@ -902,7 +902,7 @@
  command.
  
  .TP 8
  Writes the addressed lines to the standard input of
  .IR `!command' ,
  (see the
-y
\ No newline at end of file
index bdca1d937f12874e65b2ad4cbc7e52ca0c262636..af3a5aa22b81becede67572c75c19de94627a6e4 100644 (file)
@@ -1,22 +1,14 @@
-diff -Nru ed-0.2/ed.texinfo ed-0.2.new/ed.texinfo
---- ed-0.2/ed.texinfo  Sat Nov 19 13:38:01 1994
-+++ ed-0.2.new/ed.texinfo      Thu Apr  1 19:16:34 1999
-@@ -60,8 +60,17 @@
- @end titlepage
+--- ed-0.6/doc/ed.texinfo.orig 2007-06-29 02:10:39.000000000 +0200
++++ ed-0.6/doc/ed.texinfo      2007-07-11 07:29:59.024833061 +0200
+@@ -8,9 +8,9 @@
+ @set UPDATED 29 June 2007
+ @set VERSION 0.6
  
- @ifinfo
-+@format
-+@dircategory Miscellaneous:
-+@direntry
-+* ed: (ed).                           The GNU Line Editor
-+@end direntry
-+@end format
-+@end ifinfo
-+
-+@ifinfo
- @node Top, Intro, (dir), (dir)
--@top
-+@top ed
+-@dircategory Basics
++@dircategory File utilities:
+ @direntry
+-* Ed: (ed).                     The GNU line editor.
++* Ed: (ed).                           The GNU line editor
+ @end direntry
  
- This info file documents the @code{ed} text editor, as of release 0.2.
- You may find in this document:
+ @copying
index acd2e921fdb454d01a4467c25f040636717d0608..2732028d63f549165da0f77e750d8968857cf71e 100644 (file)
@@ -1,11 +1,15 @@
---- ed-0.2/Makefile.in.orig    2007-03-02 14:28:16.000000000 +0100
-+++ ed-0.2/Makefile.in 2007-03-02 14:28:30.000000000 +0100
-@@ -66,7 +66,7 @@
- all: ed
+--- ed-0.6/Makefile.in.orig    2007-07-11 18:44:28.507057421 +0200
++++ ed-0.6/Makefile.in 2007-07-11 20:13:08.702238066 +0200
+@@ -15,10 +15,10 @@
+ all : $(progname)
  
ed: $(OBJECTS)
--      $(CC) $(LDFLAGS) -o ed $(OBJECTS) $(LIBS)
-+      $(CC) $(CFLAGS) $(LDFLAGS) -o ed $(OBJECTS) $(LIBS)
$(progname) : $(objs)
+-      $(CC) $(LDFLAGS) -o $(progname) $(objs)
++      $(CC) $(LDFLAGS) $(CFLAGS) -o $(progname) $(objs)
  
- buf.o: ed.h config.h
- ed.o: ed.h config.h
+ p$(progname) : $(objs)
+-      $(CC) $(LDFLAGS) -pg -o p$(progname) $(objs)
++      $(CC) $(LDFLAGS) $(CFLAGS) -pg -o p$(progname) $(objs)
+ main.o : main.c
+       $(CC) $(CPPFLAGS) $(CFLAGS) -DPROGVERSION=\"$(progversion)\" -c -o $@ $<
This page took 0.07409 seconds and 4 git commands to generate.