]> git.pld-linux.org Git - packages/ecryptfs-utils.git/blob - ecryptfs-utils.spec
rebuild with openssl 3.0.0
[packages/ecryptfs-utils.git] / ecryptfs-utils.spec
1 #
2 # Conditional build:
3 %bcond_with     gui             # GTK+ GUI components (non-existing as of 111)
4 %bcond_without  static_libs     # static library
5 #
6 Summary:        The eCryptfs mount helper and support libraries
7 Summary(pl.UTF-8):      Narzędzie pomocnicze i biblioteki do montowania eCryptfs
8 Name:           ecryptfs-utils
9 Version:        111
10 Release:        2
11 License:        GPL v2+
12 Group:          Base
13 #Source0Download: https://launchpad.net/ecryptfs/+download
14 Source0:        https://launchpad.net/ecryptfs/trunk/%{version}/+download/%{name}_%{version}.orig.tar.gz
15 # Source0-md5:  83513228984f671930752c3518cac6fd
16 Patch0:         %{name}-sh.patch
17 Patch1:         %{name}-83-fixsalt.patch
18 Patch2:         %{name}-83-splitnss.patch
19 Patch3:         %{name}-84-fixsigness.patch
20 URL:            http://ecryptfs.org/
21 BuildRequires:  autoconf >= 2.59
22 BuildRequires:  automake
23 BuildRequires:  gettext-tools
24 BuildRequires:  glib2-devel >= 2.0
25 BuildRequires:  gpgme-devel
26 %{?with_gui:BuildRequires:      gtk+2-devel >= 2.0}
27 BuildRequires:  intltool >= 0.41.0
28 BuildRequires:  keyutils-devel >= 1.0
29 BuildRequires:  libtool
30 BuildRequires:  nss-devel >= 3
31 BuildRequires:  openssl-devel >= 0.9.7
32 BuildRequires:  pam-devel
33 BuildRequires:  perl-tools-pod
34 BuildRequires:  pkcs11-helper-devel >= 1.04
35 BuildRequires:  pkgconfig
36 BuildRequires:  python-devel >= 1:2.5
37 BuildRequires:  python-modules >= 1:2.5
38 BuildRequires:  rpm-pythonprov
39 BuildRequires:  rpmbuild(macros) >= 1.219
40 BuildRequires:  swig >= 1.3.31
41 BuildRequires:  swig-python >= 1.3.31
42 BuildRequires:  trousers-devel
43 Requires:       uname(release) >= 2.6.19
44 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
45
46 # python module
47 %define         skip_post_check_so      _libecryptfs.so.0.0.0
48
49 %description
50 eCryptfs is a stacked cryptographic filesystem that ships in Linux
51 kernel versions 2.6.19 and above. This package provides the mount
52 helper and supporting libraries to perform key management and mount
53 functions.
54
55 Install ecryptfs-utils if you would like to mount eCryptfs.
56
57 %description -l pl.UTF-8
58 eCryptfs to stakowalny kryptograficzny system plików dostępny w jądrze
59 Linuksa od wersji 2.6.19. Ten pakiet udostępnia narzędzie pomocnicze
60 dla programu mount oraz wspierające je biblioteki wykonujące
61 zarządzanie kluczami i funkcje związane z montowaniem.
62
63 Pakiet ecryptfs-utils należy zainstalować, aby montować eCryptfs.
64
65 %package devel
66 Summary:        The eCryptfs userspace development package
67 Summary(pl.UTF-8):      Pakiet programistyczny przestrzeni użytkownika dla eCryptfs
68 Group:          Development/Libraries
69 Requires:       %{name} = %{version}-%{release}
70 Requires:       keyutils-devel >= 1.0
71 Requires:       nss-devel >= 3
72
73 %description devel
74 Userspace development files for eCryptfs.
75
76 %description devel -l pl.UTF-8
77 Pliki programistyczne przestrzeni użytkownika dla eCryptfs.
78
79 %package static
80 Summary:        Static eCryptfs library
81 Summary(pl.UTF-8):      Statyczna biblioteka eCryptfs
82 Group:          Development/Libraries
83 Requires:       %{name}-devel = %{version}-%{release}
84
85 %description static
86 Static eCryptfs library.
87
88 %description static -l pl.UTF-8
89 Statyczna biblioteka eCryptfs.
90
91 %package -n pam-pam_ecryptfs
92 Summary:        eCryptfs PAM module
93 Summary(pl.UTF-8):      Moduł PAM eCryptfs
94 Group:          Base
95 Requires:       %{name} = %{version}-%{release}
96
97 %description -n pam-pam_ecryptfs
98 eCryptfs PAM module.
99
100 %description -n pam-pam_ecryptfs -l pl.UTF-8
101 Moduł PAM eCryptfs.
102
103 %package -n python-ecryptfs
104 Summary:        Python bindings for the eCryptfs utils
105 Summary(pl.UTF-8):      Wiązania Pythona do narzędzi eCryptfs
106 Group:          Libraries/Python
107 Requires:       %{name} = %{version}-%{release}
108 Obsoletes:      ecryptfs-utils-python
109
110 %description -n python-ecryptfs
111 This package contains a module that permits applications written in
112 the Python programming language to use the interface supplied by the
113 ecryptfs-utils library.
114
115 %description -n python-ecryptfs -l pl.UTF-8
116 Ten pakiet zawiera moduł pozwalający aplikacjom napisanym w Pythonie
117 na korzystanie z interfejsu dostarczanego przez bibliotekę
118 ecryptfs-utils.
119
120 %prep
121 %setup -q
122 %patch0 -p1
123 %patch1 -p1
124 %patch2 -p1
125 %patch3 -p1
126
127 %build
128 %{__libtoolize}
129 %{__aclocal} -I m4
130 %{__autoconf}
131 %{__autoheader}
132 %{__automake}
133 %configure \
134         --enable-gpg \
135         %{?with_gui:--enable-gui} \
136         --enable-nss \
137         --enable-openssl \
138         --enable-pam \
139         --enable-pkcs11-helper \
140         --enable-tspi \
141         %{?with_static_libs:--enable-static}
142
143 %{__make}
144
145 %install
146 rm -rf $RPM_BUILD_ROOT
147
148 %{__make} -j1 install \
149         DESTDIR=$RPM_BUILD_ROOT
150
151 # obsoleted by pkg-config
152 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libecryptfs.la
153
154 %{__rm} $RPM_BUILD_ROOT%{py_sitedir}/%{name}/_libecryptfs.la \
155         %{?with_static_libs:$RPM_BUILD_ROOT%{py_sitedir}/%{name}/_libecryptfs.a}
156 %py_postclean
157
158 %find_lang %{name}
159
160 %clean
161 rm -rf $RPM_BUILD_ROOT
162
163 %pre
164 %groupadd -g 260 ecryptfs
165
166 %postun
167 /sbin/ldconfig
168 if [ "$1" = "0" ]; then
169         %groupremove ecryptfs
170 fi
171
172 %post   -p /sbin/ldconfig
173
174 %files -f %{name}.lang
175 %defattr(644,root,root,755)
176 %doc AUTHORS ChangeLog NEWS README THANKS doc/{ecryptfs-faq.html,ecryptfs-pkcs11-helper-doc.txt}
177 %attr(755,root,root) /sbin/mount.ecryptfs
178 %attr(4754,root,ecryptfs) /sbin/mount.ecryptfs_private
179 %attr(755,root,root) /sbin/umount.ecryptfs_private
180 %attr(755,root,root) /sbin/umount.ecryptfs
181 %attr(755,root,root) %{_bindir}/ecryptfs-*
182 %attr(755,root,root) %{_bindir}/ecryptfsd
183 %attr(755,root,root) %{_libdir}/libecryptfs.so.*.*.*
184 %attr(755,root,root) %ghost %{_libdir}/libecryptfs.so.1
185 %dir %{_libdir}/ecryptfs
186 %attr(755,root,root) %{_libdir}/ecryptfs/libecryptfs_key_mod_gpg.so
187 %attr(755,root,root) %{_libdir}/ecryptfs/libecryptfs_key_mod_openssl.so
188 %attr(755,root,root) %{_libdir}/ecryptfs/libecryptfs_key_mod_passphrase.so
189 %attr(755,root,root) %{_libdir}/ecryptfs/libecryptfs_key_mod_pkcs11_helper.so
190 %attr(755,root,root) %{_libdir}/ecryptfs/libecryptfs_key_mod_tspi.so
191 %{_datadir}/%{name}
192 %{_mandir}/man1/ecryptfs-*.1*
193 %{_mandir}/man1/mount.ecryptfs_private.1*
194 %{_mandir}/man1/umount.ecryptfs_private.1*
195 %{_mandir}/man7/ecryptfs.7*
196 %{_mandir}/man8/ecryptfs-*.8*
197 %{_mandir}/man8/ecryptfsd.8*
198 %{_mandir}/man8/mount.ecryptfs.8*
199 %{_mandir}/man8/umount.ecryptfs.8*
200
201 %files devel
202 %defattr(644,root,root,755)
203 %attr(755,root,root) %{_libdir}/libecryptfs.so
204 %{_includedir}/ecryptfs.h
205 %{_pkgconfigdir}/libecryptfs.pc
206
207 %if %{with static_libs}
208 %files static
209 %defattr(644,root,root,755)
210 %{_libdir}/libecryptfs.a
211 %endif
212
213 %files -n pam-pam_ecryptfs
214 %defattr(644,root,root,755)
215 %attr(755,root,root) /%{_lib}/security/pam_ecryptfs.so
216 %{_mandir}/man8/pam_ecryptfs.8*
217
218 %files -n python-ecryptfs
219 %defattr(644,root,root,755)
220 %dir %{py_sitedir}/%{name}
221 %attr(755,root,root) %{py_sitedir}/%{name}/_libecryptfs.so*
222 %dir %{py_sitescriptdir}/%{name}
223 %{py_sitescriptdir}/%{name}/*.py[co]
This page took 0.092083 seconds and 3 git commands to generate.