]> git.pld-linux.org Git - packages/eclipse.git/commitdiff
- really insertBuildId
authorElan Ruusamäe <glen@pld-linux.org>
Sun, 2 Dec 2007 12:01:43 +0000 (12:01 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
- launcher patches from FC (NFY)

Changed files:
    eclipse.spec -> 1.93

eclipse.spec

index 6b9220b2ce8162f32f51c1fbc984b5b15c4b4731..b51dc8d7344fa7d70e7bd4d35882536d576c694f 100644 (file)
@@ -4,20 +4,22 @@
 #   This will make building such things like Azureus possible without having
 #   whole Eclipse suite installed.
 # - there are unpackaged source files, -devel?
 #   This will make building such things like Azureus possible without having
 #   whole Eclipse suite installed.
 # - there are unpackaged source files, -devel?
-#
+
 %define                ver_major       3.3.1.1
 %define                buildid 200710231652
 %define                ver_major       3.3.1.1
 %define                buildid 200710231652
-#
+
 Summary:       Eclipse - an open extensible IDE
 Summary(pl.UTF-8):     Eclipse - otwarte, rozszerzalne środowisko programistyczne
 Name:          eclipse
 Version:       %{ver_major}
 Summary:       Eclipse - an open extensible IDE
 Summary(pl.UTF-8):     Eclipse - otwarte, rozszerzalne środowisko programistyczne
 Name:          eclipse
 Version:       %{ver_major}
-Release:       1
+Release:       1.2
 License:       EPL v1.0
 Group:         Development/Tools
 License:       EPL v1.0
 Group:         Development/Tools
-Source0:       http://download.eclipse.org/eclipse/downloads/drops/R-%{ver_major}-%{buildid}/%{name}-sourceBuild-srcIncluded-%{ver_major}.zip
+Source0:       http://download.eclipse.org/eclipse/downloads/drops/R-%{ver_major}-%{buildid}/%{name}-sourceBuild-srcIncluded-%{version}.zip
 # Source0-md5: 593b56fce7d1f1f799e87365cafefbef
 Source1:       %{name}.desktop
 # Source0-md5: 593b56fce7d1f1f799e87365cafefbef
 Source1:       %{name}.desktop
+Patch0:                %{name}-launcher-set-install-dir-and-shared-config.patch
+Patch1:                %{name}-launcher-double-free-bug.patch
 URL:           http://www.eclipse.org/
 BuildRequires: ant >= 1.6.1
 BuildRequires: ant-apache-regexp
 URL:           http://www.eclipse.org/
 BuildRequires: ant >= 1.6.1
 BuildRequires: ant-apache-regexp
@@ -53,7 +55,19 @@ wszystkiego i niczego w szczególności.
 %setup -q -c
 
 # Build Id - it's visible in couple places in GUI
 %setup -q -c
 
 # Build Id - it's visible in couple places in GUI
-%{__sed} -e 's,buildId=.*,& (PLD Linux %{name}-%{version}-%{release}),' label.properties
+%{__sed} -i -e 's,buildId=.*,& (PLD Linux %{name}-%{version}-%{release}),' label.properties
+
+# launcher patches
+rm plugins/org.eclipse.platform/launchersrc.zip
+cd features/org.eclipse.equinox.executable
+%patch0 -p0
+%patch1 -p0
+# put the configuration directory in an arch-specific location
+sed -i -e 's:/usr/lib/eclipse/configuration:%{_libdir}/%{name}/configuration:' library/eclipse.c
+# make the eclipse binary relocatable
+sed -i -e 's:/usr/share/eclipse:%{_datadir}/%{name}:' library/eclipse.c
+zip -q -9 -r ../../plugins/org.eclipse.platform/launchersrc.zip library
+cd -
 
 %build
 unset CLASSPATH || :
 
 %build
 unset CLASSPATH || :
@@ -61,6 +75,8 @@ export JAVA_HOME=%{java_home}
 
 ./build -os linux -ws gtk -arch %{eclipse_arch} -target compile
 
 
 ./build -os linux -ws gtk -arch %{eclipse_arch} -target compile
 
+%ant insertBuildId
+
 export JAVA_INC="-I$JAVA_HOME/include -I$JAVA_HOME/include/linux"
 
 %{__make} -C plugins/org.eclipse.core.filesystem/natives/unix/linux/ \
 export JAVA_INC="-I$JAVA_HOME/include -I$JAVA_HOME/include/linux"
 
 %{__make} -C plugins/org.eclipse.core.filesystem/natives/unix/linux/ \
This page took 0.041303 seconds and 4 git commands to generate.