]> git.pld-linux.org Git - packages/eclipse.git/blobdiff - eclipse.spec
- do not provide libcairo.so.2
[packages/eclipse.git] / eclipse.spec
index 1acfe5553eeb81bd972ea0297147f94bcd2406ed..64a6ef2991bbc3f64cb8887bc3f13fc70d5b9f78 100644 (file)
@@ -1,26 +1,21 @@
-%include /usr/lib/rpm/macros.java
-#
 # TODO:
 #                      - separate SWT (there are separate tarballs at http://www.eclipse.org/swt/)
 #                        and add proper provides, obsoletes, conflicts etc. where needed.
 #                        This will make building such things like Azureus possible without having
 #                        whole Eclipse suite installed.
 #
-%define                _ver_major      3.2
-%define                _ver_minor      1
-%define                _ver_rc         RC4
-%define                _buildid        200605121600
+%define                _ver_major      3.2.2
+%define                _buildid        200702121330
 #
 Summary:       Eclipse - an open extensible IDE
-Summary(pl):   Eclipse - otwarte, rozszerzalne ¶rodowisko programistyczne
+Summary(pl.UTF-8):     Eclipse - otwarte, rozszerzalne środowisko programistyczne
 Name:          eclipse
 Version:       %{_ver_major}
-Release:       0.%{_ver_rc}_%{_buildid}.1
-#Release:      1
+Release:       1
 License:       EPL v1.0
 Group:         Development/Tools
-Source0:       http://download.eclipse.org/eclipse/downloads/drops/S-%{_ver_major}%{_ver_rc}-%{_buildid}/%{name}-sourceBuild-srcIncluded-%{_ver_major}%{_ver_rc}.zip
-# Source0-md5: c0a82a20347c0de3f956fdb6826e1d04
+Source0:       http://download.eclipse.org/eclipse/downloads/drops/R-%{_ver_major}-%{_buildid}/%{name}-sourceBuild-srcIncluded-%{_ver_major}.zip
+# Source0-md5: 5d1b9f6a146ffc59191e513083a6ec86
 Source1:       %{name}.desktop
 Patch0:                %{name}-core_resources-makefile.patch
 Patch1:                %{name}-build.patch
@@ -28,27 +23,30 @@ URL:                http://www.eclipse.org/
 BuildRequires: ant >= 1.6.1
 BuildRequires: jdk >= 1.4
 BuildRequires: pkgconfig
-BuildRequires: rpm-javaprov
-BuildRequires: rpmbuild(macros) >= 1.213
+BuildRequires: rpm-pythonprov
+BuildRequires: rpmbuild(macros) >= 1.300
 BuildRequires: unzip
 BuildRequires: zip
 Requires:      ant
 Requires:      jdk >= 1.4
 Obsoletes:     eclipse-SDK
-ExclusiveArch: i586 i686 pentium3 pentium4 athlon %{x8664} noarch
+ExclusiveArch: i586 i686 pentium3 pentium4 athlon %{x8664}
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define                _eclipse_arch   %(echo %{_target_cpu} | sed 's/i.86\\|athlon\\|pentium/x86/;s/amd64/x86_64/')
 %define                no_install_post_chrpath         1
 
+# list of script capabilities (regexps) not to be used in Provides
+%define                _noautoprov                     libcairo.so.2
+
 %description
 Eclipse is a kind of universal tool platform - an open extensible IDE
 for anything and nothing in particular.
 
-%description -l pl
-Eclipse to rodzaj uniwersalnej platformy narzêdziowej - otwarte,
-rozszerzalne IDE (zintegrowane rodowisko programistyczne) do
-wszystkiego i niczego w szczególno¶ci.
+%description -l pl.UTF-8
+Eclipse to rodzaj uniwersalnej platformy narzędziowej - otwarte,
+rozszerzalne IDE (zintegrowane środowisko programistyczne) do
+wszystkiego i niczego w szczególności.
 
 %prep
 %setup -q -c
@@ -56,7 +54,7 @@ wszystkiego i niczego w szczeg
 %patch1 -p0
 
 %build
-unset JAVA_HOME || :
+unset CLASSPATH || :
 export JAVA_HOME=%{java_home}
 
 ./build -os linux -ws gtk -arch %{_eclipse_arch} -target compile -java5home %{_libdir}/java
@@ -93,7 +91,7 @@ cp -a baseLocation/plugins/* $RPM_BUILD_ROOT%{_libdir}/%{name}/plugins
 install -d $RPM_BUILD_ROOT%{_bindir}
 cat > $RPM_BUILD_ROOT%{_bindir}/eclipse << 'EOF'
 #!/bin/sh
-exec %{_libdir}/%{name}/eclipse $*
+exec %{_libdir}/%{name}/eclipse ${1:+"$@"}
 EOF
 
 :> $RPM_BUILD_ROOT%{_datadir}/%{name}/.eclipseextension
@@ -101,6 +99,7 @@ EOF
 if [ ! -f "$RPM_BUILD_ROOT%{_libdir}/%{name}/icon.xpm" ]; then
        install features/org.eclipse.platform.launchers/bin/gtk/linux/x86/icon.xpm $RPM_BUILD_ROOT%{_libdir}/%{name}/icon.xpm
 fi
+install -D features/org.eclipse.platform.launchers/bin/gtk/linux/x86/icon.xpm $RPM_BUILD_ROOT%{_pixmapsdir}/eclipse-icon.xpm
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -111,6 +110,7 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_libdir}/%{name}/eclipse
 %attr(755,root,root) %{_libdir}/%{name}/lib*.so
 %{_desktopdir}/eclipse.desktop
+%{_pixmapsdir}/eclipse-icon.xpm
 %dir %{_libdir}/%{name}
 %{_libdir}/%{name}/.eclipseproduct
 %{_libdir}/%{name}/configuration
@@ -169,8 +169,7 @@ rm -rf $RPM_BUILD_ROOT
 %{_libdir}/%{name}/plugins/org.eclipse.help.ui_*.*.*
 %{_libdir}/%{name}/plugins/org.eclipse.help.webapp_*.*.*
 %{_libdir}/%{name}/plugins/org.eclipse.jdt_*.*.*
-%{_libdir}/%{name}/plugins/org.eclipse.jdt.apt.core_*.*.*
-%{_libdir}/%{name}/plugins/org.eclipse.jdt.apt.ui_*.*.*
+%{_libdir}/%{name}/plugins/org.eclipse.jdt.apt.*.*.*
 %{_libdir}/%{name}/plugins/org.eclipse.jdt.core_*.*.*
 %{_libdir}/%{name}/plugins/org.eclipse.jdt.core.manipulation*.*.*
 %{_libdir}/%{name}/plugins/org.eclipse.jdt.debug_*.*.*
This page took 0.08751 seconds and 4 git commands to generate.