]> git.pld-linux.org Git - packages/eclipse-pydev.git/blob - eclipse-pydev.spec
f4c43482d2a1e95bcf204aac7009e2043d14ac7f
[packages/eclipse-pydev.git] / eclipse-pydev.spec
1 %define         module  pydev
2 %define         _ver    0.9.5
3 %define         _src_ver        %(echo %{_ver}|tr . _)
4 Summary:        Python development environment for Eclipse
5 Summary(pl):    ¦rodowisko programistyczne Pythona dla Eclipse
6 Name:           eclipse-%{module}
7 Version:        %{_ver}
8 Release:        0.3
9 License:        CPL
10 Group:          Development/Tools
11 Source0:        http://dl.sourceforge.net/pydev/%{module}_%{_src_ver}.zip
12 # Source0-md5:  b5bac4248f33ada1d8dc05db4f06a3b2
13 URL:            http://pydev.sourceforge.net/
14 BuildRequires:  unzip
15 Requires:       eclipse >= 3.0
16 Requires:       eclipse < 3.1-1
17 Requires:       python
18 BuildArch:      noarch
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %define _eclipsedir     %{_datadir}/eclipse
22
23 %description
24 PyDev is a plugin for Eclipse for editing, running and debugging 
25 Python scripts.
26
27 %description -l pl
28 PyDev jest wtyczk± dla Eclipse s³u¿±c± do edycji, uruchamiania
29 i odpluskwiania skryptów Pythona.
30
31 %prep
32 %setup -q -c -T
33 unzip -qq %{SOURCE0} -x *.db
34
35 %install
36 rm -rf $RPM_BUILD_ROOT
37 install -d $RPM_BUILD_ROOT%{_libdir}/eclipse/{features,plugins}
38 cp -rf eclipse/features/* $RPM_BUILD_ROOT%{_libdir}/eclipse/features
39 cp -rf eclipse/plugins/* $RPM_BUILD_ROOT%{_libdir}/eclipse/plugins
40
41 # on future
42 #install -d $RPM_BUILD_ROOT%{_eclipsedir}/{features,plugins}
43 #cp -rf eclipse/features/* $RPM_BUILD_ROOT%{_eclipsedir}/features
44 #cp -rf eclipse/plugins/* $RPM_BUILD_ROOT%{_eclipsedir}/plugins
45
46
47 %clean
48 rm -rf $RPM_BUILD_ROOT
49
50 %files
51 %defattr(644,root,root,755)
52 %{_libdir}/eclipse/features/org.python.pydev*
53 %{_libdir}/eclipse/plugins/org.python.pydev*
54 # on future
55 #%{_eclipsedir}/features/org.python.pydev*
56 #%{_eclipsedir}/plugins/org.python.pydev*
57
58 %triggerpostun -- %{name} > 0.9.5-0.3
59 %banner %{name} -e << EOF
60 !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
61 !!!                                                                !!!
62 !!! WARNING!!!                                                     !!!
63 !!!                                                                !!!
64 !!! An user manual intervention is required after eclipse-pydev    !!!
65 !!! instalation. To get this plugin working you have to add        !!!
66 !!! /usr/share/eclipse directory as Extension Location. Click      !!!
67 !!! from eclipse menu Help->Software Updates->Manage Configuration !!!
68 !!! ->Add an Extension Location and choose /usr/share/eclipse .    !!!
69 !!!                                                                !!!
70 !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
71 EOF
This page took 0.097338 seconds and 2 git commands to generate.