- bundle subpackages
authorElan Ruusamäe <glen@pld-linux.org>
Tue, 19 May 2009 23:08:25 +0000 (23:08 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    eclipse-plugin-google.spec -> 1.2

eclipse-plugin-google.spec

index c21fcd9..e0cd075 100644 (file)
@@ -1,14 +1,28 @@
+# TODO:
+# - com.google.appengine.eclipse.sdkbundle_1.2.1.v200905131156/
+# - com.google.gwt.eclipse.sdkbundle.linux_1.6.4.v200904062254 is x86 centric (build from source?)
+%define                pluginver       1.0.1
+%define                appengver       1.2.1
+%define                gwtver          1.6.4
 %include       /usr/lib/rpm/macros.java
 Summary:       Google Plugin for Eclipse
 Name:          eclipse-plugin-google
-Version:       1.0.1
-Release:       0.2
+Version:       %{pluginver}
+Release:       0.4
 License:       Apache License, v2.0
 Group:         Development/Tools
 URL:           http://code.google.com/eclipse/
 # http://code.google.com/eclipse/docs/install-from-zip.html
 Source0:       http://dl.google.com/eclipse/plugin/3.3/zips/gpe-e33-latest.zip
 # Source0-md5: 955d207982a0ec954b1c067019c33694
+Source1:       http://dl.google.com/eclipse/plugin/3.3/features/com.google.appengine.eclipse.sdkbundle.e33.feature_%{appengver}.v200905131156.jar
+# Source1-md5: 44dbeb0e33c1458658b1626b86efd677
+Source2:       http://dl.google.com/eclipse/plugin/3.3/plugins/com.google.appengine.eclipse.sdkbundle_%{appengver}.v200905131156.jar
+# Source2-md5: ebc7c16b7291830497a24312980919c6
+Source3:       http://dl.google.com/eclipse/plugin/3.3/features/com.google.gwt.eclipse.sdkbundle.e33.feature_%{gwtver}.v200904062254.jar
+# Source3-md5: 8de9b4a53690e36e4af4fdd0e02f1528
+Source4:       http://dl.google.com/eclipse/plugin/3.3/plugins/com.google.gwt.eclipse.sdkbundle.linux_%{gwtver}.v200904062254.jar
+# Source4-md5: 9fe86bcde62ab891569b96fdb6fc0752
 BuildRequires: rpm-javaprov
 Requires:      eclipse >= 3.3
 BuildArch:     noarch
@@ -27,6 +41,24 @@ care of that for you.
 The plugin currently supports Google App Engine and Google Web Toolkit
 development.
 
+%package appengine
+Summary:       Google App Engine for Java SDK Bundle for Eclipse
+Version:       %{appengver}
+Group:         Development/Tools
+Requires:      %{name} = %{pluginver}-%{release}
+
+%description appengine
+Google App Engine for Java SDK Bundle for Eclipse.
+
+%package gwt
+Summary:       Google Web Toolkit SDK Bundle for Eclipse
+Version:       %{gwtver}
+Group:         Development/Tools
+Requires:      %{name} = %{pluginver}-%{release}
+
+%description gwt
+Google Web Toolkit SDK Bundle for Eclipse.
+
 %prep
 %setup -qc
 
@@ -36,6 +68,13 @@ install -d $RPM_BUILD_ROOT%{eclipsedir}/{features,plugins}
 cp -a features/* $RPM_BUILD_ROOT%{eclipsedir}/features
 cp -a plugins/* $RPM_BUILD_ROOT%{eclipsedir}/plugins
 
+# appengine sdkbundle
+cp -a %{SOURCE1} $RPM_BUILD_ROOT%{eclipsedir}/features
+cp -a %{SOURCE2} $RPM_BUILD_ROOT%{eclipsedir}/plugins
+# gwt sdkbundle
+cp -a %{SOURCE3} $RPM_BUILD_ROOT%{eclipsedir}/features
+cp -a %{SOURCE4} $RPM_BUILD_ROOT%{eclipsedir}/plugins
+
 %clean
 rm -rf $RPM_BUILD_ROOT
 
@@ -46,3 +85,14 @@ rm -rf $RPM_BUILD_ROOT
 %{eclipsedir}/plugins/com.google.gdt.eclipse.core_*.jar
 %{eclipsedir}/plugins/com.google.gdt.eclipse.suite_*.jar
 %{eclipsedir}/plugins/com.google.gwt.eclipse.core_*.jar
+
+%files appengine
+%defattr(644,root,root,755)
+%{eclipsedir}/features/com.google.appengine.eclipse.sdkbundle.e33.feature_*.jar
+%{eclipsedir}/plugins/com.google.appengine.eclipse.sdkbundle_*.jar
+
+%files gwt
+%defattr(644,root,root,755)
+%{eclipsedir}/features/com.google.gwt.eclipse.sdkbundle.e33.feature_*.jar
+# XXX: ix86 mozilla inside
+%{eclipsedir}/plugins/com.google.gwt.eclipse.sdkbundle.linux_*.jar
This page took 0.05927 seconds and 4 git commands to generate.