]> git.pld-linux.org Git - packages/eclipse-plugin-google.git/blob - eclipse-plugin-google.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/eclipse-plugin-google.git] / eclipse-plugin-google.spec
1 # TODO:
2 # - com.google.appengine.eclipse.sdkbundle_1.2.1.v200905131156/
3 # - com.google.gwt.eclipse.sdkbundle.linux_1.6.4.v200904062254 is x86 centric (build from source?)
4 # - http://code.google.com/webtoolkit/makinggwtbetter.html#compiling
5 %define         pluginver       1.0.1
6 %define         appengver       1.2.1
7 %define         gwtver          1.6.4
8 %include        /usr/lib/rpm/macros.java
9 Summary:        Google Plugin for Eclipse
10 Name:           eclipse-plugin-google
11 Version:        %{pluginver}
12 Release:        0.7
13 License:        Apache License, v2.0
14 Group:          Development/Tools
15 URL:            http://code.google.com/eclipse/
16 # http://code.google.com/eclipse/docs/install-from-zip.html
17 Source0:        http://dl.google.com/eclipse/plugin/3.3/zips/gpe-e33-latest.zip
18 # Source0-md5:  955d207982a0ec954b1c067019c33694
19 Source1:        http://dl.google.com/eclipse/plugin/3.3/features/com.google.appengine.eclipse.sdkbundle.e33.feature_%{appengver}.v200905131156.jar
20 # Source1-md5:  44dbeb0e33c1458658b1626b86efd677
21 Source2:        http://dl.google.com/eclipse/plugin/3.3/plugins/com.google.appengine.eclipse.sdkbundle_%{appengver}.v200905131156.jar
22 # Source2-md5:  ebc7c16b7291830497a24312980919c6
23 Source3:        http://dl.google.com/eclipse/plugin/3.3/features/com.google.gwt.eclipse.sdkbundle.e33.feature_%{gwtver}.v200904062254.jar
24 # Source3-md5:  8de9b4a53690e36e4af4fdd0e02f1528
25 Source4:        http://dl.google.com/eclipse/plugin/3.3/plugins/com.google.gwt.eclipse.sdkbundle.linux_%{gwtver}.v200904062254.jar
26 # Source4-md5:  9fe86bcde62ab891569b96fdb6fc0752
27 BuildRequires:  rpm-javaprov
28 BuildRequires:  unzip
29 Requires:       eclipse >= 3.3
30 BuildArch:      noarch
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %define         eclipsedir      %{_datadir}/eclipse
34
35 # somewhy rpm-4.5 searches for ELF provides even the .so files are not executable
36 %define         _noautoprovfiles        %{_datadir}/eclipse
37
38 %description
39 The Google Plugin for Eclipse is the fastest way to start developing
40 Google Web Toolkit and App Engine applications, allowing you to go
41 from installing the plugin to deploying an Ajax "Hello World" in a
42 matter of minutes. Simply install the plugin and get started. If you
43 don't have the GWT and App Engine SDKs installed, the plugin can take
44 care of that for you.
45
46 The plugin currently supports Google App Engine and Google Web Toolkit
47 development.
48
49 %package appengine
50 Summary:        Google App Engine for Java SDK Bundle for Eclipse
51 Version:        %{appengver}
52 Group:          Development/Tools
53 Requires:       %{name} = %{pluginver}-%{release}
54
55 %description appengine
56 Google App Engine for Java SDK Bundle for Eclipse.
57
58 %package gwt
59 Summary:        Google Web Toolkit SDK Bundle for Eclipse
60 Version:        %{gwtver}
61 Group:          Development/Tools
62 URL:            http://code.google.com/webtoolkit/
63 Requires:       %{name} = %{pluginver}-%{release}
64
65 %description gwt
66 Google Web Toolkit SDK Bundle for Eclipse.
67
68 %prep
69 %setup -qc
70 install -d appengine gwt
71 %{__unzip} -d appengine -qq %{SOURCE2}
72 %{__unzip} -d gwt -qq %{SOURCE4}
73
74 %install
75 rm -rf $RPM_BUILD_ROOT
76 install -d $RPM_BUILD_ROOT%{eclipsedir}/{features,plugins}
77 cp -a features/* $RPM_BUILD_ROOT%{eclipsedir}/features
78 cp -a plugins/* $RPM_BUILD_ROOT%{eclipsedir}/plugins
79
80 # appengine sdkbundle
81 cp -a %{SOURCE1} $RPM_BUILD_ROOT%{eclipsedir}/features
82 cp -a appengine $RPM_BUILD_ROOT%{eclipsedir}/plugins/$(basename %{SOURCE2} .jar)
83 # gwt sdkbundle
84 cp -a %{SOURCE3} $RPM_BUILD_ROOT%{eclipsedir}/features
85 cp -a gwt $RPM_BUILD_ROOT%{eclipsedir}/plugins/$(basename %{SOURCE4} .jar)
86
87 %clean
88 rm -rf $RPM_BUILD_ROOT
89
90 %files
91 %defattr(644,root,root,755)
92 %{eclipsedir}/features/com.google.gdt.eclipse.suite.e33.feature_*
93 %{eclipsedir}/plugins/com.google.appengine.eclipse.core_*.jar
94 %{eclipsedir}/plugins/com.google.gdt.eclipse.core_*.jar
95 %{eclipsedir}/plugins/com.google.gdt.eclipse.suite_*.jar
96 %{eclipsedir}/plugins/com.google.gwt.eclipse.core_*.jar
97
98 %files appengine
99 %defattr(644,root,root,755)
100 %{eclipsedir}/features/com.google.appengine.eclipse.sdkbundle.e33.feature_*.jar
101 %{eclipsedir}/plugins/com.google.appengine.eclipse.sdkbundle_*
102
103 %files gwt
104 %defattr(644,root,root,755)
105 %{eclipsedir}/features/com.google.gwt.eclipse.sdkbundle.e33.feature_*.jar
106 # XXX: ix86 mozilla inside
107 %{eclipsedir}/plugins/com.google.gwt.eclipse.sdkbundle.linux_*
This page took 0.135658 seconds and 3 git commands to generate.