]> git.pld-linux.org Git - packages/eclipse-plugin-cdt.git/blame - eclipse-plugin-cdt.spec
- up to 7.0.1
[packages/eclipse-plugin-cdt.git] / eclipse-plugin-cdt.spec
CommitLineData
9896cc05
JB
1#
2# Conditional build:
3%bcond_without incall # don't include all tarballs in .src.rpm
4#
8a4acbd2 5%define plugin_name cdt
6c15ca5a 6%define need_x86 0
7%define need_ppc 0
8%define need_ia64 0
9%define need_x8664 0
10
11%if %{with incall}
12%define need_x86 1
13%define need_ppc 1
297d9431 14%define need_ia64 1
6c15ca5a 15%define need_x8664 1
16%else
17%ifarch %{ix86}
18%define need_x86 1
19%endif
20%ifarch ppc
21%define need_ppc 1
22%endif
23%ifarch ia64
24%define need_ia64 1
25%endif
26%ifarch %{x8664}
27%define need_x8664 1
28%endif
29%endif
30
6a99fdd9 31Summary: CDT - a set of plugins for Eclipse that implement a C/C++ IDE
39e0137e 32Summary(pl.UTF-8): CDT - zestaw wtyczek do środowiska Eclipse implementujący IDE C/C++
8a4acbd2
JP
33Name: eclipse-plugin-%{plugin_name}
34%define _ver_major 7.0
35%define _ver_minor 1
b7220099 36Version: %{_ver_major}.%{_ver_minor}
8a4acbd2 37Release: 0.1
d767739f 38License: CPL v1.0
6a99fdd9 39Group: Development/Languages
8a4acbd2
JP
40Source0: http://download.eclipse.org/tools/cdt/releases/helios/dist/cdt-master-%{version}.zip
41# Source0-md5: c84f16f67b197b4ea8e8a62a9e1d6cea
6a99fdd9 42URL: http://www.eclipse.org/cdt/
e78630c3 43BuildRequires: unzip
8a4acbd2 44Requires: eclipse >= 3.6
9896cc05 45ExclusiveArch: %{ix86} %{x8664} ia64 ppc
6a99fdd9
PS
46BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
47
44cf1b12 48%define _eclipse_arch %(echo %{_target_cpu} | sed 's/i.86/x86/;s/athlon/x86/;s/pentium./x86/')
8a4acbd2 49%define _plugindir %{_libdir}/eclipse/dropins/%{plugin_name}
6a99fdd9
PS
50
51%description
9bdcb683
PS
52The CDT project adds a C/C++ Perspective to the Eclipse Workbench that
53supports C/C++ development with a number of views, wizards, a powerful
54editor, and a debugger.
55
ccc7e2e4
JR
56%description -l pl.UTF-8
57Projekt CDT rozszerza zintegrowane środowisko programistyczne Eclipse
58o nowe elementy wspomagające tworzenie aplikacji w językach C i C++.
6a99fdd9
PS
59
60%prep
2e624cd0 61%setup -q -c
6a99fdd9
PS
62
63%build
2e624cd0
BZ
64rm -rf plugins/org.eclipse.cdt.*aix*_%{_ver_major}.*
65rm -rf plugins/org.eclipse.cdt.*macosx*_%{_ver_major}.*
66rm -rf plugins/org.eclipse.cdt.*qnx*_%{_ver_major}.*
67rm -rf plugins/org.eclipse.cdt.*solaris*_%{_ver_major}.*
68rm -rf plugins/org.eclipse.cdt.*win32*_%{_ver_major}.*
d767739f 69%ifnarch %{ix86}
2e624cd0 70rm -rf plugins/org.eclipse.cdt.*.x86_%{_ver_major}.*
d767739f
PS
71%endif
72%ifnarch ppc
2e624cd0 73rm -rf plugins/org.eclipse.cdt.*.ppc_%{_ver_major}.*
6a99fdd9 74%endif
d767739f 75%ifnarch ia64
2e624cd0 76rm -rf plugins/org.eclipse.cdt.*.ia64_%{_ver_major}.*
6c15ca5a 77%endif
78%ifnarch %{x8664}
2e624cd0 79rm -rf plugins/org.eclipse.cdt.*.x86_64_%{_ver_major}.*
6a99fdd9
PS
80%endif
81
82%install
83rm -rf $RPM_BUILD_ROOT
8a4acbd2 84install -d $RPM_BUILD_ROOT%{_plugindir}/eclipse/{features,plugins}
0944af9e 85
8a4acbd2 86cp -r * $RPM_BUILD_ROOT%{_plugindir}/eclipse
6a99fdd9
PS
87
88%clean
89rm -rf $RPM_BUILD_ROOT
90
91%files
92%defattr(644,root,root,755)
8a4acbd2
JP
93%dir %{_plugindir}
94%dir %{_plugindir}/eclipse
95%dir %{_plugindir}/eclipse/features
96%{_plugindir}/eclipse/features/*.jar
97%dir %{_plugindir}/eclipse/plugins
98%{_plugindir}/eclipse/plugins/net.sourceforge.lpg*.jar
99%{_plugindir}/eclipse/plugins/org.eclipse.ant.*.jar
100%{_plugindir}/eclipse/plugins/org.eclipse.cdt*.jar
101%{_plugindir}/eclipse/plugins/org.eclipse.test*.jar
102%{_plugindir}/eclipse/plugins/org.eclipse.tm.tcf*.jar
This page took 0.043289 seconds and 4 git commands to generate.