]> git.pld-linux.org Git - packages/eclipse-plugin-cdt.git/blame - eclipse-plugin-cdt.spec
- 7.0.2
[packages/eclipse-plugin-cdt.git] / eclipse-plugin-cdt.spec
CommitLineData
9896cc05
JB
1#
2# Conditional build:
3%bcond_without incall # don't include all tarballs in .src.rpm
4#
8a4acbd2 5%define plugin_name cdt
6c15ca5a 6%define need_x86 0
7%define need_ppc 0
8%define need_ia64 0
9%define need_x8664 0
10
11%if %{with incall}
12%define need_x86 1
13%define need_ppc 1
297d9431 14%define need_ia64 1
6c15ca5a 15%define need_x8664 1
16%else
17%ifarch %{ix86}
18%define need_x86 1
19%endif
20%ifarch ppc
21%define need_ppc 1
22%endif
23%ifarch ia64
24%define need_ia64 1
25%endif
26%ifarch %{x8664}
27%define need_x8664 1
28%endif
29%endif
30
6a99fdd9 31Summary: CDT - a set of plugins for Eclipse that implement a C/C++ IDE
39e0137e 32Summary(pl.UTF-8): CDT - zestaw wtyczek do środowiska Eclipse implementujący IDE C/C++
8a4acbd2
JP
33Name: eclipse-plugin-%{plugin_name}
34%define _ver_major 7.0
09e3fd6b 35%define _ver_minor 2
b7220099 36Version: %{_ver_major}.%{_ver_minor}
357c5e6d 37Release: 1
d767739f 38License: CPL v1.0
6a99fdd9 39Group: Development/Languages
8a4acbd2 40Source0: http://download.eclipse.org/tools/cdt/releases/helios/dist/cdt-master-%{version}.zip
09e3fd6b 41# Source0-md5: 01a34887d24bded98769f44fccc51282
6a99fdd9 42URL: http://www.eclipse.org/cdt/
e78630c3 43BuildRequires: unzip
8a4acbd2 44Requires: eclipse >= 3.6
9896cc05 45ExclusiveArch: %{ix86} %{x8664} ia64 ppc
6a99fdd9
PS
46BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
47
8a4acbd2 48%define _plugindir %{_libdir}/eclipse/dropins/%{plugin_name}
6a99fdd9
PS
49
50%description
9bdcb683
PS
51The CDT project adds a C/C++ Perspective to the Eclipse Workbench that
52supports C/C++ development with a number of views, wizards, a powerful
53editor, and a debugger.
54
ccc7e2e4
JR
55%description -l pl.UTF-8
56Projekt CDT rozszerza zintegrowane środowisko programistyczne Eclipse
57o nowe elementy wspomagające tworzenie aplikacji w językach C i C++.
6a99fdd9
PS
58
59%prep
2e624cd0 60%setup -q -c
6a99fdd9
PS
61
62%build
2e624cd0
BZ
63rm -rf plugins/org.eclipse.cdt.*aix*_%{_ver_major}.*
64rm -rf plugins/org.eclipse.cdt.*macosx*_%{_ver_major}.*
65rm -rf plugins/org.eclipse.cdt.*qnx*_%{_ver_major}.*
66rm -rf plugins/org.eclipse.cdt.*solaris*_%{_ver_major}.*
67rm -rf plugins/org.eclipse.cdt.*win32*_%{_ver_major}.*
d767739f 68%ifnarch %{ix86}
2e624cd0 69rm -rf plugins/org.eclipse.cdt.*.x86_%{_ver_major}.*
d767739f
PS
70%endif
71%ifnarch ppc
2e624cd0 72rm -rf plugins/org.eclipse.cdt.*.ppc_%{_ver_major}.*
6a99fdd9 73%endif
d767739f 74%ifnarch ia64
2e624cd0 75rm -rf plugins/org.eclipse.cdt.*.ia64_%{_ver_major}.*
6c15ca5a 76%endif
77%ifnarch %{x8664}
2e624cd0 78rm -rf plugins/org.eclipse.cdt.*.x86_64_%{_ver_major}.*
6a99fdd9
PS
79%endif
80
81%install
82rm -rf $RPM_BUILD_ROOT
23746f53 83install -d $RPM_BUILD_ROOT%{_plugindir}/{features,plugins}
0944af9e 84
23746f53 85cp -r * $RPM_BUILD_ROOT%{_plugindir}
6a99fdd9
PS
86
87%clean
88rm -rf $RPM_BUILD_ROOT
89
90%files
91%defattr(644,root,root,755)
8a4acbd2 92%dir %{_plugindir}
23746f53
JR
93%dir %{_plugindir}/features
94%dir %{_plugindir}/plugins
95%{_plugindir}/features/*.jar
96%{_plugindir}/plugins/net.sourceforge.lpg*.jar
97%{_plugindir}/plugins/org.eclipse.ant.*.jar
98%{_plugindir}/plugins/org.eclipse.cdt*.jar
99%{_plugindir}/plugins/org.eclipse.test*.jar
100%{_plugindir}/plugins/org.eclipse.tm.tcf*.jar
This page took 0.077899 seconds and 4 git commands to generate.