]> git.pld-linux.org Git - packages/eclipse-ecj.git/blob - eclipse-ecj.spec
a9213e81a970a495a018c8747bc9536c08245877
[packages/eclipse-ecj.git] / eclipse-ecj.spec
1 Summary:        Eclipse Compiler for Java
2 Name:           eclipse-ecj
3 Version:        3.2.2
4 Release:        0.1
5 License:        EPL v1.0
6 Group:          Development/Tools
7 Source0:        http://distro.ibiblio.org:/pub/linux/distributions/gentoo/distfiles/eclipse-ecj-3.2.2.tar.bz2
8 # Source0-md5:  21f55de66c2deec51b6714b607b6793f
9 Patch0:         %{name}-gentoo.patch
10 URL:            http://www.eclipse.org/
11 BuildRequires:  ant >= 1.6.1
12 BuildRequires:  jdk >= 1.4
13 BuildRequires:  pkgconfig
14 BuildRequires:  rpm-pythonprov
15 BuildRequires:  rpmbuild(macros) >= 1.300
16 BuildRequires:  unzip
17 BuildRequires:  zip
18 Requires:       ant
19 Requires:       jdk >= 1.4
20 ExclusiveArch:  i586 i686 pentium3 pentium4 athlon %{x8664}
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %define         _eclipse_arch   %(echo %{_target_cpu} | sed 's/i.86\\|athlon\\|pentium/x86/;s/amd64/x86_64/')
24 %define         no_install_post_chrpath         1
25
26 %description
27 Eclipse Compiler for Java.
28
29 %prep
30 %setup -q
31 %patch0 -p1
32
33 %build
34 export JAVA_HOME=%{java_home}
35
36 ant -f compilejdtcorewithjavac.xml
37
38 CLASSPATH=${PWD}/ecj.jar; export CLASSPATH
39
40 ant -lib ecj.jar -f compilejdtcore.xml compile
41
42 %install
43 rm -rf $RPM_BUILD_ROOT
44 install -d $RPM_BUILD_ROOT{%{_bindir},%{_javadir}}
45
46 cat << 'EOF' > $RPM_BUILD_ROOT%{_bindir}/ecj
47 #!/bin/sh
48 . %{_javadir}-utils/java-functions
49 set_javacmd
50
51 CLASSPATH=%{_javadir}/ecj.jar${CLASSPATH:+:}$CLASSPATH \
52 java org.eclipse.jdt.internal.compiler.batch.Main "$@"
53 EOF
54
55 install ecj.jar $RPM_BUILD_ROOT%{_javadir}
56
57 %clean
58 rm -rf $RPM_BUILD_ROOT
59
60 %files
61 %defattr(644,root,root,755)
62 %attr(755,root,root) %{_bindir}/ecj
63 %{_javadir}/*.jar
This page took 0.060563 seconds and 2 git commands to generate.