]> git.pld-linux.org Git - packages/eclipse-ecj.git/blame - eclipse-ecj.spec
- more
[packages/eclipse-ecj.git] / eclipse-ecj.spec
CommitLineData
d77d5c98
AM
1Summary: Eclipse Compiler for Java
2Name: eclipse-ecj
3Version: 3.2.2
4Release: 0.1
5License: EPL v1.0
6Group: Development/Tools
7Source0: http://distro.ibiblio.org:/pub/linux/distributions/gentoo/distfiles/eclipse-ecj-3.2.2.tar.bz2
8# Source0-md5: 21f55de66c2deec51b6714b607b6793f
9Patch0: %{name}-gentoo.patch
10URL: http://www.eclipse.org/
11BuildRequires: ant >= 1.6.1
12BuildRequires: jdk >= 1.4
13BuildRequires: pkgconfig
14BuildRequires: rpm-pythonprov
15BuildRequires: rpmbuild(macros) >= 1.300
16BuildRequires: unzip
17BuildRequires: zip
18Requires: ant
19Requires: jdk >= 1.4
20ExclusiveArch: i586 i686 pentium3 pentium4 athlon %{x8664}
21BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23%define _eclipse_arch %(echo %{_target_cpu} | sed 's/i.86\\|athlon\\|pentium/x86/;s/amd64/x86_64/')
24%define no_install_post_chrpath 1
25
26%description
27Eclipse Compiler for Java.
28
29%prep
30%setup -q
31%patch0 -p1
32
33%build
d77d5c98
AM
34export JAVA_HOME=%{java_home}
35
36ant -f compilejdtcorewithjavac.xml
a09fb485
AM
37
38CLASSPATH=${PWD}/ecj.jar; export CLASSPATH
39
d77d5c98
AM
40ant -lib ecj.jar -f compilejdtcore.xml compile
41
42%install
43rm -rf $RPM_BUILD_ROOT
a09fb485
AM
44install -d $RPM_BUILD_ROOT{%{_bindir},%{_javadir}}
45
46cat << 'EOF' > $RPM_BUILD_ROOT%{_bindir}/ecj
47#!/bin/sh
48. %{_javadir}-utils/java-functions
49set_javacmd
50
51CLASSPATH=%{_javadir}/ecj.jar${CLASSPATH:+:}$CLASSPATH \
52java org.eclipse.jdt.internal.compiler.batch.Main "$@"
53EOF
54
55install ecj.jar $RPM_BUILD_ROOT%{_javadir}
d77d5c98
AM
56
57%clean
58rm -rf $RPM_BUILD_ROOT
59
60%files
61%defattr(644,root,root,755)
a09fb485
AM
62%attr(755,root,root) %{_bindir}/ecj
63%{_javadir}/*.jar
This page took 0.074687 seconds and 4 git commands to generate.