]> git.pld-linux.org Git - packages/ecl.git/blob - ecl.spec
- New spec file.
[packages/ecl.git] / ecl.spec
1 %define _patchlevel     p1
2 Summary:        Embeddable Common Lisp
3 Summary(pl.UTF-8):      Osadzalny Common Lisp
4 Name:           ecl
5 Version:        0.9j
6 Release:        1.%{_patchlevel}.1
7 License:        GPL v2
8 Group:          Development/Languages
9 Source0:        http://dl.sourceforge.net/sourceforge/ecls/%{name}-%{version}-%{_patchlevel}.tgz
10 # Source0-md5:  2e20a0fcad15f323b233488bbaef636a
11 URL:            http://ecls.sourceforge.net/
12 BuildRequires:  gc-devel
13 BuildRequires:  gmp-devel
14 BuildRequires:  sed >= 4.0
15 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
16
17 %description
18 ECL is a Common Lisp implementation initially developed by Giuseppe
19 Attardi and currently maintained by Juan Jose Garcia-Ripoll. ECL is
20 the successor to EcoLisp.  It works by compiling Lisp code to C and
21 invoking C compiler.
22
23 %description -l pl.UTF-8
24 ECL jest implementacją języka Common Lisp pierwotnie opracowaną przez
25 Giuseppe Attardiego, obecnie zaś utrzymywaną przez Juana Jose
26 Garcia-Ripoll.  ECL jest następcą implementacji EcoLisp.  Działa
27 kompilując kod Lispa do C i wywołując kompilator C.
28
29 %prep
30 %setup -q
31
32 # remove CVS control files
33 find -name CVS -print0 | xargs -0 rm -rf
34
35 %build
36
37 # Make ./configure wrapper accept spaces in arguments
38 %{__sed} -i 's/\$\*/"${@}"/' ./configure
39
40 %configure \
41     --enable-boehm=system \
42     --with-system-gmp \
43     --with-__thread
44
45 # Fix a typo
46 %{__sed} -i 's!..ANNOUNCEMENT!../ANNOUNCEMENT!' build/doc/Makefile
47
48 %{__make} all doc
49
50 %install
51 rm -rf $RPM_BUILD_ROOT
52
53 %{__make} install \
54         DESTDIR=$RPM_BUILD_ROOT
55
56 %{__make} -C ./build/doc install \
57         DESTDIR=$RPM_BUILD_ROOT
58
59 mkdir -p $RPM_BUILD_ROOT%{_examplesdir}
60 cp -R examples $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
61
62
63 %clean
64 rm -rf $RPM_BUILD_ROOT
65
66 %files
67 %defattr(644,root,root,755)
68 %doc ANNOUNCEMENT Copyright build/doc/*.html
69 %{_libdir}/%{name}
70 %attr(755,root,root) %{_libdir}/libecl.so
71 %{_includedir}/%{name}
72 %attr(755,root,root) %{_bindir}/*
73 %{_examplesdir}/%{name}-%{version}
74 %{_infodir}/%{name}*
75 %{_mandir}/*/*
This page took 0.081398 seconds and 3 git commands to generate.