]> git.pld-linux.org Git - packages/ecl.git/blame - ecl.spec
- New spec file.
[packages/ecl.git] / ecl.spec
CommitLineData
658183d5 1%define _patchlevel p1
2Summary: Embeddable Common Lisp
3Summary(pl.UTF-8): Osadzalny Common Lisp
4Name: ecl
5Version: 0.9j
6Release: 1.%{_patchlevel}.1
7License: GPL v2
8Group: Development/Languages
9Source0: http://dl.sourceforge.net/sourceforge/ecls/%{name}-%{version}-%{_patchlevel}.tgz
10# Source0-md5: 2e20a0fcad15f323b233488bbaef636a
11URL: http://ecls.sourceforge.net/
12BuildRequires: gc-devel
13BuildRequires: gmp-devel
14BuildRequires: sed >= 4.0
15BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
16
17%description
18ECL is a Common Lisp implementation initially developed by Giuseppe
19Attardi and currently maintained by Juan Jose Garcia-Ripoll. ECL is
20the successor to EcoLisp. It works by compiling Lisp code to C and
21invoking C compiler.
22
23%description -l pl.UTF-8
24ECL jest implementacją języka Common Lisp pierwotnie opracowaną przez
25Giuseppe Attardiego, obecnie zaś utrzymywaną przez Juana Jose
26Garcia-Ripoll. ECL jest następcą implementacji EcoLisp. Działa
27kompilując kod Lispa do C i wywołując kompilator C.
28
29%prep
30%setup -q
31
32# remove CVS control files
33find -name CVS -print0 | xargs -0 rm -rf
34
35%build
36
37# Make ./configure wrapper accept spaces in arguments
38%{__sed} -i 's/\$\*/"${@}"/' ./configure
39
40%configure \
41 --enable-boehm=system \
42 --with-system-gmp \
43 --with-__thread
44
45# Fix a typo
46%{__sed} -i 's!..ANNOUNCEMENT!../ANNOUNCEMENT!' build/doc/Makefile
47
48%{__make} all doc
49
50%install
51rm -rf $RPM_BUILD_ROOT
52
53%{__make} install \
54 DESTDIR=$RPM_BUILD_ROOT
55
56%{__make} -C ./build/doc install \
57 DESTDIR=$RPM_BUILD_ROOT
58
59mkdir -p $RPM_BUILD_ROOT%{_examplesdir}
60cp -R examples $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
61
62
63%clean
64rm -rf $RPM_BUILD_ROOT
65
66%files
67%defattr(644,root,root,755)
68%doc ANNOUNCEMENT Copyright build/doc/*.html
69%{_libdir}/%{name}
70%attr(755,root,root) %{_libdir}/libecl.so
71%{_includedir}/%{name}
72%attr(755,root,root) %{_bindir}/*
73%{_examplesdir}/%{name}-%{version}
74%{_infodir}/%{name}*
75%{_mandir}/*/*
This page took 0.097405 seconds and 4 git commands to generate.