]> git.pld-linux.org Git - packages/eb.git/blob - eb.spec
28612b6f35b5f970bf4526e13cdccd5abe334933
[packages/eb.git] / eb.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # do not build and package API docs
4 %bcond_without  static_libs     # don't build static libraries
5 #
6 Summary:        Library for accessing CD-ROM books
7 #Summary(pl.UTF-8):     -
8 Name:           eb
9 Version:        4.4.3
10 Release:        2
11 License:        BSD
12 Group:          Libraries
13 Source0:        ftp://ftp.sra.co.jp/pub/misc/eb/%{name}-%{version}.tar.bz2
14 # Source0-md5:  17dd1fade7ba0b82ce6e60f19fcbc823
15 URL:            http://www.sra.co.jp/people/m-kasahr/eb/
16 BuildRequires:  zlib-devel
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %description
20 EB Library supports to access CD-ROM books of EB, EBG, EBXA, EBXA-C,
21 S-EBXA and EPWING formats.  CD-ROM books of those formats are popular
22 in Japan.  Since CD-ROM books themseves are stands on the ISO 9660
23 format, you can mount the discs by the same way as other ISO 9660
24 discs.
25
26 #%description -l pl.UTF-8
27
28 %package utils
29 Summary:        Utilities provided by EB library
30 Summary(pl.UTF-8):      Narzędzia dostarczane przez bibliotekę EB
31 Group:          Development/Libraries
32 Requires:       %{name} = %{version}-%{release}
33
34 %description utils
35 Utilities provided by EB library.
36
37 %description utils -l pl.UTF-8
38 Narzędzia dostarczane przez bibliotekę EB.
39
40 %package devel
41 Summary:        Header files for EB library
42 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki EB
43 Group:          Development/Libraries
44 Requires:       %{name} = %{version}-%{release}
45
46 %description devel
47 Header files for EB library.
48
49 %description devel -l pl.UTF-8
50 Pliki nagłówkowe biblioteki EB.
51
52 %package static
53 Summary:        Static EB library
54 Summary(pl.UTF-8):      Statyczna biblioteka EB
55 Group:          Development/Libraries
56 Requires:       %{name}-devel = %{version}-%{release}
57
58 %description static
59 Static EB library.
60
61 %description static -l pl.UTF-8
62 Statyczna biblioteka EB.
63
64 %package apidocs
65 Summary:        EB API documentation
66 Summary(pl.UTF-8):      Dokumentacja API biblioteki EB
67 Group:          Documentation
68
69 %description apidocs
70 API and internal documentation for EB library.
71
72 %description apidocs -l pl.UTF-8
73 Dokumentacja API biblioteki EB.
74
75 %prep
76 %setup -q
77
78 %build
79 %configure \
80         --enable-samples \
81         --enable-pthread \
82         --enable-ebnet \
83         --enable-ipv6 \
84         --with-pkgdocdir=%{_docdir}/%{name}-apidocs-%{version} \
85         %{!?with_static_libs:--disable-static}
86 %{__make}
87
88 %install
89 rm -rf $RPM_BUILD_ROOT
90
91 %{__make} install \
92         DESTDIR=$RPM_BUILD_ROOT
93
94 %find_lang %{name}
95 %find_lang ebutils
96
97 %clean
98 rm -rf $RPM_BUILD_ROOT
99
100 %post   -p /sbin/ldconfig
101 %postun -p /sbin/ldconfig
102
103 %files -f %{name}.lang
104 %defattr(644,root,root,755)
105 %doc AUTHORS ChangeLog* NEWS README
106 %attr(755,root,root) %{_libdir}/libeb.so.*.*.*
107 %attr(755,root,root) %ghost %{_libdir}/libeb.so.16
108
109 %files utils -f ebutils.lang
110 %defattr(644,root,root,755)
111 %attr(755,root,root) %{_bindir}/*
112
113 %files devel
114 %defattr(644,root,root,755)
115 %{_sysconfdir}/eb.conf
116 %{_libdir}/libeb.so
117 %{_libdir}/libeb.la
118 %{_includedir}/eb
119 %{_aclocaldir}/eb4.m4
120
121 %if %{with static_libs}
122 %files static
123 %defattr(644,root,root,755)
124 %{_libdir}/libeb.a
125 %endif
126
127 %if %{with apidocs}
128 %files apidocs
129 %defattr(644,root,root,755)
130 %doc %{_docdir}/%{name}-apidocs-%{version}
131 %endif
This page took 0.059373 seconds and 2 git commands to generate.