]> git.pld-linux.org Git - packages/easytag.git/commitdiff
- new patch fixing some problems with CDDB
authorMichal Chruszcz <mchruszcz@gmail.com>
Sun, 8 Feb 2004 12:48:04 +0000 (12:48 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    easytag-0.30d.patch -> 1.1

easytag-0.30d.patch [new file with mode: 0644]

diff --git a/easytag-0.30d.patch b/easytag-0.30d.patch
new file mode 100644 (file)
index 0000000..23c3248
--- /dev/null
@@ -0,0 +1,131 @@
+diff -ruN easytag-0.30c/configure easytag-0.30d/configure
+--- easytag-0.30c/configure    Mon Feb  2 18:51:24 2004
++++ easytag-0.30d/configure    Mon Feb  2 18:54:20 2004
+@@ -1,6 +1,6 @@
+ #! /bin/sh
+ # Guess values for system-dependent variables and create Makefiles.
+-# Generated by GNU Autoconf 2.53 for easytag 0.30c.
++# Generated by GNU Autoconf 2.53 for easytag 0.30d.
+ #
+ # Copyright 1992, 1993, 1994, 1995, 1996, 1998, 1999, 2000, 2001, 2002
+ # Free Software Foundation, Inc.
+@@ -412,8 +412,8 @@
+ # Identity of this package.
+ PACKAGE_NAME='easytag'
+ PACKAGE_TARNAME='easytag'
+-PACKAGE_VERSION='0.30c'
+-PACKAGE_STRING='easytag 0.30c'
++PACKAGE_VERSION='0.30d'
++PACKAGE_STRING='easytag 0.30d'
+ PACKAGE_BUGREPORT=''
+ ac_unique_file="src/easytag.h"
+@@ -918,7 +918,7 @@
+   # Omit some internal or obsolete options to make the list less imposing.
+   # This message is too long to be a string in the A/UX 3.1 sh.
+   cat <<_ACEOF
+-\`configure' configures easytag 0.30c to adapt to many kinds of systems.
++\`configure' configures easytag 0.30d to adapt to many kinds of systems.
+ Usage: $0 [OPTION]... [VAR=VALUE]...
+@@ -984,7 +984,7 @@
+ if test -n "$ac_init_help"; then
+   case $ac_init_help in
+-     short | recursive ) echo "Configuration of easytag 0.30c:";;
++     short | recursive ) echo "Configuration of easytag 0.30d:";;
+    esac
+   cat <<\_ACEOF
+@@ -1092,7 +1092,7 @@
+ test -n "$ac_init_help" && exit 0
+ if $ac_init_version; then
+   cat <<\_ACEOF
+-easytag configure 0.30c
++easytag configure 0.30d
+ generated by GNU Autoconf 2.53
+ Copyright 1992, 1993, 1994, 1995, 1996, 1998, 1999, 2000, 2001, 2002
+@@ -1107,7 +1107,7 @@
+ This file contains any messages produced by compilers while
+ running configure, to aid debugging if configure makes a mistake.
+-It was created by easytag $as_me 0.30c, which was
++It was created by easytag $as_me 0.30d, which was
+ generated by GNU Autoconf 2.53.  Invocation command line was
+   $ $0 $@
+@@ -1639,7 +1639,7 @@
+ # Define the identity of the package.
+  PACKAGE=easytag
+- VERSION=0.30c
++ VERSION=0.30d
+ cat >>confdefs.h <<_ACEOF
+@@ -12653,7 +12653,7 @@
+ } >&5
+ cat >&5 <<_CSEOF
+-This file was extended by easytag $as_me 0.30c, which was
++This file was extended by easytag $as_me 0.30d, which was
+ generated by GNU Autoconf 2.53.  Invocation command line was
+   CONFIG_FILES    = $CONFIG_FILES
+@@ -12715,7 +12715,7 @@
+ cat >>$CONFIG_STATUS <<_ACEOF
+ ac_cs_version="\\
+-easytag config.status 0.30c
++easytag config.status 0.30d
+ configured by $0, generated by GNU Autoconf 2.53,
+   with options \\"`echo "$ac_configure_args" | sed 's/[\\""\`\$]/\\\\&/g'`\\"
+diff -ruN easytag-0.30c/configure.in easytag-0.30d/configure.in
+--- easytag-0.30c/configure.in Mon Feb  2 18:51:24 2004
++++ easytag-0.30d/configure.in Mon Feb  2 18:54:19 2004
+@@ -6,7 +6,7 @@
+ dnl VERSION=0.28
+ AC_PREREQ(2.53)
+-AC_INIT(easytag, 0.30c) dnl defines ($PACKAGE, $VERSION)
++AC_INIT(easytag, 0.30d) dnl defines ($PACKAGE, $VERSION)
+ AC_CONFIG_SRCDIR(src/easytag.h)
+ dnl -------------------------------
+ dnl Init automake
+diff -ruN easytag-0.30c/easytag.spec easytag-0.30d/easytag.spec
+--- easytag-0.30c/easytag.spec Mon Feb  2 18:51:24 2004
++++ easytag-0.30d/easytag.spec Mon Feb  2 18:54:34 2004
+@@ -1,5 +1,5 @@
+ %define    name      easytag
+-%define    version   0.30c
++%define    version   0.30d
+ %define    release   1
+ %define    prefix    /usr
+diff -ruN easytag-0.30c/src/cddb.c easytag-0.30d/src/cddb.c
+--- easytag-0.30c/src/cddb.c   Sun Sep  7 01:01:10 2003
++++ easytag-0.30d/src/cddb.c   Mon Feb  2 18:57:06 2004
+@@ -1161,7 +1161,8 @@
+     for (i=0;i<CDDB_ANSWER_LINE_SIZE;i++)
+     {
+-        bytes_read = read(socket_id,&cddb_out[i],1);
++        //bytes_read = read(socket_id,&cddb_out[i],1); // This returns "Wrong Answer..." under FreeBSD 5.1
++        bytes_read = recv(socket_id,&cddb_out[i],1,0); // Patch from Jan Kanty Palus 13/01/2004
+         if (bytes_read < 0)
+             return -1; // Error!
+diff -ruN easytag-0.30c/src/setting.c easytag-0.30d/src/setting.c
+--- easytag-0.30c/src/setting.c        Sun Sep  7 01:09:16 2003
++++ easytag-0.30d/src/setting.c        Mon Feb  2 18:52:36 2004
+@@ -186,6 +186,7 @@
+     {"load_file_run_scanner",                CV_TYPE_BOOL,    &LOAD_FILE_RUN_SCANNER                },
++    {"cddb_server_name",                     CV_TYPE_STRING,  &CDDB_SERVER_NAME                     },
+     {"cddb_server_port",                     CV_TYPE_BOOL,    &CDDB_SERVER_PORT                     },
+     {"cddb_server_cgi_path",                 CV_TYPE_STRING,  &CDDB_SERVER_CGI_PATH                 },
+     {"cddb_use_proxy",                       CV_TYPE_BOOL,    &CDDB_USE_PROXY                       },
This page took 0.032845 seconds and 4 git commands to generate.