]> git.pld-linux.org Git - packages/eagle-usb.git/blobdiff - eagle-usb.spec
- rel 4
[packages/eagle-usb.git] / eagle-usb.spec
index db274c25c7225d6a43c59966a52a5ce413e06929..d42d3afd9f070a238dab5ee39a537344accd0f44 100644 (file)
@@ -7,23 +7,29 @@
 %bcond_without kernel          # don't build kernel modules
 %bcond_without smp             # don't build SMP module
 %bcond_without userspace       # don't build userspace tools
+%bcond_without cmvs
 %bcond_with    verbose         # verbose build (V=1)
 #
+%ifarch sparc
+# no USB in sparc(32) kernel; just build userspace to use with sparc64 kernel
+%undefine      with_kernel
+%endif
 Summary:       Linux driver for the Eagle 8051 Analog (sagem f@st 800/840/908/...) modems
 Summary(pl):   Sterownik dla Linuksa do modemów Eagle 8051 Analog (sagem f@st 800/840/908/...)
 Name:          eagle-usb
-Version:       2.2.0
-%define                _rel    0.1
+Version:       2.3.2
+%define                _rel    4
 Release:       %{_rel}
 License:       GPL v2
 Group:         Base/Kernel
-Source0:       http://download.gna.org/eagleusb/eagle-usb-2.2.0/%{name}-%{version}.tar.bz2
-# Source0-md5: ad3d985b324b97de736f1efb723deb5d
+Source0:       http://download.gna.org/eagleusb/eagle-usb-2.3.0/%{name}-%{version}.tar.bz2
+# Source0-md5: 91727db818e5170b2d78a99ee51c2d58
 Patch1:                %{name}-eu_types.patch
 Patch2:                %{name}-vpivci-info.patch
 Patch3:                %{name}-opt.patch
 Patch4:                %{name}-signal.patch
 Patch5:                %{name}-usb_kill_urb.patch
+Patch6:                %{name}-kernel_sources_checking_hack.patch
 URL:           http://gna.org/projects/eagleusb/
 BuildRequires: autoconf
 BuildRequires: automake
@@ -89,6 +95,7 @@ Sterownik dla Linuksa SMP do modem
 %patch3 -p1
 %patch4 -p1
 %patch5 -p1
+%patch6 -p1
 
 %ifnarch %{ix86}
 # invalid not only for ppc
@@ -106,7 +113,14 @@ for cfg in %{?with_dist_kernel:%{?with_smp:smp} up}%{!?with_dist_kernel:nondist}
        install -d include/{config,linux}
        ln -sf %{_kernelsrcdir}/config-$cfg .config
        ln -sf %{_kernelsrcdir}/include/linux/autoconf-$cfg.h include/linux/autoconf.h
+%ifarch ppc ppc64
+       install -d include/asm
+       [ ! -d %{_kernelsrcdir}/include/asm-powerpc ] || ln -sf %{_kernelsrcdir}/include/asm-powerpc/* include/asm
+       [ ! -d %{_kernelsrcdir}/include/asm-%{_target_base_arch} ] || ln -snf %{_kernelsrcdir}/include/asm-%{_target_base_arch}/* include/asm
+%else
        ln -sf %{_kernelsrcdir}/include/asm-%{_target_base_arch} include/asm
+%endif
+       ln -sf %{_kernelsrcdir}/Module.symvers-$cfg Module.symvers
        touch include/config/MARKER
        %{__make} -C %{_kernelsrcdir} clean \
                RCS_FIND_IGNORE="-name '*.ko' -o" \
@@ -114,7 +128,8 @@ for cfg in %{?with_dist_kernel:%{?with_smp:smp} up}%{!?with_dist_kernel:nondist}
                %{?with_verbose:V=1}
        %{__make} -C %{_kernelsrcdir} modules \
                M=$PWD O=$PWD \
-               %{?with_verbose:V=1}
+               %{?with_verbose:V=1} \
+               USE_CMVS=%{?with_cmvs:1}%{!?with_cmvs:0}
        mv eagle-usb{,-$cfg}.ko
 done
 cd -
@@ -124,8 +139,8 @@ cd -
 %{__aclocal} -I .
 %{__autoconf}
 %configure \
-       --with-dsp-dir=%{_datadir}/misc \
-       --with-kernel-src=%{_kernelsrcdir}
+       %{!?with_cmvs:--disable-cmvs} \
+       --with-dsp-dir=%{_datadir}/misc 
 %{__make} -C driver/firmware \
        OPT="%{rpmcflags}"
 %{__make} -C driver/user \
This page took 0.07691 seconds and 4 git commands to generate.