]> git.pld-linux.org Git - packages/e_dbus.git/blob - e_dbus.spec
- release 2
[packages/e_dbus.git] / e_dbus.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static library
4 #
5 %define         ecore_ver       1.1.0
6 %define         eina_ver        1.1.0
7 %define         evas_ver        1.1.0
8
9 Summary:        EFL wrapper for DBus
10 Summary(pl.UTF-8):      Obudowanie EFL dla systemu DBus
11 Name:           e_dbus
12 Version:        1.1.0
13 Release:        2
14 License:        BSD
15 Group:          Libraries
16 Source0:        http://download.enlightenment.org/releases/%{name}-%{version}.tar.bz2
17 # Source0-md5:  67154e0dc9bf6c57ee8c88fc2250e8d1
18 URL:            http://trac.enlightenment.org/e/wiki/E_Dbus
19 BuildRequires:  autoconf >= 2.52
20 BuildRequires:  automake >= 1.6
21 BuildRequires:  dbus-devel >= 0.62
22 BuildRequires:  ecore-devel >= %{ecore_ver}
23 BuildRequires:  eina-devel >= %{eina_ver}
24 BuildRequires:  evas-devel >= %{ecore_ver}
25 BuildRequires:  libtool
26 BuildRequires:  pkgconfig >= 1:0.22
27 Requires:       dbus-libs >= 0.62
28 Requires:       ecore >= %{ecore_ver}
29 Requires:       eina >= %{eina_ver}
30 Requires:       evas >= %{evas_ver}
31 Obsoletes:      ecore-dbus
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %undefine       __cxx
35
36 %description
37 EFL wrapper for DBus.
38
39 %description -l pl.UTF-8
40 Obudowanie EFL dla systemu DBus.
41
42 %package devel
43 Summary:        Header files for e_dbus library
44 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki e_dbus
45 Group:          Development/Libraries
46 Requires:       %{name} = %{version}-%{release}
47 Requires:       dbus-devel >= 0.62
48 Requires:       ecore-devel >= %{ecore_ver}
49 Requires:       eina-devel >= %{eina_ver}
50 Requires:       evas-devel >= %{evas_ver}
51
52 %description devel
53 Header files for e_dbus library.
54
55 %description devel -l pl.UTF-8
56 Pliki nagłówkowe biblioteki e_dbus.
57
58 %package static
59 Summary:        Static e_dbus library
60 Summary(pl.UTF-8):      Statyczna biblioteka e_dbus
61 Group:          Development/Libraries
62 Requires:       %{name}-devel = %{version}-%{release}
63
64 %description static
65 Static e_dbus library.
66
67 %description static -l pl.UTF-8
68 Statyczna biblioteka e_dbus.
69
70 %prep
71 %setup -q
72
73 %build
74 %{__libtoolize}
75 %{__aclocal} -I m4
76 %{__autoconf}
77 %{__autoheader}
78 %{__automake}
79 %configure \
80         --disable-silent-rules \
81         %{!?with_static_libs:--disable-static}
82 %{__make} V=1
83
84 %install
85 rm -rf $RPM_BUILD_ROOT
86
87 %{__make} install \
88         DESTDIR=$RPM_BUILD_ROOT
89
90 %clean
91 rm -rf $RPM_BUILD_ROOT
92
93 %post   -p /sbin/ldconfig
94 %postun -p /sbin/ldconfig
95
96 %files
97 %defattr(644,root,root,755)
98 %doc AUTHORS COPYING ChangeLog NEWS README
99 %attr(755,root,root) %{_bindir}/e-notify-send
100 %attr(755,root,root) %{_bindir}/e_dbus_bluez_test
101 %attr(755,root,root) %{_bindir}/e_dbus_connman0_7x_test
102 %attr(755,root,root) %{_bindir}/e_dbus_notification_daemon
103 %attr(755,root,root) %{_bindir}/e_dbus_notify
104 %attr(755,root,root) %{_bindir}/e_dbus_ofono_test
105 %attr(755,root,root) %{_bindir}/e_dbus_test
106 %attr(755,root,root) %{_bindir}/e_dbus_test_client
107 %attr(755,root,root) %{_bindir}/e_dbus_ukit_test
108 %attr(755,root,root) %{_libdir}/libebluez.so.*.*.*
109 %attr(755,root,root) %ghost %{_libdir}/libebluez.so.1
110 %attr(755,root,root) %{_libdir}/libeconnman0_7x.so.*.*.*
111 %attr(755,root,root) %ghost %{_libdir}/libeconnman0_7x.so.1
112 %attr(755,root,root) %{_libdir}/libedbus.so.*.*.*
113 %attr(755,root,root) %ghost %{_libdir}/libedbus.so.1
114 %attr(755,root,root) %{_libdir}/libehal.so.*.*.*
115 %attr(755,root,root) %ghost %{_libdir}/libehal.so.1
116 %attr(755,root,root) %{_libdir}/libenotify.so.*.*.*
117 %attr(755,root,root) %ghost %{_libdir}/libenotify.so.1
118 %attr(755,root,root) %{_libdir}/libeofono.so.*.*.*
119 %attr(755,root,root) %ghost %{_libdir}/libeofono.so.1
120 %attr(755,root,root) %{_libdir}/libeukit.so.*.*.*
121 %attr(755,root,root) %ghost %{_libdir}/libeukit.so.1
122 %{_datadir}/e_dbus
123
124 %files devel
125 %defattr(644,root,root,755)
126 %attr(755,root,root) %{_libdir}/libebluez.so
127 %attr(755,root,root) %{_libdir}/libeconnman0_7x.so
128 %attr(755,root,root) %{_libdir}/libedbus.so
129 %attr(755,root,root) %{_libdir}/libehal.so
130 %attr(755,root,root) %{_libdir}/libenotify.so
131 %attr(755,root,root) %{_libdir}/libeofono.so
132 %attr(755,root,root) %{_libdir}/libeukit.so
133 %{_libdir}/libebluez.la
134 %{_libdir}/libeconnman0_7x.la
135 %{_libdir}/libedbus.la
136 %{_libdir}/libehal.la
137 %{_libdir}/libeofono.la
138 %{_libdir}/libeukit.la
139 %{_libdir}/libenotify.la
140 %{_includedir}/e_dbus-1
141 %{_pkgconfigdir}/ebluez.pc
142 %{_pkgconfigdir}/econnman-0.7x.pc
143 %{_pkgconfigdir}/edbus.pc
144 %{_pkgconfigdir}/ehal.pc
145 %{_pkgconfigdir}/enotify.pc
146 %{_pkgconfigdir}/eofono.pc
147 %{_pkgconfigdir}/eukit.pc
148
149 %if %{with static_libs}
150 %files static
151 %defattr(644,root,root,755)
152 %{_libdir}/libebluez.a
153 %{_libdir}/libeconnman0_7x.a
154 %{_libdir}/libedbus.a
155 %{_libdir}/libehal.a
156 %{_libdir}/libenotify.a
157 %{_libdir}/libeofono.a
158 %{_libdir}/libeukit.a
159 %endif
This page took 0.032447 seconds and 3 git commands to generate.