]> git.pld-linux.org Git - packages/e_dbus.git/blob - e_dbus.spec
- x32 rebuild
[packages/e_dbus.git] / e_dbus.spec
1 # NOTE: deprecated package, EFL 1.7.x specific; EFL 1.8 uses new eldbus APIs instead
2 #
3 # Conditional build:
4 %bcond_without  static_libs     # don't build static library
5 #
6 %define         ecore_ver       1.7.10
7 %define         eina_ver        1.7.10
8 %define         evas_ver        1.7.10
9
10 Summary:        EFL wrapper for DBus
11 Summary(pl.UTF-8):      Obudowanie EFL dla systemu DBus
12 Name:           e_dbus
13 Version:        1.7.10
14 Release:        2
15 License:        BSD
16 Group:          Libraries
17 Source0:        http://download.enlightenment.org/releases/%{name}-%{version}.tar.bz2
18 # Source0-md5:  f91fed0d720b21310c270ea8b0b80565
19 URL:            http://trac.enlightenment.org/e/wiki/E_Dbus
20 BuildRequires:  autoconf >= 2.52
21 BuildRequires:  automake >= 1.6
22 BuildRequires:  dbus-devel >= 0.62
23 BuildRequires:  ecore-devel >= %{ecore_ver}
24 BuildRequires:  ecore-evas-devel >= %{ecore_ver}
25 BuildRequires:  eina-devel >= %{eina_ver}
26 BuildRequires:  evas-devel >= %{ecore_ver}
27 BuildRequires:  libtool
28 BuildRequires:  pkgconfig >= 1:0.22
29 Requires:       dbus-libs >= 0.62
30 Requires:       ecore >= %{ecore_ver}
31 Requires:       ecore-evas >= %{ecore_ver}
32 Requires:       eina >= %{eina_ver}
33 Requires:       evas >= %{evas_ver}
34 Obsoletes:      ecore-dbus
35 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37 %undefine       __cxx
38
39 %description
40 EFL wrapper for DBus.
41
42 %description -l pl.UTF-8
43 Obudowanie EFL dla systemu DBus.
44
45 %package devel
46 Summary:        Header files for e_dbus library
47 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki e_dbus
48 Group:          Development/Libraries
49 Requires:       %{name} = %{version}-%{release}
50 Requires:       dbus-devel >= 0.62
51 Requires:       ecore-devel >= %{ecore_ver}
52 Requires:       eina-devel >= %{eina_ver}
53 Requires:       evas-devel >= %{evas_ver}
54
55 %description devel
56 Header files for e_dbus library.
57
58 %description devel -l pl.UTF-8
59 Pliki nagłówkowe biblioteki e_dbus.
60
61 %package static
62 Summary:        Static e_dbus library
63 Summary(pl.UTF-8):      Statyczna biblioteka e_dbus
64 Group:          Development/Libraries
65 Requires:       %{name}-devel = %{version}-%{release}
66
67 %description static
68 Static e_dbus library.
69
70 %description static -l pl.UTF-8
71 Statyczna biblioteka e_dbus.
72
73 %prep
74 %setup -q
75
76 %build
77 %{__libtoolize}
78 %{__aclocal} -I m4
79 %{__autoconf}
80 %{__autoheader}
81 %{__automake}
82 %configure \
83         --disable-silent-rules \
84         %{!?with_static_libs:--disable-static}
85 %{__make}
86
87 %install
88 rm -rf $RPM_BUILD_ROOT
89
90 %{__make} install \
91         DESTDIR=$RPM_BUILD_ROOT
92
93 # obsoleted by pkg-config
94 %{__rm} $RPM_BUILD_ROOT%{_libdir}/lib*.la
95
96 %clean
97 rm -rf $RPM_BUILD_ROOT
98
99 %post   -p /sbin/ldconfig
100 %postun -p /sbin/ldconfig
101
102 %files
103 %defattr(644,root,root,755)
104 %doc AUTHORS COPYING ChangeLog NEWS README
105 %attr(755,root,root) %{_bindir}/e-notify-send
106 %attr(755,root,root) %{_bindir}/e_dbus_async_client_test
107 %attr(755,root,root) %{_bindir}/e_dbus_async_server_test
108 %attr(755,root,root) %{_bindir}/e_dbus_bluez_test
109 %attr(755,root,root) %{_bindir}/e_dbus_connman0_7x_test
110 %attr(755,root,root) %{_bindir}/e_dbus_notification_daemon
111 %attr(755,root,root) %{_bindir}/e_dbus_notify
112 %attr(755,root,root) %{_bindir}/e_dbus_ofono_test
113 %attr(755,root,root) %{_bindir}/e_dbus_test
114 %attr(755,root,root) %{_bindir}/e_dbus_test_client
115 %attr(755,root,root) %{_bindir}/e_dbus_ukit_test
116 %attr(755,root,root) %{_libdir}/libebluez.so.*.*.*
117 %attr(755,root,root) %ghost %{_libdir}/libebluez.so.1
118 %attr(755,root,root) %{_libdir}/libeconnman0_7x.so.*.*.*
119 %attr(755,root,root) %ghost %{_libdir}/libeconnman0_7x.so.1
120 %attr(755,root,root) %{_libdir}/libedbus.so.*.*.*
121 %attr(755,root,root) %ghost %{_libdir}/libedbus.so.1
122 %attr(755,root,root) %{_libdir}/libehal.so.*.*.*
123 %attr(755,root,root) %ghost %{_libdir}/libehal.so.1
124 %attr(755,root,root) %{_libdir}/libenotify.so.*.*.*
125 %attr(755,root,root) %ghost %{_libdir}/libenotify.so.1
126 %attr(755,root,root) %{_libdir}/libeofono.so.*.*.*
127 %attr(755,root,root) %ghost %{_libdir}/libeofono.so.1
128 %attr(755,root,root) %{_libdir}/libeukit.so.*.*.*
129 %attr(755,root,root) %ghost %{_libdir}/libeukit.so.1
130 %{_datadir}/e_dbus
131
132 %files devel
133 %defattr(644,root,root,755)
134 %attr(755,root,root) %{_libdir}/libebluez.so
135 %attr(755,root,root) %{_libdir}/libeconnman0_7x.so
136 %attr(755,root,root) %{_libdir}/libedbus.so
137 %attr(755,root,root) %{_libdir}/libehal.so
138 %attr(755,root,root) %{_libdir}/libenotify.so
139 %attr(755,root,root) %{_libdir}/libeofono.so
140 %attr(755,root,root) %{_libdir}/libeukit.so
141 %{_includedir}/e_dbus-1
142 %{_pkgconfigdir}/ebluez.pc
143 %{_pkgconfigdir}/econnman-0.7x.pc
144 %{_pkgconfigdir}/edbus.pc
145 %{_pkgconfigdir}/ehal.pc
146 %{_pkgconfigdir}/enotify.pc
147 %{_pkgconfigdir}/eofono.pc
148 %{_pkgconfigdir}/eukit.pc
149
150 %if %{with static_libs}
151 %files static
152 %defattr(644,root,root,755)
153 %{_libdir}/libebluez.a
154 %{_libdir}/libeconnman0_7x.a
155 %{_libdir}/libedbus.a
156 %{_libdir}/libehal.a
157 %{_libdir}/libenotify.a
158 %{_libdir}/libeofono.a
159 %{_libdir}/libeukit.a
160 %endif
This page took 0.03926 seconds and 3 git commands to generate.