]> git.pld-linux.org Git - packages/e3.git/blob - e3.spec
- no_install_post_strip is back, e3 binary is statically linked and after
[packages/e3.git] / e3.spec
1 Summary:        Tiny editor
2 Summary(pl.UTF-8):      Mikroedytorek
3 Name:           e3
4 Version:        2.7.0
5 Release:        1
6 Epoch:          1
7 License:        GPL v2
8 Group:          Applications/Editors
9 Source0:        http://www.sax.de/~adlibit/%{name}-%{version}.tar.gz
10 # Source0-md5:  a76dd61c52a80a1f4d3938a4ce54c62e
11 Source1:        %{name}-editor.sh
12 Patch0:         %{name}-gcc421.patch
13 URL:            http://www.sax.de/~adlibit/
14 %ifarch %{ix86}
15 BuildRequires:  nasm
16 %endif
17 BuildRequires:  perl-base
18 %ifarch %{x8664}
19 BuildRequires:  yasm
20 %endif
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %define         no_install_post_strip   1
24
25 %description
26 e3 is a text micro editor with a code size less than 10000 bytes.
27 Except for 'undo' and 'syntax highlighting', e3 supports all of the
28 basic functions one expects. If you have installed the stream editor
29 'sed' or 'ex' you can use these tools as sub-processes, getting the
30 full power of regular expressions. e3 can use Wordstar-, EMACS-, Pico,
31 Nedit or vi-like key bindings, whichever the user chooses. e3 is
32 designed to be INDEPENDENT OF LIBC OR ANY OTHER library.
33
34 %description -l pl.UTF-8
35 e3 jest mikroskopijnym wręcz edytorem tekstu, jego rozmiar nie
36 przekracza 10000 bajtów. Wspiera on wszystkie podstawowe funkcje,
37 jakich można oczekiwać od edytora, z wyjątkiem podświetlania składni 
38 i cofania dokonanych zmian (undo). Jeśli chcesz skorzystać z potęgi
39 wyrażeń regularnych, to e3 może wywołać zewnętrzny edytor strumieni
40 ('sed' lub 'ex'). e3 potrafi emulować ustawienia klawiszy Wordstara,
41 EMACSA, Pico, Nedit oraz vi. e3 nie jest zależny od żadnej biblioteki
42 (wliczając glibc).
43
44 %prep
45 %setup -q
46 %patch0 -p1
47
48 %build
49 %ifarch %{ix86}
50 %{__make}
51 %endif
52 %ifarch %{x8664}
53 %{__make} yasm64 \
54         AFLAGS=-
55 %endif
56 %{__cc} %{rpmcflags} %{rpmldflags} -DLIBDIR=\"%{_libdir}\" e3c/e3.c -o e3c.bin
57
58 %install
59 rm -rf $RPM_BUILD_ROOT
60 install -d $RPM_BUILD_ROOT{%{_bindir},%{_mandir}/man1,%{_libdir}}
61 %ifarch %{ix86} %{x8664}
62 install e3 $RPM_BUILD_ROOT%{_bindir}/e3
63 %else
64 ln -sf e3c $RPM_BUILD_ROOT%{_bindir}/e3
65 %endif
66
67 install e3c.bin $RPM_BUILD_ROOT%{_bindir}/e3c
68
69 install %{SOURCE1} $RPM_BUILD_ROOT%{_bindir}/e3-editor.sh
70 install e3.man $RPM_BUILD_ROOT%{_mandir}/man1/e3.1
71 install e3c/e3c.man $RPM_BUILD_ROOT%{_mandir}/man1/e3c.1
72
73 install e3c/*.{hlp,res} $RPM_BUILD_ROOT%{_libdir}
74
75 for i in ws em pi vi ne; do
76         ln -sf e3 $RPM_BUILD_ROOT%{_bindir}/e3${i}
77 done
78
79 for i in emacs vi pico ne ws; do
80         ln -sf e3-editor.sh $RPM_BUILD_ROOT%{_bindir}/e3-$i
81 done
82
83 %clean
84 rm -rf $RPM_BUILD_ROOT
85
86 %files
87 %defattr(644,root,root,755)
88 %doc COPYRIGHT ChangeLog README
89 %attr(755,root,root) %{_bindir}/e3*
90 %{_mandir}/man1/e3*.1*
91 %{_libdir}/*.hlp
92 %{_libdir}/*.res
This page took 0.113519 seconds and 3 git commands to generate.