]> git.pld-linux.org Git - packages/e2fsprogs.git/blobdiff - e2fsprogs.spec
- updated to 1.42.13 (fixes CVE-2015-1572)
[packages/e2fsprogs.git] / e2fsprogs.spec
index 419a4b1e97e1a6b1c5c071084a2fef19dd3ddc58..e55848406363bf372f28ec29e050fa2996abdc03 100644 (file)
@@ -1,15 +1,27 @@
 #
 # Conditional build:
 %bcond_with    allstatic       # link everything statically
-%bcond_without static          # link e2fsck dynamically with libc
 %bcond_without nls             # build without NLS
-%bcond_without initrd          # don't build initrd version
+%bcond_without tls             # TLS
+%if "%{pld_release}" == "ac"
+%bcond_with    initrd          # don't build initrd version
 %bcond_without uClibc          # link initrd version with static glibc instead of uClibc
-#
-%ifarch sparc64 sparc
+%bcond_with    dietlibc        # link initrd version with dietlibc instead of uClibc
+%else
+%bcond_with    initrd          # don't build initrd version
+%bcond_with    uClibc          # link initrd version with static glibc instead of uClibc
+%bcond_without dietlibc        # link initrd version with dietlibc instead of uClibc
+%endif
+
+%ifarch sparc64 sparc alpha ppc ppc64
 %undefine       with_uClibc
 %endif
-#
+
+# see glibc.spec
+%ifarch        i386
+%undefine      with_tls
+%endif
+
 Summary:       Utilities for managing the second extended (ext2) filesystem
 Summary(cs.UTF-8):     Nástroje pro správu souborových systémů typu ext2
 Summary(da.UTF-8):     Værktøjer til håndtering af ext2 filsystemer
@@ -34,44 +46,54 @@ Summary(uk.UTF-8):  Утиліти для роботи з файловою сис
 Summary(zh_CN.UTF-8):  管理第二扩展(ext2)文件系统的工具。
 Summary(zh_TW.UTF-8):  用於管理 ext2 檔案系統的工具程式。
 Name:          e2fsprogs
-Version:       1.40.5
-Release:       0.1
+Version:       1.42.13
+Release:       1
 License:       GPL v2 (with LGPL v2 and BSD parts)
 Group:         Applications/System
-Source0:       http://dl.sourceforge.net/e2fsprogs/%{name}-%{version}.tar.gz
-# Source0-md5: 69e55eaf543acfab8e2eb8ba2883d8cd
+Source0:       http://downloads.sourceforge.net/e2fsprogs/%{name}-%{version}.tar.gz
+# Source0-md5: bc759fc62666786f5436e2075beb3265
 Source1:       e2compr-0.4.texinfo.gz
 # Source1-md5: c3c59ff37e49d8759abb1ef95a8d3abf
 Source2:       http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
 # Source2-md5: 992a37783bd42a897232972917e8ca7d
 Patch0:                %{name}-info.patch
 Patch1:                e2compr-info.patch
-Patch2:                %{name}-no-bashism.patch
+Patch2:                %{name}-498381.patch
+Patch3:                %{name}-diet.patch
 URL:           http://e2fsprogs.sourceforge.net/
-BuildRequires: autoconf
+BuildRequires: autoconf >= 2.54
 BuildRequires: automake
-BuildRequires: device-mapper-devel >= 1.02.18-2
-BuildRequires: gettext-devel >= 0.11
+BuildRequires: gettext-tools >= 0.11
+BuildRequires: libblkid-devel
+BuildRequires: libuuid-devel
+BuildRequires: pkgconfig
+BuildRequires: rpm >= 4.4.9-56
+BuildRequires: rpmbuild(macros) >= 1.583
 BuildRequires: texinfo
-%if %{with static}
-BuildRequires: device-mapper-static
+BuildRequires: texinfo-texi2dvi
+%if %{with allstatic}
 BuildRequires: glibc-static
-BuildRequires: libselinux-static
-BuildRequires: libsepol-static
 %endif
 %if %{with initrd}
        %if %{with uClibc}
-               %ifarch ppc
 BuildRequires: uClibc-static >= 2:0.9.29
+       %else
+               %if %{with dietlibc}
+BuildRequires: dietlibc-static >= 2:0.32-9
+BuildRequires: libblkid-dietlibc
+BuildRequires: libuuid-dietlibc
                %else
-BuildRequires: uClibc-static >= 2:0.9.26
+BuildRequires: glibc-static
+BuildRequires: libblkid-static
+BuildRequires: libuuid-static
                %endif
        %endif
 %endif
 Requires(post,postun): /sbin/ldconfig
-Requires:      fsck = %{version}-%{release}
+Requires:      %{name}-libs = %{version}-%{release}
+Requires:      fsck
 Requires:      libcom_err = %{version}-%{release}
-Requires:      libuuid = %{version}-%{release}
+Requires:      libss = %{version}-%{release}
 Obsoletes:     e2fsprogs-evms
 Obsoletes:     libext2fs2
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
@@ -79,6 +101,25 @@ BuildRoot:  %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 # changing CFLAGS in the middle confuses confcache
 %undefine       configure_cache
 
+# objdump -T /lib/libcom_err.so.2.1 | grep ___tls_get_addr
+# on ac it is:
+# 00000000      D  *UND*  00000000              ___tls_get_addr
+# on th it is:
+# 00000000      DF *UND*  00000000  GLIBC_2.3   ___tls_get_addr
+# yet on ac rpm-build-macros think it's unresolved symbol, but program still seem to work
+%if "%{pld_release}" == "ac"
+%define                skip_post_check_so      libcom_err.so.2.1
+%endif
+
+# for some reason known only to rpm there must be "\\|" not "\|" here
+%define                dietarch        %(echo %{_target_cpu} | sed -e 's/i.86\\|pentium.\\|athlon/i386/;s/amd64/x86_64/;s/armv.*/arm/')
+%define                dietlibdir      %{_prefix}/lib/dietlibc/lib-%{dietarch}
+
+%ifarch ppc ppc64
+# for dietlibc
+%define                filterout_ld    -Wl,-z,relro
+%endif
+
 %description
 The e2fsprogs package contains a number of utilities for creating,
 checking, modifying and correcting any inconsistencies in second
@@ -290,6 +331,20 @@ debugfs(用于检查文件系统的内部结构、手动修复被破坏的文
 创建测试范例)、 tune2fs(用于修改文件系统参数)和其它大多数核心
 ext2fs 文件系统实用程序。
 
+%package libs
+Summary:       ext2 filesystem-specific libraries
+Summary(pl.UTF-8):     Biblioteki dla systemu plików ext2
+Group:         Libraries
+Requires:      libcom_err = %{version}-%{release}
+Conflicts:     e2fsprogs < 1.40.6-3
+Conflicts:     fsck < 1.40.6-3
+
+%description libs
+ext2 filesystem-specific libraries.
+
+%description libs -l pl.UTF-8
+Biblioteki dla systemu plików ext2.
+
 %package devel
 Summary:       ext2 filesystem-specific libraries and headers
 Summary(cs.UTF-8):     Knihovny a hlavičkové soubory pro systém souborů ext2
@@ -314,10 +369,14 @@ Summary(uk.UTF-8):        Бібліотки програміста та хедери 
 Summary(zh_CN.UTF-8):  ext2 文件系统特有的静态库和头文件。
 Summary(zh_TW.UTF-8):  ext2 檔案系統特定的靜態函式庫與表頭。
 Group:         Development/Libraries
-Requires:      %{name} = %{version}-%{release}
+%if %{without allstatic}
+Requires:      %{name}-libs = %{version}-%{release}
+%endif
 Requires:      libcom_err-devel = %{version}-%{release}
-Requires:      libuuid-devel = %{version}-%{release}
+Requires:      libuuid-devel
 Obsoletes:     libext2fs2-devel
+# until it comes back
+Obsoletes:     libquota-devel
 
 %description devel
 e2fsprogs-devel contains the libraries and header files needed to
@@ -489,167 +548,201 @@ A Common Error Description Library for unices - static version.
 %description -n libcom_err-static -l pl.UTF-8
 Biblioteka opisu popularnych błędów dla uniksów - wersja statyczna.
 
-%package -n libuuid
-Summary:       Library for accessing and manipulating UUID
-Summary(pl.UTF-8):     Biblioteka umożliwiająca dostęp i zmiany UUID
-License:       BSD
+%package -n libss
+Summary:       Subsystem command parsing library
+Summary(pl.UTF-8):     Biblioteka analizy poleceń podsystemów
 Group:         Libraries
+Requires:      libcom_err = %{version}-%{release}
 Conflicts:     e2fsprogs < 1.34-3
+Conflicts:     e2fsprogs-libs < 1.41.11-2
 
-%description -n libuuid
-Library for accessing and manipulating UUID.
+%description -n libss
+Subsystem command parsing library.
 
-%description -n libuuid -l pl.UTF-8
-Biblioteka umożliwiająca dostęp i zmiany UUID.
+%description -n libss -l pl.UTF-8
+Biblioteka analizy poleceń podsystemów.
 
-%package -n libuuid-devel
-Summary:       Header files for library for accessing and manipulating UUID
-Summary(pl.UTF-8):     Pliki nagłówkowe biblioteki umożliwiającej dostęp i zmiany UUID
-License:       BSD
+%package -n libss-devel
+Summary:       Development files for subsystem command parsing library
+Summary(pl.UTF-8):     Pliki dla programistów do biblioteki analizy poleceń podsystemów
 Group:         Development/Libraries
-Requires:      libuuid = %{version}-%{release}
-Conflicts:     e2fsprogs-devel < 1.34-3
+Requires:      libcom_err-devel = %{version}-%{release}
+Requires:      libss = %{version}-%{release}
+Conflicts:     e2fsprogs < 1.41.11-2
+Conflicts:     e2fsprogs-devel < 1.41.11-2
 
-%description -n libuuid-devel
-Library for accessing and manipulating UUID - development files.
+%description -n libss-devel
+Development files for subsystem command parsing library, including
+header files and mk_cmds utility.
 
-%description -n libuuid-devel -l pl.UTF-8
-Biblioteka umożliwiająca dostęp i zmiany UUID - pliki dla
-programistów.
+%description -n libss-devel -l pl.UTF-8
+Biblioteka opisu popularPliki dla programistów do biblioteki analizy
+poleceń podsystemów - w tym pliki nagłówkowe i narzędzie mk_cmds.
 
-%package -n libuuid-static
-Summary:       Static library for accessing and manipulating UUID
-Summary(pl.UTF-8):     Statyczna biblioteka umożliwiająca dostęp i zmiany UUID
-License:       BSD
+%package -n libss-static
+Summary:       Static version of subsystem command parsing library
+Summary(pl.UTF-8):     Statyczna wersja biblioteki analizy poleceń podsystemów
 Group:         Development/Libraries
-Requires:      libuuid-devel = %{version}-%{release}
-Conflicts:     e2fsprogs-static < 1.34-3
+Requires:      libss-devel = %{version}-%{release}
+Conflicts:     e2fsprogs-static < 1.41.11-2
 
-%description -n libuuid-static
-Library for accessing and manipulating UUID - static version.
+%description -n libss-static
+Static version of subsystem command parsing library.
 
-%description -n libuuid-static -l pl.UTF-8
-Biblioteka umożliwiająca dostęp i zmiany UUID - wersja statyczna.
+%description -n libss-static -l pl.UTF-8
+Statyczna wersja biblioteki analizy poleceń podsystemów.
 
-%package -n fsck
-Summary:       Check and repair a Linux file system
-Summary(pl.UTF-8):     Sprawdzenie i naprawa linuksowego systemu plików
-Group:         Applications/System
-Requires:      libuuid = %{version}-%{release}
+%package -n libquota-devel
+Summary:       Quota management library
+Summary(pl.UTF-8):     Biblioteka do zarządzania limitami dyskowymi (quotami)
+Group:         Development/Libraries
 
-%description -n fsck
-Check and repair a Linux file system.
+%description -n libquota-devel
+Quota management library.
 
-%description -n fsck -l pl.UTF-8
-Sprawdzenie i naprawa linuksowego systemu plików.
+%description -n libquota-devel -l pl.UTF-8
+Biblioteka do zarządzania limitami dyskowymi (quotami).
 
 %package initrd
-Summary:       blkid - initrd version
-Summary(pl.UTF-8):     blkid - wersja dla initrd
+Summary:       e2fsck and mke2fs - initrd version
+Summary(pl.UTF-8):     e2fsck i mke2fs - wersja dla initrd
 Group:         Base
+Conflicts:     geninitrd < 10000.10
 
 %description initrd
-This package includes a blkid utility to recognize partitions by label
-or UUID - staticaly linked for initrd.
+This package includes a e2fsck and mke2fs utilities staticaly linked
+for initrd.
 
 %description initrd -l pl.UTF-8
-Pakiet ten zawiera narzędzie blkid do rozpoznawania partycji przez
-etykietę lub UUID - statycznie skonsolidowane na potrzeby initrd.
+Pakiet ten zawiera narzędzia e2fsck i mke2fs statycznie skonsolidowane
+na potrzeby initrd.
 
 %prep
 %setup -q
 %patch0 -p1
-gunzip < %{SOURCE1} > doc/e2compr.texinfo
+%{__gzip} -dc < %{SOURCE1} > doc/e2compr.texinfo
 %patch1 -p1
 %patch2 -p1
-
-sed -i -e "
-       s,DEVMAPPER_REQ='libselinux libsepol',DEVMAPPER_REQ=,;
-       s,DEVMAPPER_LIBS='-ldevmapper -lselinux -lsepol',DEVMAPPER_LIBS='-ldevmapper',;
-       s,/usr/lib/libdevmapper.a /usr/lib/libselinux.a /usr/lib/libsepol.a,/usr/%{_lib}/libdevmapper.a /usr/%{_lib}/libselinux.a /usr/%{_lib}/libsepol.a," \
-       -e '/AC_SUBST(DO_TEST_SUITE/a\MKINSTALLDIRS="install -d"\nAC_SUBST(MKINSTALLDIRS)\n' configure.in
-
-%{!?with_static:sed '/^all:/s/e2fsck\.static//' -i e2fsck/Makefile.in}
-
-# AX_TLS
-tail -n +2604 aclocal.m4 > acinclude.m4
+%patch3 -p1
 
 %build
 cp -f /usr/share/automake/config.sub .
-%{__gettextize}
 %{__aclocal}
 %{__autoconf}
 
 %if %{with initrd}
 %configure \
-       %{?with_uClibc:CC="%{_target_cpu}-uclibc-gcc"} \
        ac_cv_lib_dl_dlopen=no \
-       --with-ccopts="-Os" \
-       --with-ldopts="-static" \
+       %{?with_uClibc:CC="%{_target_cpu}-uclibc-gcc"} \
+       %{?with_dietlibc:CC="diet %{__cc}"} \
+       CFLAGS="%{rpmcflags} -Os" \
+       LDFLAGS="%{rpmldflags} -static" \
        --disable-elf-shlibs \
-       --disable-selinux \
-       --disable-nls
+       --disable-fsck \
+       --disable-libblkid \
+       --disable-libuuid \
+       --disable-nls \
+       --disable-testio-debug \
+       --disable-e2initrd-helper \
+       --disable-threads \
+       --disable-tls \
+       --disable-uuidd
 
-%{__make} libs
-%{__make} progs
-mv -f misc/blkid initrd-blkid
+%{__make} -j1 libs \
+       V=1
+%{__make} progs \
+       V=1
+mv -f misc/mke2fs initrd-mke2fs
 %{__make} clean
 %endif
 
 %configure \
        --with-root-prefix="" \
+       --disable-fsck \
+       --disable-libblkid \
+       --disable-libuuid \
        %{!?with_nls:--disable-nls} \
-       %{!?with_allstatic:--enable-elf-shlibs} \
-       --enable-blkid-devmapper \
+       %{!?with_tls:--disable-tls} \
+       --disable-rpath \
+       --disable-uuidd \
        --enable-compression \
+       %{!?with_allstatic:--enable-elf-shlibs} \
        --enable-htree \
-       %{!?with_static:--enable-dynamic-e2fsck} \
-       --enable-fsck \
-       --disable-rpath
+       --enable-quota
 
 %{__make} -j1 libs \
-       LDFLAGS="%{rpmldflags}"
+       LDFLAGS="%{rpmldflags}" \
+       V=1
 %{__make} progs docs \
-       LDFLAGS="%{rpmldflags}"
+       LDFLAGS="%{rpmldflags}" \
+       V=1
 
 cd doc
 makeinfo --no-split e2compr.texinfo
 
 %install
 rm -rf $RPM_BUILD_ROOT
+%{?with_dietlibc:install -d $RPM_BUILD_ROOT%{dietlibdir}}
 export PATH=/sbin:$PATH
 
-install -d $RPM_BUILD_ROOT/var/lib/libuuid
-
 echo "install-shlibs:" >> intl/Makefile
 
-%{__make} install install-libs \
+%{__make} -j1 install install-libs \
        root_libdir=/%{_lib} \
        mkinstalldirs='install -d' \
+       LDCONFIG=true \
        DESTDIR=$RPM_BUILD_ROOT
 
 ln -sf e2fsck $RPM_BUILD_ROOT/sbin/fsck.ext2
 ln -sf e2fsck $RPM_BUILD_ROOT/sbin/fsck.ext3
 ln -sf mke2fs $RPM_BUILD_ROOT/sbin/mkfs.ext2
 
-install doc/e2compr.info $RPM_BUILD_ROOT%{_infodir}
+cp -p doc/e2compr.info $RPM_BUILD_ROOT%{_infodir}
 
 touch $RPM_BUILD_ROOT%{_sysconfdir}/e2fsck.conf
 
 bzip2 -dc %{SOURCE2} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
 
-rm -f $RPM_BUILD_ROOT%{_mandir}/man8/{mkfs,fsck}.ext[23].8*
+rm -f $RPM_BUILD_ROOT%{_mandir}/man8/{mkfs,fsck}.ext[234]*.8*
 echo '.so e2fsck.8' > $RPM_BUILD_ROOT%{_mandir}/man8/fsck.ext2.8
 echo '.so e2fsck.8' > $RPM_BUILD_ROOT%{_mandir}/man8/fsck.ext3.8
+echo '.so e2fsck.8' > $RPM_BUILD_ROOT%{_mandir}/man8/fsck.ext4.8
+echo '.so e2fsck.8' > $RPM_BUILD_ROOT%{_mandir}/man8/fsck.ext4dev.8
 echo '.so mke2fs.8' > $RPM_BUILD_ROOT%{_mandir}/man8/mkfs.ext2.8
 echo '.so mke2fs.8' > $RPM_BUILD_ROOT%{_mandir}/man8/mkfs.ext3.8
+echo '.so mke2fs.8' > $RPM_BUILD_ROOT%{_mandir}/man8/mkfs.ext4.8
+echo '.so mke2fs.8' > $RPM_BUILD_ROOT%{_mandir}/man8/mkfs.ext4dev.8
 # missing in non-english-man-pages tarball
 echo '.so e2fsck.8' > $RPM_BUILD_ROOT%{_mandir}/hu/man8/fsck.ext3.8
+echo '.so e2fsck.8' > $RPM_BUILD_ROOT%{_mandir}/hu/man8/fsck.ext4.8
+echo '.so e2fsck.8' > $RPM_BUILD_ROOT%{_mandir}/hu/man8/fsck.ext4dev.8
 echo '.so e2fsck.8' > $RPM_BUILD_ROOT%{_mandir}/it/man8/fsck.ext3.8
+echo '.so e2fsck.8' > $RPM_BUILD_ROOT%{_mandir}/it/man8/fsck.ext4.8
+echo '.so e2fsck.8' > $RPM_BUILD_ROOT%{_mandir}/it/man8/fsck.ext4dev.8
 echo '.so mke2fs.8' > $RPM_BUILD_ROOT%{_mandir}/it/man8/mkfs.ext3.8
+echo '.so mke2fs.8' > $RPM_BUILD_ROOT%{_mandir}/it/man8/mkfs.ext4.8
+echo '.so mke2fs.8' > $RPM_BUILD_ROOT%{_mandir}/it/man8/mkfs.ext4dev.8
+echo '.so e2fsck.8' > $RPM_BUILD_ROOT%{_mandir}/ja/man8/fsck.ext4.8
+echo '.so e2fsck.8' > $RPM_BUILD_ROOT%{_mandir}/ja/man8/fsck.ext4dev.8
+echo '.so mke2fs.8' > $RPM_BUILD_ROOT%{_mandir}/ja/man8/mkfs.ext4.8
+echo '.so mke2fs.8' > $RPM_BUILD_ROOT%{_mandir}/ja/man8/mkfs.ext4dev.8
 echo '.so e2fsck.8' > $RPM_BUILD_ROOT%{_mandir}/ko/man8/fsck.ext3.8
+echo '.so e2fsck.8' > $RPM_BUILD_ROOT%{_mandir}/ko/man8/fsck.ext4.8
+echo '.so e2fsck.8' > $RPM_BUILD_ROOT%{_mandir}/ko/man8/fsck.ext4dev.8
 echo '.so mke2fs.8' > $RPM_BUILD_ROOT%{_mandir}/ko/man8/mkfs.ext3.8
+echo '.so mke2fs.8' > $RPM_BUILD_ROOT%{_mandir}/ko/man8/mkfs.ext4.8
+echo '.so mke2fs.8' > $RPM_BUILD_ROOT%{_mandir}/ko/man8/mkfs.ext4dev.8
+echo '.so e2fsck.8' > $RPM_BUILD_ROOT%{_mandir}/pl/man8/fsck.ext4.8
+echo '.so e2fsck.8' > $RPM_BUILD_ROOT%{_mandir}/pl/man8/fsck.ext4dev.8
 echo '.so mke2fs.8' > $RPM_BUILD_ROOT%{_mandir}/pl/man8/mkfs.ext3.8
+echo '.so mke2fs.8' > $RPM_BUILD_ROOT%{_mandir}/pl/man8/mkfs.ext4.8
+echo '.so mke2fs.8' > $RPM_BUILD_ROOT%{_mandir}/pl/man8/mkfs.ext4dev.8
+# moved to util-linux-ng.spec
+%{__rm} $RPM_BUILD_ROOT%{_mandir}/*/man1/uuidgen.1
+%{__rm} $RPM_BUILD_ROOT%{_mandir}/*/man3/libuuid.3
+%{__rm} $RPM_BUILD_ROOT%{_mandir}/*/man3/uuid_*.3
+%{__rm} $RPM_BUILD_ROOT%{_mandir}/*/man8/findfs.8
+%{__rm} $RPM_BUILD_ROOT%{_mandir}/*/man8/fsck.8
 
 %if %{with nls}
 [ "`file $RPM_BUILD_ROOT%{_datadir}/locale/it/LC_MESSAGES/e2fsprogs.mo |\
@@ -658,103 +751,95 @@ echo '.so mke2fs.8' > $RPM_BUILD_ROOT%{_mandir}/pl/man8/mkfs.ext3.8
 %endif
 
 rm -f $RPM_BUILD_ROOT%{_mandir}/README.e2fsprogs-non-english-man-pages
-touch $RPM_BUILD_ROOT%{_sysconfdir}/blkid.tab
 
-%{?with_initrd:install initrd-blkid $RPM_BUILD_ROOT/sbin/initrd-blkid}
+%if %{with initrd}
+install -d $RPM_BUILD_ROOT%{_libdir}/initrd
+install -p initrd-mke2fs $RPM_BUILD_ROOT%{_libdir}/initrd/mke2fs
+%endif
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
-%post
-/sbin/ldconfig
-[ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
+%post  -p /sbin/postshell
+-/usr/sbin/fix-info-dir -c %{_infodir}
+
+%postun        -p /sbin/postshell
+-/usr/sbin/fix-info-dir -c %{_infodir}
 
-%postun
-/sbin/ldconfig
-[ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
+%post  libs -p /sbin/ldconfig
+%postun        libs -p /sbin/ldconfig
 
-%post devel    -p      /sbin/postshell
+%post  devel -p /sbin/postshell
 -/usr/sbin/fix-info-dir -c %{_infodir}
 
-%postun devel  -p      /sbin/postshell
+%postun        devel -p /sbin/postshell
 -/usr/sbin/fix-info-dir -c %{_infodir}
 
 %post  -n libcom_err -p /sbin/ldconfig
 %postun        -n libcom_err -p /sbin/ldconfig
 
-%pre   -n libuuid
-%groupadd -g 222 libuuid
-%useradd -u 222 -r -d /var/lib/libuuid -s /bin/false -c "libuuid" -g libuuid libuuid
-
-%post  -n libuuid -p /sbin/ldconfig
-
-%postun        -n libuuid
-if [ "$1" = "0" ]; then
-       %userremove libuuid
-       %groupremove libuuid
-fi
-/sbin/ldconfig
-
-%post  -n fsck -p /sbin/ldconfig
-%postun        -n fsck -p /sbin/ldconfig
+%post  -n libss -p /sbin/ldconfig
+%postun        -n libss -p /sbin/ldconfig
 
 %files %{?with_nls:-f %{name}.lang}
 %defattr(644,root,root,755)
 # COPYING specifies license details for some parts of package
 %doc COPYING README RELEASE-NOTES
 %attr(755,root,root) /sbin/badblocks
-%attr(755,root,root) /sbin/blkid
 %attr(755,root,root) /sbin/debugfs
 %attr(755,root,root) /sbin/dumpe2fs
 %attr(755,root,root) /sbin/e2fsck
 %attr(755,root,root) /sbin/e2image
 %attr(755,root,root) /sbin/e2label
-%attr(755,root,root) /sbin/findfs
+%attr(755,root,root) /sbin/e2undo
 %attr(755,root,root) /sbin/fsck.ext2
 %attr(755,root,root) /sbin/fsck.ext3
+%attr(755,root,root) /sbin/fsck.ext4
+%attr(755,root,root) /sbin/fsck.ext4dev
 %attr(755,root,root) /sbin/logsave
 %attr(755,root,root) /sbin/mke2fs
 %attr(755,root,root) /sbin/mkfs.ext2
 %attr(755,root,root) /sbin/mkfs.ext3
+%attr(755,root,root) /sbin/mkfs.ext4
+%attr(755,root,root) /sbin/mkfs.ext4dev
 %attr(755,root,root) /sbin/resize2fs
 %attr(755,root,root) /sbin/tune2fs
 %attr(755,root,root) %{_bindir}/chattr
 %attr(755,root,root) %{_bindir}/lsattr
-%attr(755,root,root) %{_bindir}/mk_cmds
+%attr(755,root,root) %{_sbindir}/e2freefrag
+%attr(755,root,root) %{_sbindir}/e4defrag
 %attr(755,root,root) %{_sbindir}/filefrag
 %attr(755,root,root) %{_sbindir}/mklost+found
-%if %{without allstatic}
-%attr(755,root,root) /%{_lib}/libe2p.so.*.*
-%attr(755,root,root) %ghost /%{_lib}/libe2p.so.2
-%attr(755,root,root) /%{_lib}/libext2fs.so.*.*
-%attr(755,root,root) %ghost /%{_lib}/libext2fs.so.2
-%attr(755,root,root) /%{_lib}/libss.so.*.*
-%attr(755,root,root) %ghost /%{_lib}/libss.so.2
-%endif
 %attr(755,root,root) %{_libdir}/e2initrd_helper
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/e2fsck.conf
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mke2fs.conf
-%ghost %{_sysconfdir}/blkid.tab
 %{_mandir}/man1/chattr.1*
 %{_mandir}/man1/lsattr.1*
-%{_mandir}/man1/mk_cmds.1*
 %{_mandir}/man5/e2fsck.conf.5*
+%{_mandir}/man5/ext2.5*
+%{_mandir}/man5/ext3.5*
+%{_mandir}/man5/ext4.5*
 %{_mandir}/man5/mke2fs.conf.5*
 %{_mandir}/man8/badblocks.8*
-%{_mandir}/man8/blkid.8*
 %{_mandir}/man8/debugfs.8*
 %{_mandir}/man8/dumpe2fs.8*
+%{_mandir}/man8/e2freefrag.8*
 %{_mandir}/man8/e2fsck.8*
 %{_mandir}/man8/e2image.8*
 %{_mandir}/man8/e2label.8*
+%{_mandir}/man8/e2undo.8*
+%{_mandir}/man8/e4defrag.8*
 %{_mandir}/man8/filefrag.8*
-%{_mandir}/man8/findfs.8*
 %{_mandir}/man8/fsck.ext2.8*
 %{_mandir}/man8/fsck.ext3.8*
+%{_mandir}/man8/fsck.ext4.8*
+%{_mandir}/man8/fsck.ext4dev.8*
 %{_mandir}/man8/logsave.8*
 %{_mandir}/man8/mke2fs.8*
 %{_mandir}/man8/mkfs.ext2.8*
 %{_mandir}/man8/mkfs.ext3.8*
+%{_mandir}/man8/mkfs.ext4.8*
+%{_mandir}/man8/mkfs.ext4dev.8*
 %{_mandir}/man8/mklost+found.8*
 %{_mandir}/man8/resize2fs.8*
 %{_mandir}/man8/tune2fs.8*
@@ -771,6 +856,8 @@ fi
 %lang(hu) %{_mandir}/hu/man8/e2fsck.8*
 %lang(hu) %{_mandir}/hu/man8/fsck.ext2.8*
 %lang(hu) %{_mandir}/hu/man8/fsck.ext3.8*
+%lang(hu) %{_mandir}/hu/man8/fsck.ext4.8*
+%lang(hu) %{_mandir}/hu/man8/fsck.ext4dev.8*
 %lang(hu) %{_mandir}/hu/man8/tune2fs.8*
 %lang(it) %{_mandir}/it/man1/chattr.1*
 %lang(it) %{_mandir}/it/man1/lsattr.1*
@@ -780,9 +867,13 @@ fi
 %lang(it) %{_mandir}/it/man8/e2fsck.8*
 %lang(it) %{_mandir}/it/man8/fsck.ext2.8*
 %lang(it) %{_mandir}/it/man8/fsck.ext3.8*
+%lang(it) %{_mandir}/it/man8/fsck.ext4.8*
+%lang(it) %{_mandir}/it/man8/fsck.ext4dev.8*
 %lang(it) %{_mandir}/it/man8/mke2fs.8*
 %lang(it) %{_mandir}/it/man8/mkfs.ext2.8*
 %lang(it) %{_mandir}/it/man8/mkfs.ext3.8*
+%lang(it) %{_mandir}/it/man8/mkfs.ext4.8*
+%lang(it) %{_mandir}/it/man8/mkfs.ext4dev.8*
 %lang(it) %{_mandir}/it/man8/mklost+found.8*
 %lang(it) %{_mandir}/it/man8/tune2fs.8*
 %lang(ja) %{_mandir}/ja/man1/chattr.1*
@@ -793,12 +884,15 @@ fi
 %lang(ja) %{_mandir}/ja/man8/e2fsck.8*
 %lang(ja) %{_mandir}/ja/man8/e2image.8*
 %lang(ja) %{_mandir}/ja/man8/e2label.8*
-%lang(ja) %{_mandir}/ja/man8/findfs.8*
 %lang(ja) %{_mandir}/ja/man8/fsck.ext2.8*
 %lang(ja) %{_mandir}/ja/man8/fsck.ext3.8*
+%lang(ja) %{_mandir}/ja/man8/fsck.ext4.8*
+%lang(ja) %{_mandir}/ja/man8/fsck.ext4dev.8*
 %lang(ja) %{_mandir}/ja/man8/mke2fs.8*
 %lang(ja) %{_mandir}/ja/man8/mkfs.ext2.8*
 %lang(ja) %{_mandir}/ja/man8/mkfs.ext3.8*
+%lang(ja) %{_mandir}/ja/man8/mkfs.ext4.8*
+%lang(ja) %{_mandir}/ja/man8/mkfs.ext4dev.8*
 %lang(ja) %{_mandir}/ja/man8/mklost+found.8*
 %lang(ja) %{_mandir}/ja/man8/resize2fs.8*
 %lang(ja) %{_mandir}/ja/man8/tune2fs.8*
@@ -810,9 +904,13 @@ fi
 %lang(ko) %{_mandir}/ko/man8/e2fsck.8*
 %lang(ko) %{_mandir}/ko/man8/fsck.ext2.8*
 %lang(ko) %{_mandir}/ko/man8/fsck.ext3.8*
+%lang(ko) %{_mandir}/ko/man8/fsck.ext4.8*
+%lang(ko) %{_mandir}/ko/man8/fsck.ext4dev.8*
 %lang(ko) %{_mandir}/ko/man8/mke2fs.8*
 %lang(ko) %{_mandir}/ko/man8/mkfs.ext2.8*
 %lang(ko) %{_mandir}/ko/man8/mkfs.ext3.8*
+%lang(ko) %{_mandir}/ko/man8/mkfs.ext4.8*
+%lang(ko) %{_mandir}/ko/man8/mkfs.ext4dev.8*
 %lang(ko) %{_mandir}/ko/man8/mklost+found.8*
 %lang(ko) %{_mandir}/ko/man8/tune2fs.8*
 %lang(pl) %{_mandir}/pl/man1/chattr.1*
@@ -824,40 +922,42 @@ fi
 %lang(pl) %{_mandir}/pl/man8/e2label.8*
 %lang(pl) %{_mandir}/pl/man8/fsck.ext2.8*
 %lang(pl) %{_mandir}/pl/man8/fsck.ext3.8*
+%lang(pl) %{_mandir}/pl/man8/fsck.ext4.8*
+%lang(pl) %{_mandir}/pl/man8/fsck.ext4dev.8*
 %lang(pl) %{_mandir}/pl/man8/mke2fs.8*
 %lang(pl) %{_mandir}/pl/man8/mkfs.ext2.8*
 %lang(pl) %{_mandir}/pl/man8/mkfs.ext3.8*
+%lang(pl) %{_mandir}/pl/man8/mkfs.ext4.8*
+%lang(pl) %{_mandir}/pl/man8/mkfs.ext4dev.8*
 %lang(pl) %{_mandir}/pl/man8/mklost+found.8*
 %lang(pl) %{_mandir}/pl/man8/tune2fs.8*
-%{_datadir}/ss
 %{_infodir}/e2compr.info*
 
+%if %{without allstatic}
+%files libs
+%defattr(644,root,root,755)
+%attr(755,root,root) /%{_lib}/libe2p.so.*.*
+%attr(755,root,root) %ghost /%{_lib}/libe2p.so.2
+%attr(755,root,root) /%{_lib}/libext2fs.so.*.*
+%attr(755,root,root) %ghost /%{_lib}/libext2fs.so.2
+%endif
+
 %files devel
 %defattr(644,root,root,755)
-%doc doc/libblkid.txt
 %if %{without allstatic}
-%attr(755,root,root) %{_libdir}/libblkid.so
 %attr(755,root,root) %{_libdir}/libe2p.so
 %attr(755,root,root) %{_libdir}/libext2fs.so
-%attr(755,root,root) %{_libdir}/libss.so
 %endif
-%{_includedir}/blkid
 %{_includedir}/e2p
 %{_includedir}/ext2fs
-%{_includedir}/ss
-%{_pkgconfigdir}/blkid.pc
 %{_pkgconfigdir}/e2p.pc
 %{_pkgconfigdir}/ext2fs.pc
-%{_pkgconfigdir}/ss.pc
 %{_infodir}/libext2fs.info*
-%{_mandir}/man3/libblkid.3*
 
 %files static
 %defattr(644,root,root,755)
-%{_libdir}/libblkid.a
 %{_libdir}/libe2p.a
 %{_libdir}/libext2fs.a
-%{_libdir}/libss.a
 
 %files -n libcom_err
 %defattr(644,root,root,755)
@@ -870,6 +970,7 @@ fi
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/compile_et
 %{!?with_allstatic:%attr(755,root,root) %{_libdir}/libcom_err.so}
+%{_includedir}/com_err.h
 %{_includedir}/et
 %{_datadir}/et
 %{_pkgconfigdir}/com_err.pc
@@ -882,48 +983,39 @@ fi
 %defattr(644,root,root,755)
 %{_libdir}/libcom_err.a
 
-%files -n libuuid
-%defattr(644,root,root,755)
-%doc lib/uuid/COPYING
-%attr(755,root,root) %{_bindir}/uuidgen
-%attr(6755,libuuid,libuuid) %{_sbindir}/uuidd
 %if %{without allstatic}
-%attr(755,root,root) /%{_lib}/libuuid.so.*.*
-%attr(755,root,root) %ghost /%{_lib}/libuuid.so.1
+%files -n libss
+%defattr(644,root,root,755)
+%attr(755,root,root) /%{_lib}/libss.so.*.*
+%attr(755,root,root) %ghost /%{_lib}/libss.so.2
 %endif
-%attr(750,libuuid,libuuid) /var/lib/libuuid
-%{_mandir}/man1/uuidgen.1*
-%{_mandir}/man8/uuidd.8*
-%lang(ja) %{_mandir}/ja/man1/uuidgen.1*
 
-%files -n libuuid-devel
+%files -n libss-devel
 %defattr(644,root,root,755)
-%{!?with_allstatic:%attr(755,root,root) %{_libdir}/libuuid.so}
-%{_includedir}/uuid
-%{_pkgconfigdir}/uuid.pc
-%{_mandir}/man3/uuid*.3*
-%lang(ja) %{_mandir}/ja/man3/libuuid.3*
-%lang(ja) %{_mandir}/ja/man3/uuid_*.3*
-
-%files -n libuuid-static
+%attr(755,root,root) %{_bindir}/mk_cmds
+%if %{without allstatic}
+%attr(755,root,root) %{_libdir}/libss.so
+%endif
+%{_includedir}/ss
+%{_datadir}/ss
+%{_pkgconfigdir}/ss.pc
+%{_mandir}/man1/mk_cmds.1*
+
+%files -n libss-static
 %defattr(644,root,root,755)
-%{_libdir}/libuuid.a
+%{_libdir}/libss.a
 
-%files -n fsck
+%if 0
+# was installed in >= 1.42.2, since 1.42.12 is private only
+%files -n libquota-devel
 %defattr(644,root,root,755)
-%attr(755,root,root) /sbin/fsck
-%if %{without allstatic}
-%attr(755,root,root) /%{_lib}/libblkid.so.*.*
-%attr(755,root,root) %ghost /%{_lib}/libblkid.so.1
+%{_libdir}/libquota.a
+%{_includedir}/quota
+%{_pkgconfigdir}/quota.pc
 %endif
-%{_mandir}/man8/fsck.8*
-%lang(it) %{_mandir}/it/man8/fsck.8*
-%lang(ja) %{_mandir}/ja/man8/fsck.8*
-%lang(ko) %{_mandir}/ko/man8/fsck.8*
-%lang(pl) %{_mandir}/pl/man8/fsck.8*
 
 %if %{with initrd}
 %files initrd
 %defattr(644,root,root,755)
-%attr(755,root,root) /sbin/initrd-blkid
+%attr(755,root,root) %{_libdir}/initrd/mke2fs
 %endif
This page took 0.104401 seconds and 4 git commands to generate.