]> git.pld-linux.org Git - packages/e2fsprogs.git/blobdiff - e2fsprogs.spec
- updated to 1.42.13 (fixes CVE-2015-1572)
[packages/e2fsprogs.git] / e2fsprogs.spec
index 248e652b6567a566017be855d58ea871514c1b36..e55848406363bf372f28ec29e050fa2996abdc03 100644 (file)
@@ -1,7 +1,6 @@
 #
 # Conditional build:
 %bcond_with    allstatic       # link everything statically
-%bcond_without static          # link e2fsck dynamically with libc
 %bcond_without nls             # build without NLS
 %bcond_without tls             # TLS
 %if "%{pld_release}" == "ac"
@@ -9,7 +8,7 @@
 %bcond_without uClibc          # link initrd version with static glibc instead of uClibc
 %bcond_with    dietlibc        # link initrd version with dietlibc instead of uClibc
 %else
-%bcond_without initrd          # don't build initrd version
+%bcond_with    initrd          # don't build initrd version
 %bcond_with    uClibc          # link initrd version with static glibc instead of uClibc
 %bcond_without dietlibc        # link initrd version with dietlibc instead of uClibc
 %endif
@@ -47,12 +46,12 @@ Summary(uk.UTF-8):  Утиліти для роботи з файловою сис
 Summary(zh_CN.UTF-8):  管理第二扩展(ext2)文件系统的工具。
 Summary(zh_TW.UTF-8):  用於管理 ext2 檔案系統的工具程式。
 Name:          e2fsprogs
-Version:       1.41.14
+Version:       1.42.13
 Release:       1
 License:       GPL v2 (with LGPL v2 and BSD parts)
 Group:         Applications/System
 Source0:       http://downloads.sourceforge.net/e2fsprogs/%{name}-%{version}.tar.gz
-# Source0-md5: 05f70470aea2ef7efbb0845b2b116720
+# Source0-md5: bc759fc62666786f5436e2075beb3265
 Source1:       e2compr-0.4.texinfo.gz
 # Source1-md5: c3c59ff37e49d8759abb1ef95a8d3abf
 Source2:       http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
@@ -62,13 +61,14 @@ Patch1:             e2compr-info.patch
 Patch2:                %{name}-498381.patch
 Patch3:                %{name}-diet.patch
 URL:           http://e2fsprogs.sourceforge.net/
-BuildRequires: autoconf >= 2.50
+BuildRequires: autoconf >= 2.54
 BuildRequires: automake
-BuildRequires: gettext-devel >= 0.11
+BuildRequires: gettext-tools >= 0.11
 BuildRequires: libblkid-devel
 BuildRequires: libuuid-devel
 BuildRequires: pkgconfig
-BuildRequires: rpmbuild(macros) >= 1.426
+BuildRequires: rpm >= 4.4.9-56
+BuildRequires: rpmbuild(macros) >= 1.583
 BuildRequires: texinfo
 BuildRequires: texinfo-texi2dvi
 %if %{with allstatic}
@@ -101,6 +101,16 @@ BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 # changing CFLAGS in the middle confuses confcache
 %undefine       configure_cache
 
+# objdump -T /lib/libcom_err.so.2.1 | grep ___tls_get_addr
+# on ac it is:
+# 00000000      D  *UND*  00000000              ___tls_get_addr
+# on th it is:
+# 00000000      DF *UND*  00000000  GLIBC_2.3   ___tls_get_addr
+# yet on ac rpm-build-macros think it's unresolved symbol, but program still seem to work
+%if "%{pld_release}" == "ac"
+%define                skip_post_check_so      libcom_err.so.2.1
+%endif
+
 # for some reason known only to rpm there must be "\\|" not "\|" here
 %define                dietarch        %(echo %{_target_cpu} | sed -e 's/i.86\\|pentium.\\|athlon/i386/;s/amd64/x86_64/;s/armv.*/arm/')
 %define                dietlibdir      %{_prefix}/lib/dietlibc/lib-%{dietarch}
@@ -365,6 +375,8 @@ Requires:   %{name}-libs = %{version}-%{release}
 Requires:      libcom_err-devel = %{version}-%{release}
 Requires:      libuuid-devel
 Obsoletes:     libext2fs2-devel
+# until it comes back
+Obsoletes:     libquota-devel
 
 %description devel
 e2fsprogs-devel contains the libraries and header files needed to
@@ -580,6 +592,17 @@ Static version of subsystem command parsing library.
 %description -n libss-static -l pl.UTF-8
 Statyczna wersja biblioteki analizy poleceń podsystemów.
 
+%package -n libquota-devel
+Summary:       Quota management library
+Summary(pl.UTF-8):     Biblioteka do zarządzania limitami dyskowymi (quotami)
+Group:         Development/Libraries
+
+%description -n libquota-devel
+Quota management library.
+
+%description -n libquota-devel -l pl.UTF-8
+Biblioteka do zarządzania limitami dyskowymi (quotami).
+
 %package initrd
 Summary:       e2fsck and mke2fs - initrd version
 Summary(pl.UTF-8):     e2fsck i mke2fs - wersja dla initrd
@@ -602,36 +625,18 @@ na potrzeby initrd.
 %patch2 -p1
 %patch3 -p1
 
-sed -i -e '/AC_SUBST(DO_TEST_SUITE/a\MKINSTALLDIRS="install -d"\nAC_SUBST(MKINSTALLDIRS)\n' configure.in
-
-# AX_TLS
-tail -n +2604 aclocal.m4 > acinclude.m4
-
 %build
 cp -f /usr/share/automake/config.sub .
-%{__gettextize}
 %{__aclocal}
 %{__autoconf}
 
 %if %{with initrd}
-%if %{with dietlibc}
-# needed for syscall()
-cp -a MCONFIG.in MCONFIG.in.org
-sed -i -e 's|\(^LIBUUID = .*\)|\1 -lcompat|g' \
-       -e 's|\(^STATIC_LIBUUID = .*\)|\1 -lcompat|g' MCONFIG.in
-%endif
 %configure \
        ac_cv_lib_dl_dlopen=no \
        %{?with_uClibc:CC="%{_target_cpu}-uclibc-gcc"} \
        %{?with_dietlibc:CC="diet %{__cc}"} \
        CFLAGS="%{rpmcflags} -Os" \
        LDFLAGS="%{rpmldflags} -static" \
-%if %{with dietlibc}
-       LIBUUID_LIBADD="-lcompat" \
-       LIBBLKID_LIBADD="-luuid -lcompat" \
-%else
-       LIBBLKID_LIBADD="-luuid" \
-%endif
        --disable-elf-shlibs \
        --disable-fsck \
        --disable-libblkid \
@@ -649,7 +654,6 @@ sed -i -e 's|\(^LIBUUID = .*\)|\1 -lcompat|g' \
        V=1
 mv -f misc/mke2fs initrd-mke2fs
 %{__make} clean
-%{?with_dietlibc:mv MCONFIG.in.org MCONFIG.in}
 %endif
 
 %configure \
@@ -663,7 +667,8 @@ mv -f misc/mke2fs initrd-mke2fs
        --disable-uuidd \
        --enable-compression \
        %{!?with_allstatic:--enable-elf-shlibs} \
-       --enable-htree
+       --enable-htree \
+       --enable-quota
 
 %{__make} -j1 libs \
        LDFLAGS="%{rpmldflags}" \
@@ -682,16 +687,17 @@ export PATH=/sbin:$PATH
 
 echo "install-shlibs:" >> intl/Makefile
 
-%{__make} install install-libs \
+%{__make} -j1 install install-libs \
        root_libdir=/%{_lib} \
        mkinstalldirs='install -d' \
+       LDCONFIG=true \
        DESTDIR=$RPM_BUILD_ROOT
 
 ln -sf e2fsck $RPM_BUILD_ROOT/sbin/fsck.ext2
 ln -sf e2fsck $RPM_BUILD_ROOT/sbin/fsck.ext3
 ln -sf mke2fs $RPM_BUILD_ROOT/sbin/mkfs.ext2
 
-install doc/e2compr.info $RPM_BUILD_ROOT%{_infodir}
+cp -p doc/e2compr.info $RPM_BUILD_ROOT%{_infodir}
 
 touch $RPM_BUILD_ROOT%{_sysconfdir}/e2fsck.conf
 
@@ -748,7 +754,7 @@ rm -f $RPM_BUILD_ROOT%{_mandir}/README.e2fsprogs-non-english-man-pages
 
 %if %{with initrd}
 install -d $RPM_BUILD_ROOT%{_libdir}/initrd
-install initrd-mke2fs $RPM_BUILD_ROOT%{_libdir}/initrd/mke2fs
+install -p initrd-mke2fs $RPM_BUILD_ROOT%{_libdir}/initrd/mke2fs
 %endif
 
 %clean
@@ -801,6 +807,7 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_bindir}/chattr
 %attr(755,root,root) %{_bindir}/lsattr
 %attr(755,root,root) %{_sbindir}/e2freefrag
+%attr(755,root,root) %{_sbindir}/e4defrag
 %attr(755,root,root) %{_sbindir}/filefrag
 %attr(755,root,root) %{_sbindir}/mklost+found
 %attr(755,root,root) %{_libdir}/e2initrd_helper
@@ -809,6 +816,9 @@ rm -rf $RPM_BUILD_ROOT
 %{_mandir}/man1/chattr.1*
 %{_mandir}/man1/lsattr.1*
 %{_mandir}/man5/e2fsck.conf.5*
+%{_mandir}/man5/ext2.5*
+%{_mandir}/man5/ext3.5*
+%{_mandir}/man5/ext4.5*
 %{_mandir}/man5/mke2fs.conf.5*
 %{_mandir}/man8/badblocks.8*
 %{_mandir}/man8/debugfs.8*
@@ -818,6 +828,7 @@ rm -rf $RPM_BUILD_ROOT
 %{_mandir}/man8/e2image.8*
 %{_mandir}/man8/e2label.8*
 %{_mandir}/man8/e2undo.8*
+%{_mandir}/man8/e4defrag.8*
 %{_mandir}/man8/filefrag.8*
 %{_mandir}/man8/fsck.ext2.8*
 %{_mandir}/man8/fsck.ext3.8*
@@ -936,7 +947,6 @@ rm -rf $RPM_BUILD_ROOT
 %if %{without allstatic}
 %attr(755,root,root) %{_libdir}/libe2p.so
 %attr(755,root,root) %{_libdir}/libext2fs.so
-%attr(755,root,root) %{_libdir}/libss.so
 %endif
 %{_includedir}/e2p
 %{_includedir}/ext2fs
@@ -960,6 +970,7 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/compile_et
 %{!?with_allstatic:%attr(755,root,root) %{_libdir}/libcom_err.so}
+%{_includedir}/com_err.h
 %{_includedir}/et
 %{_datadir}/et
 %{_pkgconfigdir}/com_err.pc
@@ -994,6 +1005,15 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %{_libdir}/libss.a
 
+%if 0
+# was installed in >= 1.42.2, since 1.42.12 is private only
+%files -n libquota-devel
+%defattr(644,root,root,755)
+%{_libdir}/libquota.a
+%{_includedir}/quota
+%{_pkgconfigdir}/quota.pc
+%endif
+
 %if %{with initrd}
 %files initrd
 %defattr(644,root,root,755)
This page took 0.095005 seconds and 4 git commands to generate.