]> git.pld-linux.org Git - packages/e2fsprogs.git/blobdiff - e2fsprogs.spec
- proper e4defrag path
[packages/e2fsprogs.git] / e2fsprogs.spec
index 4938a87e2c43be91aa1ebbea057ad720342ff296..3a53e0c29394f018c6313b92e1537d57616be94f 100644 (file)
@@ -3,14 +3,26 @@
 %bcond_with    allstatic       # link everything statically
 %bcond_without static          # link e2fsck dynamically with libc
 %bcond_without nls             # build without NLS
+%bcond_without tls             # TLS
+%if "%{pld_release}" == "ac"
+%bcond_with    initrd          # don't build initrd version
+%bcond_without uClibc          # link initrd version with static glibc instead of uClibc
+%bcond_with    dietlibc        # link initrd version with dietlibc instead of uClibc
+%else
 %bcond_without initrd          # don't build initrd version
 %bcond_with    uClibc          # link initrd version with static glibc instead of uClibc
 %bcond_without dietlibc        # link initrd version with dietlibc instead of uClibc
-#
-%ifarch sparc64 sparc
+%endif
+
+%ifarch sparc64 sparc alpha ppc ppc64
 %undefine       with_uClibc
 %endif
-#
+
+# see glibc.spec
+%ifarch        i386
+%undefine      with_tls
+%endif
+
 Summary:       Utilities for managing the second extended (ext2) filesystem
 Summary(cs.UTF-8):     Nástroje pro správu souborových systémů typu ext2
 Summary(da.UTF-8):     Værktøjer til håndtering af ext2 filsystemer
@@ -35,12 +47,12 @@ Summary(uk.UTF-8):  Утиліти для роботи з файловою сис
 Summary(zh_CN.UTF-8):  管理第二扩展(ext2)文件系统的工具。
 Summary(zh_TW.UTF-8):  用於管理 ext2 檔案系統的工具程式。
 Name:          e2fsprogs
-Version:       1.41.14
-Release:       1
+Version:       1.42.2
+Release:       0.1
 License:       GPL v2 (with LGPL v2 and BSD parts)
 Group:         Applications/System
 Source0:       http://downloads.sourceforge.net/e2fsprogs/%{name}-%{version}.tar.gz
-# Source0-md5: 05f70470aea2ef7efbb0845b2b116720
+# Source0-md5: 04f4561a54ad0419248316a00c016baa
 Source1:       e2compr-0.4.texinfo.gz
 # Source1-md5: c3c59ff37e49d8759abb1ef95a8d3abf
 Source2:       http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
@@ -56,7 +68,8 @@ BuildRequires:        gettext-devel >= 0.11
 BuildRequires: libblkid-devel
 BuildRequires: libuuid-devel
 BuildRequires: pkgconfig
-BuildRequires: rpmbuild(macros) >= 1.426
+BuildRequires: rpm >= 4.4.9-56
+BuildRequires: rpmbuild(macros) >= 1.583
 BuildRequires: texinfo
 BuildRequires: texinfo-texi2dvi
 %if %{with allstatic}
@@ -89,6 +102,16 @@ BuildRoot:  %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 # changing CFLAGS in the middle confuses confcache
 %undefine       configure_cache
 
+# objdump -T /lib/libcom_err.so.2.1 | grep ___tls_get_addr
+# on ac it is:
+# 00000000      D  *UND*  00000000              ___tls_get_addr
+# on th it is:
+# 00000000      DF *UND*  00000000  GLIBC_2.3   ___tls_get_addr
+# yet on ac rpm-build-macros think it's unresolved symbol, but program still seem to work
+%if "%{pld_release}" == "ac"
+%define                skip_post_check_so      libcom_err.so.2.1
+%endif
+
 # for some reason known only to rpm there must be "\\|" not "\|" here
 %define                dietarch        %(echo %{_target_cpu} | sed -e 's/i.86\\|pentium.\\|athlon/i386/;s/amd64/x86_64/;s/armv.*/arm/')
 %define                dietlibdir      %{_prefix}/lib/dietlibc/lib-%{dietarch}
@@ -568,6 +591,17 @@ Static version of subsystem command parsing library.
 %description -n libss-static -l pl.UTF-8
 Statyczna wersja biblioteki analizy poleceń podsystemów.
 
+%package -n libquota-devel
+Summary:       Quota management library
+Summary(pl.UTF-8):     Biblioteka do zarządzania limitami dyskowymi (quotami)
+Group:         Development/Libraries
+
+%description -n libquota-devel
+Quota management library.
+
+%description -n libquota-devel -l pl.UTF-8
+Biblioteka do zarządzania limitami dyskowymi (quotami).
+
 %package initrd
 Summary:       e2fsck and mke2fs - initrd version
 Summary(pl.UTF-8):     e2fsck i mke2fs - wersja dla initrd
@@ -646,6 +680,7 @@ mv -f misc/mke2fs initrd-mke2fs
        --disable-libblkid \
        --disable-libuuid \
        %{!?with_nls:--disable-nls} \
+       %{!?with_tls:--disable-tls} \
        --disable-rpath \
        --disable-uuidd \
        --enable-compression \
@@ -678,7 +713,7 @@ ln -sf e2fsck $RPM_BUILD_ROOT/sbin/fsck.ext2
 ln -sf e2fsck $RPM_BUILD_ROOT/sbin/fsck.ext3
 ln -sf mke2fs $RPM_BUILD_ROOT/sbin/mkfs.ext2
 
-install doc/e2compr.info $RPM_BUILD_ROOT%{_infodir}
+cp -p doc/e2compr.info $RPM_BUILD_ROOT%{_infodir}
 
 touch $RPM_BUILD_ROOT%{_sysconfdir}/e2fsck.conf
 
@@ -735,7 +770,7 @@ rm -f $RPM_BUILD_ROOT%{_mandir}/README.e2fsprogs-non-english-man-pages
 
 %if %{with initrd}
 install -d $RPM_BUILD_ROOT%{_libdir}/initrd
-install initrd-mke2fs $RPM_BUILD_ROOT%{_libdir}/initrd/mke2fs
+install -p initrd-mke2fs $RPM_BUILD_ROOT%{_libdir}/initrd/mke2fs
 %endif
 
 %clean
@@ -788,6 +823,7 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_bindir}/chattr
 %attr(755,root,root) %{_bindir}/lsattr
 %attr(755,root,root) %{_sbindir}/e2freefrag
+%attr(755,root,root) %{_sbindir}/e4defrag
 %attr(755,root,root) %{_sbindir}/filefrag
 %attr(755,root,root) %{_sbindir}/mklost+found
 %attr(755,root,root) %{_libdir}/e2initrd_helper
@@ -805,6 +841,7 @@ rm -rf $RPM_BUILD_ROOT
 %{_mandir}/man8/e2image.8*
 %{_mandir}/man8/e2label.8*
 %{_mandir}/man8/e2undo.8*
+%{_mandir}/man8/e4defrag.8*
 %{_mandir}/man8/filefrag.8*
 %{_mandir}/man8/fsck.ext2.8*
 %{_mandir}/man8/fsck.ext3.8*
@@ -947,6 +984,7 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/compile_et
 %{!?with_allstatic:%attr(755,root,root) %{_libdir}/libcom_err.so}
+%{_includedir}/com_err.h
 %{_includedir}/et
 %{_datadir}/et
 %{_pkgconfigdir}/com_err.pc
@@ -981,6 +1019,12 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %{_libdir}/libss.a
 
+%files -n libquota-devel
+%defattr(644,root,root,755)
+%{_libdir}/libquota.a
+%{_includedir}/quota
+%{_pkgconfigdir}/quota.pc
+
 %if %{with initrd}
 %files initrd
 %defattr(644,root,root,755)
This page took 0.03737 seconds and 4 git commands to generate.