]> git.pld-linux.org Git - packages/e16.git/blobdiff - enlightenment-config-path.patch
- removed all Group fields translations (oure rpm now can handle translating
[packages/e16.git] / enlightenment-config-path.patch
index 588f2b094c75412cf7f73f10a6f534834328b79f..bedbabb4ef0b9b7a5cf5fe7f832ad6ee532944f5 100644 (file)
@@ -1,80 +1,57 @@
-diff -ur enlightenment-0.16.devel.2.orig/src/Makefile.in enlightenment-0.16.devel.2/src/Makefile.in
---- enlightenment-0.16.devel.2.orig/src/Makefile.in    Mon May 24 20:45:06 1999
-+++ enlightenment-0.16.devel.2/src/Makefile.in Sun Jun 20 04:10:42 1999
-@@ -102,7 +102,7 @@
+diff -Nru enlightenment-0.16.5/src/config.c enlightenment-0.16.5.new/src/config.c
+--- enlightenment-0.16.5/src/config.c  Sun Oct  1 06:58:42 2000
++++ enlightenment-0.16.5.new/src/config.c      Sun Oct  1 07:03:53 2000
+@@ -3268,7 +3268,7 @@
+         }
+       Esnprintf(execline, sizeof(execline), "%s " "-P " "-nostdinc " "-undef "
+ #ifndef __EMX__
+-                "-include %s/config/definitions " "-I%s " "-I%s/config "
++                "-include %s/definitions " "-I%s " "-I%s "
+                 "-D ENLIGHTENMENT_VERSION=%s " "-D ENLIGHTENMENT_ROOT=%s "
+                 "-D ENLIGHTENMENT_BIN=%s "
+ #else
+@@ -3283,7 +3283,7 @@
+                 "-D USER_SHELL=%s " "-D ENLIGHTENMENT_VERSION_015=1 "
+                 "%s %s/cached/cfg/%s.preparsed",
+ #ifndef __EMX__
+-                epp_path, ENLIGHTENMENT_ROOT, themepath, ENLIGHTENMENT_ROOT,
++                epp_path, CONFIGDATADIR, themepath, CONFIGDATADIR,
+                 ENLIGHTENMENT_VERSION, ENLIGHTENMENT_ROOT, ENLIGHTENMENT_BIN,
+ #else
+                 epp_path, x11root, ENLIGHTENMENT_ROOT, themepath, x11root,
+@@ -3600,7 +3600,7 @@
  
- INCLUDES = -I$(top_srcdir) $(ESD_CFLAGS) $(IMLIB_CFLAGS) -I$(includedir) -I..
--DEFS = -DENLIGHTENMENT_ROOT=\"@ENLIGHTENMENT_ROOT@\" -DENLIGHTENMENT_BIN=\"@ENLIGHTENMENT_BIN@\"
-+DEFS = -DENLIGHTENMENT_ROOT=\"@ENLIGHTENMENT_ROOT@\" -DENLIGHTENMENT_BIN=\"@ENLIGHTENMENT_BIN@\" -DCONFIGDATADIR=\"$(configdatadir)\"
- mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
- CONFIG_HEADER = ../econfig.h
- CONFIG_CLEAN_FILES = 
-diff -ur enlightenment-0.16.devel.2.orig/src/config.c enlightenment-0.16.devel.2/src/config.c
---- enlightenment-0.16.devel.2.orig/src/config.c       Mon May 24 20:33:15 1999
-+++ enlightenment-0.16.devel.2/src/config.c    Sun Jun 20 04:09:44 1999
-@@ -2675,8 +2675,8 @@
-               "-P "
-               "-nostdinc "
-               "-undef "
--              "-include %s/config/definitions "
--              "-I%s/config "
-+              "-include %s/definitions "
-+              "-I%s "
-               "-D ENLIGHTENMENT_VERSION=%s "
-               "-D ENLIGHTENMENT_ROOT=%s "
-               "-D ENLIGHTENMENT_BIN=%s "
-@@ -2690,7 +2690,7 @@
-               "-D USER_SHELL=%s "
-               "-D ENLIGHTENMENT_VERSION_015=1 "
-               "%s %s/.enlightenment/cached/cfg/%s.preparsed",
--              epp_path, ENLIGHTENMENT_ROOT, ENLIGHTENMENT_ROOT,
-+              epp_path, CONFIGDATADIR, CONFIGDATADIR,
-               ENLIGHTENMENT_VERSION, ENLIGHTENMENT_ROOT, ENLIGHTENMENT_BIN,
-               themepath,
-               root.w, root.h, root.w, root.h, root.depth,
-@@ -2969,7 +2969,7 @@
-   if (isfile(s))
-     EDBUG_RETURN(duplicate(s));
-   /* look in system config dir */
--  Esnprintf(s, sizeof(s), "%s/config/%s", ENLIGHTENMENT_ROOT, file);
-+  Esnprintf(s, sizeof(s), "%s/%s", CONFIGDATADIR, file);
-   if (isfile(s))
-     EDBUG_RETURN(duplicate(s));
-   /* not found.... NULL */
-@@ -2996,7 +2996,7 @@
-   if (isfile(s))
-     EDBUG_RETURN(duplicate(s));
-   /* look in system config dir */
--  Esnprintf(s, sizeof(s), "%s/config/%s", ENLIGHTENMENT_ROOT, file);
-+  Esnprintf(s, sizeof(s), "%s/%s", CONFIGDATADIR, file);
-   if (isfile(s))
-     EDBUG_RETURN(duplicate(s));
-   /* not found.... NULL */
-@@ -3017,7 +3017,7 @@
-   home = homedir(getuid());
-   Esnprintf(s, sizeof(s), "%s/.enlightenment/", home);
-   Fnlib_add_dir(fd, s);
--  Esnprintf(s, sizeof(s), "%s/config/", ENLIGHTENMENT_ROOT);
-+  Esnprintf(s, sizeof(s), "%s/", CONFIGDATADIR);
-   Fnlib_add_dir(fd, s);
-   /* save the current theme */
-   if ((themelocation) && (themelocation[0] != 0))
-@@ -3048,7 +3048,7 @@
-       Alert("Enlightenment has just experienced some major problems in\n"
-           "attempting to load the theme you specified or the default\n"
-           "configuration directory:\n"
--          "%s/config/\n"
-+          "%s/\n"
-           "This will prevent Enlightenment from loading any configuration\n"
-           "files at all.\n"
-           "Since this couldn't be found Enlightenment is probably not\n"
-@@ -3067,7 +3067,7 @@
-           "Please contact your system administrator or package maintainer.\n"
-           "If you are the administrator of your own system please\n"
-           "consult the documentation that came with Enlightenment for\n"
--          "addional information.\n", ENLIGHTENMENT_ROOT);
-+          "addional information.\n", CONFIGDATADIR);
-       if (home)
-       Efree(home);
-       EDBUG_RETURN(0);
+    /* look in system config dir */
+ #ifndef __EMX__
+-   Esnprintf(s, sizeof(s), "%s/config/%s", ENLIGHTENMENT_ROOT, file);
++   Esnprintf(s, sizeof(s), "%s/%s", CONFIGDATADIR, file);
+ #else
+    Esnprintf(s, sizeof(s), "%s/config/%s", __XOS2RedirRoot(ENLIGHTENMENT_ROOT),
+            file);
+@@ -3670,7 +3670,7 @@
+    Esnprintf(s, sizeof(s), "%s/", UserEDir());
+    Fnlib_add_dir(fd, s);
+ #ifndef __EMX__
+-   Esnprintf(s, sizeof(s), "%s/config/", ENLIGHTENMENT_ROOT);
++   Esnprintf(s, sizeof(s), "%s/", CONFIGDATADIR);
+ #else
+    Esnprintf(s, sizeof(s), "%s/config/", __XOS2RedirRoot(ENLIGHTENMENT_ROOT));
+ #endif
+@@ -3701,7 +3701,7 @@
+       Alert(_
+             ("Enlightenment has just experienced some major problems in\n"
+              "attempting to load the theme you specified or the default\n"
+-             "configuration directory:\n" "%s/config/\n"
++             "configuration directory:\n" "%s/\n"
+              "This will prevent Enlightenment from loading any "
+              "configuration\n" "files at all.\n"
+              "Since this couldn't be found Enlightenment is probably not\n"
+@@ -3721,7 +3721,7 @@
+              "maintainer.\n"
+              "If you are the administrator of your own system please\n"
+              "consult the documentation that came with Enlightenment for\n"
+-             "additional information.\n"), ENLIGHTENMENT_ROOT);
++             "additional information.\n"), CONFIGDATADIR);
+       EDBUG_RETURN(0);
+      }
+    strcpy(themepath, theme);
This page took 0.066624 seconds and 4 git commands to generate.