]> git.pld-linux.org Git - packages/dxr2-driver.git/commitdiff
- new auto/th/dxr2-driver-1.0.4-1
authorJakub Bogusz <qboosh@pld-linux.org>
Sun, 24 Feb 2013 14:29:26 +0000 (15:29 +0100)
committerJakub Bogusz <qboosh@pld-linux.org>
Sun, 24 Feb 2013 14:29:26 +0000 (15:29 +0100)
- added subtitles patch from dxr2-install-0.5 package

dxr2-driver-subtitles.patch [new file with mode: 0644]
dxr2-driver.spec [new file with mode: 0644]

diff --git a/dxr2-driver-subtitles.patch b/dxr2-driver-subtitles.patch
new file mode 100644 (file)
index 0000000..0b6e22b
--- /dev/null
@@ -0,0 +1,62 @@
+--- dxr2-driver/ChangeLog      2002-03-16 01:19:59.000000000 +0100
++++ dxr2driver/ChangeLog       2002-03-25 02:57:22.000000000 +0100
+@@ -1,3 +1,13 @@
++2002-03-24 Scott Bucholtz <linuxman@linuxmanland.com>
++      * Applied Tobias Diedrich's <ranma@gmx.at> latest subtitles patch which
++        takes care of some weird color palettes which were showing up in the
++        subtitles.
++
++
++2002-03-19 Scott Bucholtz <linuxman@linuxmanland.com>
++      * Released dxr2-driver-1.0.4.
++
++
+ 2002-03-15 Scott Bucholtz <linuxman@linuxmanland.com>
+       * Added Tobias Diedrich's <ranma@gmx.at> new subtitles patch
+         which is much easier than the old ones because of the utilization
+--- dxr2-driver/player/dvd_controls.c  2002-03-16 01:18:36.000000000 +0100
++++ dxr2driver/player/dvd_controls.c   2002-03-25 02:54:36.000000000 +0100
+@@ -33,6 +33,7 @@
+ #include "dvd_controls.h"
+ #include "multifile.h"
+ #include <stdio.h>
++#include <dxr2ioctl.h>
+ #define min(x,y) (x < y ? x : y)
+@@ -264,6 +265,8 @@
+ int dvd_setup(dvd_controls *con, char *file_name)
+ {
++  dxr2_palette_t      pal;
++  int i;
+   if (!con->dvd && !(con->dvd=DVDOpen(file_name)))
+     return 0;
+   
+@@ -317,9 +320,12 @@
+   con->cur_pgc = con->vts_file->vts_pgcit->pgci_srp[con->pgc_id - 1].pgc;
+   con->next_cell = con->cur_pgc->program_map[con->pgn - 1] - 1;
+-  /*  This next line is for the subtitles  */
+-  dxr2_set_subpicture_palettes(con->vmg_file->first_play_pgc->palette);
+-  
++  /*  This is for the subtitles  */
++  for (i=0; i<16; i++) {
++      pal.entries[i]=con->vts_file->vts_pgcit->pgci_srp->pgc->palette[i];
++  }
++  dxr2_set_subpicture_palette(pal);
++
+   /*
+    * We've got enough info, time to open the title set data.
+    */
+--- dxr2-driver/player/dxr2-api.c      2002-03-16 01:20:27.000000000 +0100
++++ dxr2driver/player/dxr2-api.c       2002-03-25 02:59:44.000000000 +0100
+@@ -205,7 +205,7 @@
+ }
+ /*  This should do the subtitles correctly  */
+-int dxr2_set_subpicture_palettes(dxr2_palette_t pal)
++int dxr2_set_subpicture_palette(dxr2_palette_t pal)
+ {
+   return dxr2FD<0 ? -1 : ioctl(dxr2FD, DXR2_IOC_SET_SUBPICTURE_PALETTE, &pal);
+ }
diff --git a/dxr2-driver.spec b/dxr2-driver.spec
new file mode 100644 (file)
index 0000000..80c2419
--- /dev/null
@@ -0,0 +1,93 @@
+# TODO: Linux 2.6 port of drivers (some work started somewhere by vapier?)
+Summary:       Linux drivers for Creative Labs DXR2 devices
+Summary(pl.UTF-8):     Sterowniki linuksowe do urządzeń Creative Labs DXR2
+Name:          dxr2-driver
+Version:       1.0.4
+Release:       1
+License:       GPL v2+
+Group:         Libraries
+Source0:       http://downloads.sourceforge.net/dxr2/%{name}-%{version}.tar.gz
+# Source0-md5: d31c9513bf1e6901ab459f08c2c14424
+# from dxr2install-0.5
+Patch0:                %{name}-subtitles.patch
+URL:           http://dxr2.sourceforge.net/
+BuildRequires: libdvdread-devel
+BuildRequires: ncurses-devel
+BuildRequires: xorg-lib-libX11-devel
+BuildRequires: xorg-lib-libXext-devel
+BuildRequires: xorg-lib-libXmu-devel
+BuildRequires: xorg-lib-libXxf86vm-devel
+BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
+
+# needs on external print_info() function
+%define                skip_post_check_so      libdxr2css.so.*
+
+%description
+Linux drivers for Creative Labs DXR2 devices.
+
+%description -l pl.UTF-8
+Sterowniki linuksowe do urządzeń Creative Labs DXR2.
+
+%package devel
+Summary:       Header files for Creative Labs DXR2 devices
+Summary(pl.UTF-8):     Pliki nagłówkowe dla urządzeń Creative Labs DXR2
+Group:         Development/Libraries
+
+%description devel
+Header files for Creative Labs DXR2 devices.
+
+%description devel -l pl.UTF-8
+Pliki nagłówkowe dla urządzeń Creative Labs DXR2.
+
+%package -n dxr2-player
+Summary:       DXR2-powered DVD player
+Summary(pl.UTF-8):     Odtwarzacz DVD dla kart DXR2
+Group:         Applications/Multimedia
+
+%description -n dxr2-player
+DXR2-powered DVD player.
+
+%description -n dxr2-player -l pl.UTF-8
+Odtwarzacz DVD dla kart DXR2.
+
+%prep
+%setup -q -n %{name}
+%patch0 -p1
+
+%build
+%{__make} \
+       DIRS="player" \
+       CC="%{__cc}" \
+       CFLAGS="%{rpmcflags} -D__DVD_DEBUG -D_LARGEFILE64_SOURCE -D_REENTRANT -I../sysinclude -DNEED_SYS_TYPES_H -I/usr/include/ncurses" \
+       X_LIBS="-lXmu -lXt -lX11 -lXext -lXxf86vm"
+
+%install
+rm -rf $RPM_BUILD_ROOT
+install -d $RPM_BUILD_ROOT{%{_includedir}/dxr2,%{_bindir},%{_libdir}}
+
+cp -p sysinclude/*.h $RPM_BUILD_ROOT%{_includedir}/dxr2
+cp -dp player/libdxr2css.so.* $RPM_BUILD_ROOT%{_libdir}
+install player/{dvdplay*,driveauth,dvd-sum,*dvd} $RPM_BUILD_ROOT%{_bindir}
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%post  -n dxr2-player -p /sbin/ldconfig
+%postun        -n dxr2-player -p /sbin/ldconfig
+
+%files devel
+%defattr(644,root,root,755)
+%doc CONTRIBUTORS ChangeLog ReadMe TODO api.html
+%attr(755,root,root) %{_includedir}/dxr2
+
+%files -n dxr2-player
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_bindir}/driveauth
+%attr(755,root,root) %{_bindir}/dvd
+%attr(755,root,root) %{_bindir}/dvd-sum
+%attr(755,root,root) %{_bindir}/dvdplay
+%attr(755,root,root) %{_bindir}/dvdplay-curses
+%attr(755,root,root) %{_bindir}/dvdplay-wrapper
+%attr(755,root,root) %{_bindir}/undvd
+%attr(755,root,root) %{_libdir}/libdxr2css.so.*.*.*
+%attr(755,root,root) %ghost %{_libdir}/libdxr2css.so.0
This page took 0.088283 seconds and 4 git commands to generate.